aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/npm/APKBUILD6
-rw-r--r--main/npm/smoke-tests-npm-location.patch8
2 files changed, 7 insertions, 7 deletions
diff --git a/main/npm/APKBUILD b/main/npm/APKBUILD
index d658151ccab..f284bc08a28 100644
--- a/main/npm/APKBUILD
+++ b/main/npm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=npm
-pkgver=7.24.2
+pkgver=8.0.0
pkgrel=0
pkgdesc="The package manager for JavaScript"
url="https://npm.community"
@@ -113,10 +113,10 @@ doc() {
}
sha512sums="
-56a443836b7c6a39fe5f71b1a970998e1f1db9fec7ff896a5bae80aea5b9d626590a462f79b3b874653273375cbe270a597c9ea44f18694967681fa86f3133a0 npm-cli-7.24.2.tar.gz
+baf99b84ef794b95e3ae7d0aedca1b10d9383d69cd42cf7b5304737d9458988e8d40c7fcd1abccef747a27d5cfe474b1341e736ea183b0bb19f57b27cd1f75ab npm-cli-8.0.0.tar.gz
c75734fc24bf9aac9ae795f49f1145a99b82ec359a05af18531ae5a22edd1a22348faf301d9b6e3d0b68d3333df76136c17d4953ecd4f5f5efdbfb06a227a174 reproducible-documentation-build.patch
86bcf0d9883073b330dcb90ced00e8293dd011e1587791fadc14eb0c25eedfe7132626f9bfb792ae2587d335464f71b1af1183b5e6a411b04f975ff5aa06cdc7 dont-check-for-last-version.patch
0aed63f6b541378d51794393bf70b6401c7bdbc8c1ebbf35fc8b91c8220fc5ab1753f577908b0dc24bdeaf4f9cabb3bb1a48329c2ac026aba1f479d6a53311d6 make-dont-install-deps.patch
-bb0f40db679c4811531e0373cb133dc116cf0efe3e9b4619a73c6897ab440dd99c592fa4f682b72aaef311a231f5b02934b90f9aa538aadb106b49cb3f2ddd91 smoke-tests-npm-location.patch
+0ec638b7a5bc55b116f5d358055363e96d74fcfa2b3bc3b9b35e0a64551e9ce06a871faa013b00e2b3e9ad370d4f5a2be7983fb85f0d52a31bed65de99cccfb5 smoke-tests-npm-location.patch
6d0ce425061ffff1c5d7a42c9908f3382cd77abf81a9c30a62ff6fff1f0d02ff633b2bb090814aa619f7d2a51237b3da7f85d97d0f584e037639b60ccfaf0e96 npmrc
"
diff --git a/main/npm/smoke-tests-npm-location.patch b/main/npm/smoke-tests-npm-location.patch
index 79f96758fae..efc5437a262 100644
--- a/main/npm/smoke-tests-npm-location.patch
+++ b/main/npm/smoke-tests-npm-location.patch
@@ -3,16 +3,16 @@ without development dependencies involved.
--- a/smoke-tests/index.js
+++ b/smoke-tests/index.js
-@@ -29,7 +29,7 @@
+@@ -30,7 +30,7 @@
})
const localPrefix = resolve(path, 'project')
const userconfigLocation = resolve(path, '.npmrc')
--const npmLocation = resolve(__dirname, '..')
-+const npmLocation = resolve(__dirname, process.env.NPM_LOCATION || '..')
+-const npmLocation = resolve(__dirname, '../bin/npm-cli.js')
++const npmLocation = resolve(__dirname, process.env.NPM_LOCATION + '/bin/npm-cli.js' || '../bin/npm-cli.js')
const cacheLocation = resolve(path, 'cache')
const binLocation = resolve(path, 'bin')
const env = {
-@@ -57,7 +57,7 @@
+@@ -95,7 +95,7 @@
t.equal(pkg.version, '1.0.0', 'should have expected generated version')
})