aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/openscad/APKBUILD6
-rw-r--r--testing/openscad/boost-1.72.patch24
2 files changed, 28 insertions, 2 deletions
diff --git a/testing/openscad/APKBUILD b/testing/openscad/APKBUILD
index 1fafc433d54..91fc4714950 100644
--- a/testing/openscad/APKBUILD
+++ b/testing/openscad/APKBUILD
@@ -34,7 +34,8 @@ checkdepends="
xorgproto
xvfb-run
"
-source="https://files.openscad.org/openscad-$pkgver.src.tar.gz"
+source="https://files.openscad.org/openscad-$pkgver.src.tar.gz
+ boost-1.72.patch"
options="!check" # Tests fail in xvfb, but pass on real X server
build() {
@@ -56,4 +57,5 @@ package() {
make INSTALL_ROOT="$pkgdir" install
}
-sha512sums="073053f625ffa4fea6ed836396b7ff4b87b26cf7500b06c804983afc0f1dfd3d78bfb81b3fd217c3939b0ec915d85b0c7990773eaf968512a150deaa0399df13 openscad-2019.05.src.tar.gz"
+sha512sums="073053f625ffa4fea6ed836396b7ff4b87b26cf7500b06c804983afc0f1dfd3d78bfb81b3fd217c3939b0ec915d85b0c7990773eaf968512a150deaa0399df13 openscad-2019.05.src.tar.gz
+8cd01ce250975440bdc4515bd5acb13b39853b9c03b0368eea3e998752c80f57026db34ff653194461fb3e5187ff3f084943bc0ddc599bbaa100a9003ba7494a boost-1.72.patch"
diff --git a/testing/openscad/boost-1.72.patch b/testing/openscad/boost-1.72.patch
new file mode 100644
index 00000000000..eb3651f220f
--- /dev/null
+++ b/testing/openscad/boost-1.72.patch
@@ -0,0 +1,24 @@
+From b6c170cc5dd1bc677176ee732cdb0ddae57e5cf0 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Fri, 25 Oct 2019 15:10:26 +0000
+Subject: [PATCH] Add missing header bootlegged by Boost < 1.72
+
+src/parser.y:76:6: error: no template named 'stack' in namespace 'std'
+std::stack<LocalScope *> scope_stack;
+~~~~~^
+---
+ src/parser.y | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/parser.y b/src/parser.y
+index 7f4fd56ca7..4c77c989ea 100644
+--- a/src/parser.y
++++ b/src/parser.y
+@@ -46,6 +46,7 @@
+ #include "printutils.h"
+ #include "memory.h"
+ #include <sstream>
++#include <stack>
+ #include <boost/filesystem.hpp>
+ #include "boost-utils.h"
+ #include "feature.h"