aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py-rpigpio/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/community/py-rpigpio/APKBUILD b/community/py-rpigpio/APKBUILD
index cfac0a12352..a50e864f93f 100644
--- a/community/py-rpigpio/APKBUILD
+++ b/community/py-rpigpio/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py-rpigpio
_pkgname=RPi.GPIO
pkgver=0.6.3
-pkgrel=0
+pkgrel=1
pkgdesc="This package provides a class to control the GPIO on a Raspberry Pi."
url="https://pypi.python.org/pypi/RPi.GPIO"
arch="armhf"
@@ -31,19 +31,17 @@ package() {
_py2() {
replaces="$pkgname"
- depends="${depends//py-/py2-}"
_py python2
}
_py3() {
- depends="${depends//py-/py3-}"
_py python3
}
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python" ## remove if arch isn't noarch
+ depends="$depends $python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"