aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/pylint/APKBUILD40
1 files changed, 30 insertions, 10 deletions
diff --git a/testing/pylint/APKBUILD b/testing/pylint/APKBUILD
index 0bebb31dd06..e3b373eaec7 100644
--- a/testing/pylint/APKBUILD
+++ b/testing/pylint/APKBUILD
@@ -1,29 +1,49 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=pylint
-pkgver=1.4.3
+pkgver=1.6.4
pkgrel=0
pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
url="http://pypi.python.org/pypi/pylint"
arch="noarch"
license="GPL2+"
-depends="python2 py-astroid"
-depends_dev=""
-makedepends="python2-dev py-setuptools py-astroid"
-install=""
+depends="py-astroid"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$pkgname-$pkgver
+
build() {
cd "$builddir"
python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="5924c1c7ca5ca23647812f5971d0ea44 pylint-1.4.3.tar.gz"
-sha256sums="1dce8c143a5aa15e0638887c2b395e2e823223c63ebaf8d5f432a99e44b29f60 pylint-1.4.3.tar.gz"
-sha512sums="63af8c72496b88db967c61d5be2b974fca053a45425ea8b5898e941be135d26c8c004b91b8b3a98337c0c5af4f5a530afbf091d7c5ecfa36bfa36aef9f843a95 pylint-1.4.3.tar.gz"
+md5sums="66ba9c27e067568bdabcdd7c21303903 pylint-1.6.4.tar.gz"
+sha256sums="ef901a34b62ed7a734370ba5b162d890231ba8822abe88c6dda1268e2575f5f1 pylint-1.6.4.tar.gz"
+sha512sums="8252a46f8a7ff6a70f2ea10a94a9e8618a903014210cf87c061e649fbe0c2106fb1b63643605ae0ed3f4652e8ed09442f4fd32a0df11f3639e6e35128e432d51 pylint-1.6.4.tar.gz"