aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/nextcloud-client/APKBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/community/nextcloud-client/APKBUILD b/community/nextcloud-client/APKBUILD
index b9f39bad0b4..0399b53081a 100644
--- a/community/nextcloud-client/APKBUILD
+++ b/community/nextcloud-client/APKBUILD
@@ -1,22 +1,18 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=nextcloud-client
-_realname=client_theming
-pkgver=2.3.2
-pkgrel=1
+pkgver=2.3.3
+pkgrel=0
pkgdesc="Nextcloud Desktop Client"
url="https://github.com/nextcloud/client_theming"
arch="all"
license="GPL2"
-depends=
-depends_dev=
makedepends="$depends_dev cmake qt5-qttools-dev qt5-qtwebkit-dev
qt5-qtkeychain-dev"
-install=
subpackages="$pkgname-dev"
+options="!check" # no testsuite
source="owncloud-client-$pkgver.tar.gz::https://github.com/owncloud/client/archive/v$pkgver.tar.gz
- $pkgname-$pkgver.tar.gz::https://github.com/nextcloud/$_realname/archive/v$pkgver.tar.gz"
-
+ $pkgname-$pkgver.tar.gz::https://github.com/nextcloud/client_theming/archive/v$pkgver.tar.gz"
builddir="$srcdir"/client-$pkgver
build() {
@@ -28,17 +24,13 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_SYSCONFDIR=/etc/$pkgname \
-DOEM_THEME_DIR="$srcdir/$_realname-$pkgver/nextcloudtheme"
- make all || return 1
+ make all
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
-
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="33c2ae87794db3bce8293a07098f02b0b8434daf81f77d4108c7a5f55388a8b6712847b4409edd75a7b91f42a73846704302d67735fb05b923c09d021e8b3910 owncloud-client-2.3.2.tar.gz
-0447a3e5ee3338cb98b9d503a94d32c926f9092a25fee11e3686e5d662362137dce09865350cdc3c9af62ac8a6ebfa7fcd00f817edbb10189512a6df8e587628 nextcloud-client-2.3.2.tar.gz"
+sha512sums="f037987307cc0f66e7135114557b91bfae7e66ab9b3cf97d7b4f3a28de53fe651ae306a27fe01d14d6505da55eddb540b4e8ec2636c4b25f628da8d873ed2b0e owncloud-client-2.3.3.tar.gz
+fd02c61a7a92b77f9063e4f15be426be84d02033bead4b176d876134f8b85d7385e4a361959b68c332f1ccb55d43e2a8b55e0d5c8e5a54f645a5816a37790bde nextcloud-client-2.3.3.tar.gz"