aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py-django-appconf/APKBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/community/py-django-appconf/APKBUILD b/community/py-django-appconf/APKBUILD
index aeabcc44ef7..c2eb3d7f12e 100644
--- a/community/py-django-appconf/APKBUILD
+++ b/community/py-django-appconf/APKBUILD
@@ -1,34 +1,27 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=py-django-appconf
+_pkgname=django-appconf
pkgver=1.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Packaged application configuation helper for Django"
-url=http://django-appconf.readthedocs.org/
-arch=noarch
-license=BSD
+url="http://django-appconf.readthedocs.org/"
+arch="noarch"
+license="BSD"
depends="py-django py-six"
-makedepends=py-setuptools
-source="https://files.pythonhosted.org/packages/source/d/django-appconf/django-appconf-$pkgver.tar.gz"
+makedepends="py-setuptools"
+options="!check" # No test suite available
+source="https://files.pythonhosted.org/packages/source/d/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir=$srcdir/django-appconf-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py install --root "$pkgdir"
}