aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/telegram-desktop/APKBUILD39
-rw-r--r--testing/telegram-desktop/PrecompiledHeader-cmake.patch14
-rw-r--r--testing/telegram-desktop/Telegram.cmake5
-rw-r--r--testing/telegram-desktop/ThirdParty-qtlottie.cmake21
-rw-r--r--testing/telegram-desktop/sourcefiles-lottie.patch13
-rw-r--r--testing/telegram-desktop/submodule-lottie.patch13
6 files changed, 79 insertions, 26 deletions
diff --git a/testing/telegram-desktop/APKBUILD b/testing/telegram-desktop/APKBUILD
index 2d72955c3e1..b6f7a11c729 100644
--- a/testing/telegram-desktop/APKBUILD
+++ b/testing/telegram-desktop/APKBUILD
@@ -1,17 +1,18 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
# Contributor: Leo <thinkabit.ukim@gmail.com>
pkgname=telegram-desktop
-pkgver=1.7.0
+pkgver=1.7.3
# https://github.com/telegramdesktop/tdesktop/blob/v$pkgver/docs/building-cmake.md
-_libtgvoip_commit=e7010506210fbb3a6704d7ac1276b3334f9ab6c9
+_libtgvoip_commit=a19a0aff644127d8089f6a4ac18119ec5247dbd0
_GSL_commit=d846fe50a3f0bb7767c7e087a05f4be95f4da0ec
_variant_commit=550ac2f159ca883d360c196149b466955c77a573
-_crl_commit=84072fba75f14620935e5e91788ce603daeb1988
+_crl_commit=d259aebc11df52cb6ff8c738580dc4d8f245d681
+_qtlottie_commit=a3fac9db920b167a5f91d678ee7968f100f6fe51
pkgrel=0
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
url="https://desktop.telegram.org/"
-arch="all !s390x !armhf !armv7" # ARM are failing due to range-v3
+arch="all !s390x" # ARM are failing due to range-v3
license="GPL-3.0-or-later WITH OpenSSL"
depends="qt5-qtimageformats"
makedepends="cmake
@@ -33,13 +34,16 @@ makedepends="cmake
python2
xxhash-dev
range-v3-dev
- grep"
+ grep
+ rapidjson-dev
+ "
source="
$pkgname-$pkgver.tar.gz::https://github.com/telegramdesktop/tdesktop/archive/v${pkgver}.tar.gz
libtgvoip-$_libtgvoip_commit.tar.gz::https://github.com/telegramdesktop/libtgvoip/archive/${_libtgvoip_commit}.tar.gz
GSL-$_GSL_commit.tar.gz::https://github.com/Microsoft/GSL/archive/${_GSL_commit}.tar.gz
variant-$_variant_commit.tar.gz::https://github.com/mapbox/variant/archive/${_variant_commit}.tar.gz
crl-$_crl_commit.tar.gz::https://github.com/telegramdesktop/crl/archive/${_crl_commit}.tar.gz
+ qtlottie-$_qtlottie_commit.tar.gz::https://github.com/telegramdesktop/qtlottie/archive/${_qtlottie_commit}.tar.gz
musl.patch
no-gtk2.patch
no-pulse.patch
@@ -54,10 +58,14 @@ source="
ThirdParty-crl.cmake
ThirdParty-libtgvoip-webrtc.cmake
ThirdParty-libtgvoip.cmake
+ ThirdParty-qtlottie.cmake
PrecompiledHeader-cmake.patch
add-private-qt-functions.patch
fix-missing-use-of-pch.patch
- dynamic-linking-qt5.patch"
+ dynamic-linking-qt5.patch
+ sourcefiles-lottie.patch
+ submodule-lottie.patch
+ "
builddir="$srcdir/tdesktop-$pkgver"
prepare() {
@@ -65,12 +73,14 @@ prepare() {
rmdir Telegram/ThirdParty/GSL
rmdir Telegram/ThirdParty/variant
rmdir Telegram/ThirdParty/crl
+ rmdir Telegram/ThirdParty/qtlottie
# Copy fetched libraries to their appropriate locations
mv ../libtgvoip-${_libtgvoip_commit} "${builddir}"/Telegram/ThirdParty/libtgvoip
mv ../GSL-${_GSL_commit} "${builddir}"/Telegram/ThirdParty/GSL
mv ../variant-${_variant_commit} "${builddir}"/Telegram/ThirdParty/variant
mv ../crl-${_crl_commit} "${builddir}"/Telegram/ThirdParty/crl
+ mv ../qtlottie-${_qtlottie_commit} "${builddir}"/Telegram/ThirdParty/qtlottie
# Copy cmake files
mv ../Telegram.cmake "${builddir}"/Telegram/CMakeLists.txt
@@ -78,6 +88,7 @@ prepare() {
mv ../ThirdParty-libtgvoip.cmake "${builddir}"/Telegram/ThirdParty/libtgvoip/CMakeLists.txt
mv ../ThirdParty-libtgvoip-webrtc.cmake \
"${builddir}"/Telegram/ThirdParty/libtgvoip/webrtc_dsp/CMakeLists.txt
+ mv ../ThirdParty-qtlottie.cmake "${builddir}"/Telegram/ThirdParty/qtlottie/CMakeLists.txt
mkdir -p "${builddir}"/Telegram/cmake
mv ../FindBreakpad.cmake "${builddir}"/Telegram/cmake
@@ -138,11 +149,12 @@ package() {
done
}
-sha512sums="6cf66bf46483b0cfee61a1efb37361c839c24db9d572686775c60004660acd76f9c55d7293771054840f3579e48152240ae4f187dab5b5d1132bb85fb0300545 telegram-desktop-1.7.0.tar.gz
-a8ef97da8ab50fdbb166933b8e8fd7b6d7db95a95dcdcd92f6882e1f1104e283a6dece5cf4c40bd8d56738efac3e3905bb403287ede2ec2dc5ace3815df4b097 libtgvoip-e7010506210fbb3a6704d7ac1276b3334f9ab6c9.tar.gz
+sha512sums="b94fdf2e4b6d5f21a5ffe54a0c34ef15597b1335204511ab96f40caa852c8e6ed175811d839dcbb594cd5a93490f8095a71d77fceb1a03f497030c852e1559a0 telegram-desktop-1.7.3.tar.gz
+9d7826d0996d39dcaf1f56bdd418251b3bc39ebf9ec662280a01dea97deeb02b784b69de4e0421791cda7a18680d26437fbe9d0c965c13a2b0cb971a0b3f511f libtgvoip-a19a0aff644127d8089f6a4ac18119ec5247dbd0.tar.gz
83560cb0c39b6a4781e916c6081ad2728296e1b19760ca1b6426a8431fb6d7093760a882c539dd77152f5892fe081b1795af6366ea91385bb10aba6adf27170f GSL-d846fe50a3f0bb7767c7e087a05f4be95f4da0ec.tar.gz
537ce0a1731274da63a5be063311f7113c1391081e43970663a994b82a7b2e860302406c2931184789661d86343b2c60064c7014b73dc42799573f5b93bc12ff variant-550ac2f159ca883d360c196149b466955c77a573.tar.gz
-a148b62500c2c735065a0612d7168ee671e9b251b822efea90d25718fe0f0fc2abb8f4c93360d6ac38242c669a2d4349ea917cdc63564ebc4a8825fde13666fb crl-84072fba75f14620935e5e91788ce603daeb1988.tar.gz
+b2aac32e8964165dcf449ceb98dca9665ed9ababdd45c323252a8e39f08acac703dc14a17bafefc40f0a7e76a0c6eb7341a7581cc08e47d64a1f98c8cee50d29 crl-d259aebc11df52cb6ff8c738580dc4d8f245d681.tar.gz
+9385cd7072b2258d8ca1ed9932d953bbdee104833573e15a19f2a824c760cd43e79cd0713385c63fa10648d6ae3d201df080f9da0135f9b338a86ea10cc8a867 qtlottie-a3fac9db920b167a5f91d678ee7968f100f6fe51.tar.gz
fc672d8168f6b2807e596570bc57f3b89296891b5d62b8e12b38193ed4919e4eb17efd72691c4086fb0ff4383de54695a9faf9874a0727a0980ef35e5ca4bee7 musl.patch
cb01655dd097b68e89b15e6e4b1f6da10c52e8bec681eeef9807ca376283b10cb3da34acc976c790f3c8dea05acbef1ba1967612920a2e4acb3b9da79e251a0d no-gtk2.patch
90caf4e67f1fb8bcb26455553b90e35d247cbf67097508bd430f7f790aad9e2ae1646b0ea174013c87c331fb37e60633031187a24787e6a73ca73b706d741739 no-pulse.patch
@@ -150,14 +162,17 @@ cb01655dd097b68e89b15e6e4b1f6da10c52e8bec681eeef9807ca376283b10cb3da34acc976c790
3647ad5fff6326ba9c75fa98189a08c0909af8d1c2b704c8c62fd9da6603f5162af3176c37daa67eb5896bebe3814bf1fd66b9e93c78cbd9b439e472d0db4b44 ppc64le-enable-arch.patch
ce6be003220267bac5483caf8302b492e1581892bc36d35a61236ebf9f9d766b8bd2159557a1c36256aa85f461797a38bfaae57b12da7a72101b21c0b17ed653 system-wide-fonts.patch
8b75da50a8212cd7c77e497ad5a49290e2656a2e01037d179cd6270105337a9adb238814f98bdf7a3e954ce8661dc3183a7400533067f9a21e38133a6628563a FindBreakpad.cmake
-dc0a87356b3e06efc64fc9bdd27a7172454b769d2f615b15fa1f1594d51908d37127932fd1765be71d7391fe4b2c1f6a245c3893c7c0979144ba48e1bab1a38b Telegram.cmake
+2ce9f5c1d07a8d379754a79d173880c4ee75fbe1ed1e3df31053f3b588ddb1774312217869bbcf34a67f3c9de20abb963493110189cebedaf5bd0f10cc0dd48e Telegram.cmake
56aaf0e35ba1989d463ffa2699e7c0a7235168599f0720f66ff159f03541920e04e5944554b4d1b3a0893cf4581ff50ff00600b54522d24d59fa7192e4f80c0a TelegramCodegen.cmake
f6e42004d36c69497fd635f1bbd9779027fef1b44fc506cba85ff19c5e49e6b41008782ffb65d59ef4acef78dc0a671c285789ae21cb7a67a9b215c28a2c2eeb TelegramCodegenTools.cmake
4726ba77330d61f952c7e5af82454cc5536cd92634150406ea5dbc303acfd1d33093334b9b04cf06aa4adca84d97553f28b44dcc554d10af8052352f265c9505 TelegramTests.cmake
fe1a860184fc31888430d8efb5d12bcf57ef0ed7d64a9570159b906138e987e711e52ea87e3e0567bf749f0336d394aba8a7af9bae6b156c621a13f0aa301b6e ThirdParty-crl.cmake
2282dedd3d6551893674272ea1308d0c36469711ecf52d1ac2cdc719ab0560a35abc968cc903678dd4e3c2454324e18bcb897b46c597a02013c6d75a7406fffe ThirdParty-libtgvoip-webrtc.cmake
72b7e188c6787b05f68031f24d901194315243a8b8fb5c3e0c10f1e7c75554ae147810e4d47fa2a0fdf7323da07f48b1cd4a6b840cffd65af96ad9a997e4caff ThirdParty-libtgvoip.cmake
-4f6e4d73fe5774a2fe813b9424438d86e23cfb47483b9f2be56ff14bc471c6312e93549a3a712f1b4e51a0663dc6df086134f5b139536709234a31a695635677 PrecompiledHeader-cmake.patch
+237700c1903661c7949585a0181154c5916b5fb3cf64a37bf61dc30151aaa99fc3952aaf950efec3b9879ae61147f3c586c252cb33a17017da7a3712827f3d14 ThirdParty-qtlottie.cmake
+41eb47dc7733e7e865a877579dcc742b0156fe6f4ad4f97dbc885814b3cc6d115e608fa9a268f21ab7de41835cb5aa0bedda29c0b2d3f9f901edfb08ee66e220 PrecompiledHeader-cmake.patch
d7f8db23af250156b73b47ad4b1996b73643eb224c969cd1da2929eedfa23a3784ccf8a5728070f464891c621ec6f786e5da323f5bbb2a2cfba999cf80d9dec4 add-private-qt-functions.patch
6289d5a3eb224ebb05ab64e23ca3d081e617d905cec07edbba423265dc617548005eeb643ce5dfb2fcef9ac774e9f7b64150729bd894ca0e94af0e2aea9c823b fix-missing-use-of-pch.patch
-ad7f1b811b7907b24e0708c5b8f7531891e163b3edebebb159e47cbc24a9201a6ddb5f276f4d0968f84c6d928997f1e94fe9ca678b31e9aad90cdf28449ce39f dynamic-linking-qt5.patch"
+ad7f1b811b7907b24e0708c5b8f7531891e163b3edebebb159e47cbc24a9201a6ddb5f276f4d0968f84c6d928997f1e94fe9ca678b31e9aad90cdf28449ce39f dynamic-linking-qt5.patch
+3b6fabfb23ea82ae7eb42221dd07af6ad08e4ec2e4657697148159c7ebe46c3681857f16b5445b79d5b29de36101d394e2eb6b85a45145e109cfe63e14fed9b4 sourcefiles-lottie.patch
+2aafc567e7ad4c5d7b5d3ccba3ee5c6998c0f2107ca63079471379fe27e822ccbd95c4a67cbcef77fbd2b0edca1b493ed19e80d3106f1d71cbe6fd9b05f91729 submodule-lottie.patch"
diff --git a/testing/telegram-desktop/PrecompiledHeader-cmake.patch b/testing/telegram-desktop/PrecompiledHeader-cmake.patch
index d0d6bce8295..e576b372d2c 100644
--- a/testing/telegram-desktop/PrecompiledHeader-cmake.patch
+++ b/testing/telegram-desktop/PrecompiledHeader-cmake.patch
@@ -1,13 +1,5 @@
--- a/Telegram/gyp/PrecompiledHeader.cmake
+++ b/Telegram/gyp/PrecompiledHeader.cmake
-@@ -79,7 +79,6 @@ function(export_all_flags _filename _source_name_for_flags)
- endfunction()
-
- function(add_precompiled_header _target _input)
-- if(CMAKE_COMPILER_IS_GNUCXX)
- get_filename_component(_name ${_input} NAME)
- set(_pch_header "${CMAKE_CURRENT_SOURCE_DIR}/${_input}")
- set(_pch_binary_dir "${CMAKE_CURRENT_BINARY_DIR}/${_target}_pch")
@@ -112,7 +111,7 @@ function(add_precompiled_header _target _input)
set(_compiler_FLAGS "@${_pch_c_flags_file}")
add_custom_command(
@@ -26,10 +18,4 @@
DEPENDS "${_pchfile}" "${_pch_cpp_flags_file}"
IMPLICIT_DEPENDS CXX "${_pch_header}"
COMMENT "Precompiling ${_name} for ${_target} (C++)")
-@@ -161,5 +160,4 @@ function(add_precompiled_header _target _input)
- OBJECT_DEPENDS "${_object_depends}")
- endif()
- endforeach()
-- endif(CMAKE_COMPILER_IS_GNUCXX)
- endfunction()
diff --git a/testing/telegram-desktop/Telegram.cmake b/testing/telegram-desktop/Telegram.cmake
index e4e83306c49..6b0ba8c578f 100644
--- a/testing/telegram-desktop/Telegram.cmake
+++ b/testing/telegram-desktop/Telegram.cmake
@@ -53,10 +53,13 @@ list(APPEND THIRD_PARTY_INCLUDE_DIRS
${THIRD_PARTY_DIR}/emoji_suggestions
${THIRD_PARTY_DIR}/libtgvoip
${THIRD_PARTY_DIR}/variant/include
+ ${THIRD_PARTY_DIR}/qtlottie/src/imports
+ ${THIRD_PARTY_DIR}/qtlottie/src/bodymovin
)
add_subdirectory(${THIRD_PARTY_DIR}/crl)
add_subdirectory(${THIRD_PARTY_DIR}/libtgvoip)
+add_subdirectory(${THIRD_PARTY_DIR}/qtlottie)
set(TELEGRAM_SOURCES_DIR ${CMAKE_SOURCE_DIR}/SourceFiles)
set(TELEGRAM_RESOURCES_DIR ${CMAKE_SOURCE_DIR}/Resources)
@@ -102,6 +105,7 @@ file(GLOB FLAT_SOURCE_FILES
SourceFiles/storage/*.cpp
SourceFiles/storage/cache/*.cpp
SourceFiles/support/*cpp
+ SourceFiles/lottie/*cpp
${THIRD_PARTY_DIR}/emoji_suggestions/*.cpp
)
file(GLOB FLAT_EXTRA_FILES
@@ -161,6 +165,7 @@ set(TELEGRAM_LINK_LIBRARIES
xxhash
crl
tgvoip
+ qtlottie
OpenSSL::Crypto
OpenSSL::SSL
Qt5::DBus
diff --git a/testing/telegram-desktop/ThirdParty-qtlottie.cmake b/testing/telegram-desktop/ThirdParty-qtlottie.cmake
new file mode 100644
index 00000000000..97926608a67
--- /dev/null
+++ b/testing/telegram-desktop/ThirdParty-qtlottie.cmake
@@ -0,0 +1,21 @@
+project(qtlottie)
+
+find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui)
+
+foreach(__qt_module IN ITEMS QtCore QtGui)
+ list(APPEND QT_PRIVATE_INCLUDE_DIRS
+ ${QT_INCLUDE_DIR}/${__qt_module}/${Qt5_VERSION}
+ ${QT_INCLUDE_DIR}/${__qt_module}/${Qt5_VERSION}/${__qt_module}
+ )
+endforeach()
+message(STATUS "Using Qt private include directories: ${QT_PRIVATE_INCLUDE_DIRS}")
+
+file(GLOB QTLOTTIE_SOURCE_FILES
+ src/bodymovin/*.cpp
+ src/imports/rasterrenderer/*.cpp
+)
+
+add_library(${PROJECT_NAME} STATIC ${QTLOTTIE_SOURCE_FILES})
+
+target_include_directories(${PROJECT_NAME} PUBLIC src src/bodymovin ${QT_PRIVATE_INCLUDE_DIRS})
+target_link_libraries(${PROJECT_NAME} Qt5::Core Qt5::Widgets Qt5::Gui)
diff --git a/testing/telegram-desktop/sourcefiles-lottie.patch b/testing/telegram-desktop/sourcefiles-lottie.patch
new file mode 100644
index 00000000000..0fd3c1b87ae
--- /dev/null
+++ b/testing/telegram-desktop/sourcefiles-lottie.patch
@@ -0,0 +1,13 @@
+diff --git a/Telegram/SourceFiles/lottie/lottie_animation.cpp b/Telegram/SourceFiles/lottie/lottie_animation.cpp
+index cee1bf7bb..c8adfc343 100644
+--- a/Telegram/SourceFiles/lottie/lottie_animation.cpp
++++ b/Telegram/SourceFiles/lottie/lottie_animation.cpp
+@@ -15,6 +15,7 @@ https://github.com/telegramdesktop/tdesktop/blob/master/LEGAL
+ #include "logs.h"
+
+ #include <QFile>
++#include <QtDebug>
+ #include <crl/crl_async.h>
+ #include <crl/crl_on_main.h>
+
+
diff --git a/testing/telegram-desktop/submodule-lottie.patch b/testing/telegram-desktop/submodule-lottie.patch
new file mode 100644
index 00000000000..d96ab2506bd
--- /dev/null
+++ b/testing/telegram-desktop/submodule-lottie.patch
@@ -0,0 +1,13 @@
+diff --git a/Telegram/ThirdParty/qtlottie/src/bodymovin/bmbase.h b/Telegram/ThirdParty/qtlottie/src/bodymovin/bmbase.h
+index 97f5940..a4a3433 100644
+--- a/Telegram/ThirdParty/qtlottie/src/bodymovin/bmbase.h
++++ b/Telegram/ThirdParty/qtlottie/src/bodymovin/bmbase.h
+@@ -29,6 +29,7 @@
+ #pragma once
+
+ #include <QList>
++#include <QtDebug>
+ #include <functional>
+
+ namespace Lottie {
+