aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ion-shell/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/ion-shell/APKBUILD b/community/ion-shell/APKBUILD
index afa79e76216..34f362bbbe9 100644
--- a/community/ion-shell/APKBUILD
+++ b/community/ion-shell/APKBUILD
@@ -1,25 +1,29 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: omni <omni+alpine@hack.org>
pkgname=ion-shell
-pkgver=1.0.5_git20210627
-pkgrel=1
-_commit=df993477678248a62745c9c0a56c880dfd06b515
+pkgver=1.0.5_git20220727
+pkgrel=0
+_commit=fc153ac4e83d879ab70208c5452faae2e7d69b6b
pkgdesc="modern system shell with simple, yet powerful, syntax"
url="https://doc.redox-os.org/ion-manual/"
-# ppc64le: Rust SIGSEGVs when compiling
-arch="all !s390x !riscv64" # limited by cargo
+arch="all !s390x" # s390x blocked by nix crate
license="MIT"
makedepends="cargo"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
source="$pkgname-$_commit.tar.gz::https://gitlab.redox-os.org/redox-os/ion/-/archive/$_commit.tar.gz"
builddir="$srcdir/ion-$_commit"
+prepare() {
+ default_prepare
+ cargo fetch --locked
+}
+
build() {
- cargo build --release --locked
+ cargo build --release --frozen
}
check() {
- cargo test --release --locked
+ cargo test --release --frozen
}
package() {
@@ -27,5 +31,5 @@ package() {
}
sha512sums="
-a68889e1d3cbf93b142ed995c998f1758fa1bcbbb825a0c5ce353b27d00550cbd719977990a4aff3202a16e3a5aed3d9b41c06f038ad145d2628e654acf58754 ion-shell-df993477678248a62745c9c0a56c880dfd06b515.tar.gz
+d997e9666f032bbbed5adc448ad524f5367bd1825047a14204cb31a6e6535f13e452dc2806c79f8c70de60ca2af8555a3c96a25ebf705eaf37ae0005ccf7d838 ion-shell-fc153ac4e83d879ab70208c5452faae2e7d69b6b.tar.gz
"