aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/bluez/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 4b103d15a6a..e919eb0f21e 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=5.55
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -24,6 +24,7 @@ subpackages="
$pkgname-hid2hci
$pkgname-meshctl
$pkgname-obexd
+ $pkgname-plugins
$pkgname-zsh-completion:zshcomp:noarch
"
source="https://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
@@ -61,7 +62,8 @@ build() {
--enable-library \
--enable-deprecated \
--enable-hid2hci \
- --enable-mesh
+ --enable-mesh \
+ --enable-sixaxis
make
}
@@ -138,6 +140,12 @@ obexd() {
mv "$pkgdir"/usr/lib/bluetooth/obexd "$subpkgdir"/usr/lib/bluetooth
}
+plugins() {
+ pkgdesc="Bluez plugins (PS3 Sixaxis controller)"
+ cd "$builddir"
+ make DESTDIR="$subpkgdir" install-pluginLTLIBRARIES
+}
+
zshcomp() {
depends=""
pkgdesc="Zsh compltions for $pkgname"