aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/kealib/10-config-shell.patch12
-rw-r--r--testing/kealib/APKBUILD46
2 files changed, 58 insertions, 0 deletions
diff --git a/testing/kealib/10-config-shell.patch b/testing/kealib/10-config-shell.patch
new file mode 100644
index 00000000000..099fa9924f8
--- /dev/null
+++ b/testing/kealib/10-config-shell.patch
@@ -0,0 +1,12 @@
+Author: Holger Jaekel <holger.jaekel@gmx.de>
+Summary: use sh instead of bash
+----
+
+--- a/tools/kea-config.in
++++ b/tools/kea-config.in
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env bash
++#!/usr/bin/env sh
+
+ usage()
+ {
diff --git a/testing/kealib/APKBUILD b/testing/kealib/APKBUILD
new file mode 100644
index 00000000000..f6f3546e575
--- /dev/null
+++ b/testing/kealib/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
+# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
+pkgname=kealib
+pkgver=1.4.14
+pkgrel=0
+pkgdesc="KEA is an image file format that provides a full implementation of the GDAL data model"
+url="http://www.kealib.org/"
+arch="all"
+license="MIT"
+makedepends="
+ cmake
+ hdf5-dev
+ "
+subpackages="
+ $pkgname-dev
+ "
+source="
+ https://github.com/ubarsc/kealib/releases/download/kealib-$pkgver/kealib-$pkgver.tar.gz
+ 10-config-shell.patch
+ "
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ $CMAKE_CROSSOPTS
+ cmake --build build
+}
+
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+sha512sums="
+1da469fdfc95151b4c70b523727ed61ccce4223cc925254a022a12a7e32ed01769d70cab496eadd4cd7211d2769bf4ea9a04b66e25595124b64289e45e57916d kealib-1.4.14.tar.gz
+fe77138269e4b0f375d1d670fd41661784d59bf8eaaea5339bd95e669bee07ff81ca7a50798981ced7ffbd6f480e2e36801e2e580d298b864acc85b7864735c3 10-config-shell.patch
+"