aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--unmaintained/kdewebkit/APKBUILD51
-rw-r--r--unmaintained/py-application/APKBUILD27
-rw-r--r--unmaintained/py-centinel/APKBUILD41
-rw-r--r--unmaintained/py-django-compressor/APKBUILD27
-rw-r--r--unmaintained/py-embedly/APKBUILD41
-rw-r--r--unmaintained/py-flask-errormail/APKBUILD41
-rw-r--r--unmaintained/py-flask-oauth/APKBUILD41
-rw-r--r--unmaintained/py-flask-openid/APKBUILD41
-rw-r--r--unmaintained/py-flask-sqlalchemy/APKBUILD51
-rw-r--r--unmaintained/py-flask-weasyprint/APKBUILD40
-rw-r--r--unmaintained/py-gi/APKBUILD32
-rw-r--r--unmaintained/py-httreplay/APKBUILD41
-rw-r--r--unmaintained/py-imaging/APKBUILD29
-rw-r--r--unmaintained/py-ludibrio/APKBUILD41
-rw-r--r--unmaintained/py-mopidy-beets/APKBUILD40
-rw-r--r--unmaintained/py-mopidy-moped/APKBUILD40
-rw-r--r--unmaintained/py-mopidy-mopify/APKBUILD40
-rw-r--r--unmaintained/py-mopidy-spotify/APKBUILD41
-rw-r--r--unmaintained/py-mysqldb/APKBUILD28
-rw-r--r--unmaintained/py-mysqldb/mariadb.patch22
-rw-r--r--unmaintained/py-napalm/APKBUILD49
-rw-r--r--unmaintained/py-newt_syrup/APKBUILD34
-rw-r--r--unmaintained/py-pygtksourceview2/APKBUILD38
-rw-r--r--unmaintained/py-pysqlite/APKBUILD39
-rw-r--r--unmaintained/py-pywebkitgtk/APKBUILD37
-rw-r--r--unmaintained/py-sphinxcontrib-jinjadomain/APKBUILD41
-rw-r--r--unmaintained/py-sphinxcontrib-jsx/APKBUILD41
-rw-r--r--unmaintained/py-sphinxcontrib-rawfiles/APKBUILD41
-rw-r--r--unmaintained/py-stencil/APKBUILD27
-rw-r--r--unmaintained/py-turq/APKBUILD41
-rw-r--r--unmaintained/py-urlnorm/APKBUILD40
-rw-r--r--unmaintained/py-weasyprint/APKBUILD57
-rw-r--r--unmaintained/qt5-qtwebkit/0001-musl-mcontext.patch67
-rw-r--r--unmaintained/qt5-qtwebkit/0002-fix-build-with-bison3.7.patch46
-rw-r--r--unmaintained/qt5-qtwebkit/0003-fix-compilation-with-python3.9.patch27
-rw-r--r--unmaintained/qt5-qtwebkit/0004-glib-2.68.patch26
-rw-r--r--unmaintained/qt5-qtwebkit/0005-Add-support-for-RISC-V-64-bit-architecture.patch76
-rw-r--r--unmaintained/qt5-qtwebkit/APKBUILD74
-rw-r--r--unmaintained/wkhtmltopdf/APKBUILD24
39 files changed, 0 insertions, 1580 deletions
diff --git a/unmaintained/kdewebkit/APKBUILD b/unmaintained/kdewebkit/APKBUILD
deleted file mode 100644
index 298ea72229..0000000000
--- a/unmaintained/kdewebkit/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=kdewebkit
-pkgver=5.87.0
-pkgrel=0
-pkgdesc="Integration of the HTML rendering engine WebKit"
-# armhf blocked by extra-cmake-modules
-# mips64 and riscv64 blocked by qt5-qtwebkit
-# s390x blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
-url="https://community.kde.org/Frameworks"
-license="LGPL-2.1-or-later"
-depends_dev="
- kconfig-dev
- kcoreaddons-dev
- kio-dev
- kjobwidgets-dev
- kparts-dev
- kservice-dev
- kwallet-dev
- qt5-qtbase-dev
- qt5-qttools-dev
- qt5-qtwebkit-dev
- "
-makedepends="$depends_dev
- extra-cmake-modules
- "
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/portingAids/kdewebkit-$pkgver.tar.xz"
-subpackages="$pkgname-dev"
-
-build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- cmake --build build
-}
-
-check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-ff745fb1454e821bb0e5e51cd61ef553b3b3a446117f99e42cf78d8a057983ae300f95c1b6c544efc768f404b24238e4f07b761edcf183bf144b2526510e31f2 kdewebkit-5.87.0.tar.xz
-"
diff --git a/unmaintained/py-application/APKBUILD b/unmaintained/py-application/APKBUILD
deleted file mode 100644
index 7435868e5a..0000000000
--- a/unmaintained/py-application/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-application
-_pkgname=python-application
-pkgver=2.7.0
-pkgrel=0
-pkgdesc="Basic building blocks for python applications"
-url="http://pypi.python.org/pypi/python-application"
-arch="noarch"
-license="LGPL-2.0-or-later"
-depends="python2"
-makedepends="py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- python2 setup.py build
-}
-
-check() {
- python2 setup.py check
-}
-
-package() {
- python2 setup.py install --prefix=/usr --root="$pkgdir"
-}
-sha512sums="d4fd24eb904bcaab2959df6876bb0398e6cc96d3548151ddb8af1b9e1406427103721889544599c9e39aee961e44f18283e45a312875ba51d7d727e0176703b3 python-application-2.7.0.tar.gz"
diff --git a/unmaintained/py-centinel/APKBUILD b/unmaintained/py-centinel/APKBUILD
deleted file mode 100644
index ba2230423f..0000000000
--- a/unmaintained/py-centinel/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-centinel
-_pkgname=centinel
-pkgver=0.1.3
-pkgrel=0
-pkgdesc="A tool used to detect network interference and internet censorship"
-url="https://github.com/projectbismark/centinel"
-arch="noarch"
-license="MIT"
-depends="python2 py-dnspython"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="51dc7adedc5063c341a42b16ffb73d50 centinel-0.1.3.tar.gz"
-sha256sums="6cebe17a0864e0576b3eb207f29b0c72962563b29b408a5c36a75d4e7f861096 centinel-0.1.3.tar.gz"
-sha512sums="d20a4077bb416af653d8fd02b18dcb2060637d431013c26a2b3941504b01f733e259c5bcc0dec016687fea0cbc617542a7363d42c40230c0a904d16dde31e1a5 centinel-0.1.3.tar.gz"
diff --git a/unmaintained/py-django-compressor/APKBUILD b/unmaintained/py-django-compressor/APKBUILD
deleted file mode 100644
index a51abf5d33..0000000000
--- a/unmaintained/py-django-compressor/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Contributor: Kaarle Ritvanen <kunkku@alpinelinux.org>
-# Maintainer: Kaarle Ritvanen <kunkku@alpinelinux.org>
-pkgname=py-django-compressor
-_pkgname=django_compressor
-pkgver=2.2
-pkgrel=1
-pkgdesc="JavaScript and CSS compressor for Django"
-url="https://github.com/django-compressor/django-compressor"
-arch="noarch"
-license="MIT and Apache-2.0 and BSD"
-depends="py-django py-django-appconf"
-makedepends="py-setuptools"
-source="https://files.pythonhosted.org/packages/source/d/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --root "$pkgdir"
-}
-
-sha512sums="f29aabb25c6e0fc4d7b8e7963ad4289ee06cab4400da7c9c544ccc85c53d584fcd135f41afd0ab93ab85ac6e15f751ccccf53b6b914f03f564b3a2679598cfe7 django_compressor-2.2.tar.gz"
diff --git a/unmaintained/py-embedly/APKBUILD b/unmaintained/py-embedly/APKBUILD
deleted file mode 100644
index 9d89f4ee87..0000000000
--- a/unmaintained/py-embedly/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-embedly
-_pkgname=Embedly
-pkgver=0.5.0
-pkgrel=0
-pkgdesc="A Python module for Embedly"
-url="https://github.com/embedly/embedly-python"
-arch="noarch"
-license="BSD"
-depends="python2 py-httplib2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="67bfdf6496e219307ffbefef15748702 Embedly-0.5.0.tar.gz"
-sha256sums="e10bca4b5e25e8f30e93eb459921f787b08efc4004b6370a68f4c8984f6f16e1 Embedly-0.5.0.tar.gz"
-sha512sums="c85abacaa33b7897ccda79dc3746497f4eefe54bac3eef0aaa7c9120fec14ff6b7652a342303bea0667f60c2e31cb1591a22cddeff6827c87c6e2b1cc3274469 Embedly-0.5.0.tar.gz"
diff --git a/unmaintained/py-flask-errormail/APKBUILD b/unmaintained/py-flask-errormail/APKBUILD
deleted file mode 100644
index 24cbe61964..0000000000
--- a/unmaintained/py-flask-errormail/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flask-errormail
-_pkgname=Flask-ErrorMail
-pkgver=0.2.2
-pkgrel=0
-pkgdesc="Flask sending error mail extension"
-url="https://pypi.python.org/pypi/Flask-ErrorMail"
-arch="noarch"
-license="MIT"
-depends="python2 py-flask"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="4deaf797b70de3f45ce5a06270952b8a Flask-ErrorMail-0.2.2.tar.gz"
-sha256sums="e4886e5e1ef630c5b6b958856dff6f80545f5acaa2530586a00466d8a6fab41c Flask-ErrorMail-0.2.2.tar.gz"
-sha512sums="fc9fdb749cdbd7ba32ca8454709f10d6f30c98d64a0e1ff179e5f00dc0564e8506d004a95c2603e95cc39e0dc9ce666dc63c5e6b36bcb6c00f3033599f750226 Flask-ErrorMail-0.2.2.tar.gz"
diff --git a/unmaintained/py-flask-oauth/APKBUILD b/unmaintained/py-flask-oauth/APKBUILD
deleted file mode 100644
index b9636ede0a..0000000000
--- a/unmaintained/py-flask-oauth/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flask-oauth
-_pkgname=Flask-OAuth
-pkgver=0.12
-pkgrel=1
-pkgdesc="Flask OAuth extension"
-url="https://pypi.python.org/pypi/Flask-OAuth"
-arch="noarch"
-license="BSD"
-depends="python2 py-flask py-oauth2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="eea1295eb191f3d3064c61df5a10cdc1 Flask-OAuth-0.12.tar.gz"
-sha256sums="74eb646b3e0b3b63d4adc36024d163033fc6d01f32cf01f9e9b6c8b562313ec6 Flask-OAuth-0.12.tar.gz"
-sha512sums="a51f437eb0921ebedf7af8e3191eb8f7a263639046cf4cc56e2f6b0a0ebecdc3ae5322d503e1abef06d0d359666843b36d705310d4601e21c631d638a4391fb5 Flask-OAuth-0.12.tar.gz"
diff --git a/unmaintained/py-flask-openid/APKBUILD b/unmaintained/py-flask-openid/APKBUILD
deleted file mode 100644
index 1e44c369f1..0000000000
--- a/unmaintained/py-flask-openid/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flask-openid
-_pkgname=Flask-OpenID
-pkgver=1.2
-pkgrel=0
-pkgdesc="Flask OpenID extension"
-url="https://pypi.python.org/pypi/Flask-OpenID"
-arch="noarch"
-license="BSD"
-depends="python2 py-flask"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="349d497ecd0d9a37fce6a54783d7ce0f Flask-OpenID-1.2.tar.gz"
-sha256sums="e496f760bceaf5fa4f22833ec2d454ae72f675f5892ced1d3be3de11530f56a7 Flask-OpenID-1.2.tar.gz"
-sha512sums="17d24a4276ac887405b29eb3f610029d9af97e016a6d998b0942ed8b43ea7495dddffb571fbf7f26f039bcc7ef48cc155cd032878f93b591c0eb7d466e8655d2 Flask-OpenID-1.2.tar.gz"
diff --git a/unmaintained/py-flask-sqlalchemy/APKBUILD b/unmaintained/py-flask-sqlalchemy/APKBUILD
deleted file mode 100644
index 28ea869652..0000000000
--- a/unmaintained/py-flask-sqlalchemy/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname=py-flask-sqlalchemy
-pkgver=2.1
-pkgrel=2
-pkgdesc="SQLAlchemy integration for Flask"
-url="http://flask.pocoo.org/"
-arch="noarch"
-license="MIT"
-depends="py-flask py-sqlalchemy"
-depends_dev=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-flask-sqlalchemy:py2 py3-flask-sqlalchemy:py3"
-source="https://files.pythonhosted.org/packages/source/F/Flask-SQLAlchemy/Flask-SQLAlchemy-$pkgver.tar.gz"
-
-builddir="$srcdir"/Flask-SQLAlchemy-$pkgver
-
-build() {
- cd "$_builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-py2() {
- cd "$builddir"
- _py python2
-}
-
-py3() {
- cd "$builddir"
- _py python3
-}
-
-md5sums="dc15fe08b07b434d3d2c4063b4674b72 Flask-SQLAlchemy-2.1.tar.gz"
-sha256sums="c5244de44cc85d2267115624d83faef3f9e8f088756788694f305a5d5ad137c5 Flask-SQLAlchemy-2.1.tar.gz"
-sha512sums="023f3dd011a57768e921928dd3df791a54c64bb8a0cc1bb545dbb8e16dda263b730da74a0d400e5a057819830dd4cd014a642098a081c956a7ea8a2d37ec112a Flask-SQLAlchemy-2.1.tar.gz"
diff --git a/unmaintained/py-flask-weasyprint/APKBUILD b/unmaintained/py-flask-weasyprint/APKBUILD
deleted file mode 100644
index 68b4c5501f..0000000000
--- a/unmaintained/py-flask-weasyprint/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname=py-flask-weasyprint
-pkgver=0.4
-pkgrel=1
-pkgdesc="flask binding to py-weasyprint"
-url="https://pythonhosted.org/flask-weasyprint"
-arch="noarch"
-license="BSD"
-depends="python2 py-weasyprint py-flask py-setuptools"
-depends_dev=""
-makedepends="python2-dev"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/F/Flask-WeasyPrint/Flask-WeasyPrint-$pkgver.tar.gz"
-
-_builddir="$srcdir"/Flask-WeasyPrint-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="6d24da2c30f7d3feebc43f5081670884 Flask-WeasyPrint-0.4.tar.gz"
-sha256sums="ae586c52d1b465eb196fd187d52c7a09ebb6519f9db749d7082c12d1844b78dc Flask-WeasyPrint-0.4.tar.gz"
-sha512sums="941997a553f9154fcea3d4e35e2cd3ab7d5e8b19dad91ed7fb7bbad1e413d9060b272a9e452ddb42a4d698fbcc43673323ede27dc998d8a4067b52ae0a74fca7 Flask-WeasyPrint-0.4.tar.gz"
diff --git a/unmaintained/py-gi/APKBUILD b/unmaintained/py-gi/APKBUILD
deleted file mode 100644
index 499eced804..0000000000
--- a/unmaintained/py-gi/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-gi
-_pkgname=gi
-pkgver=1.2
-pkgrel=0
-pkgdesc="Command line to private gist. Example: gi.py myFile"
-url="http://github.com/inconditus/gi"
-arch="noarch"
-license="MIT"
-depends="python2"
-depends_dev=""
-makedepends="$depends_dev python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="63bdf817281813f049064133ed584a6e gi-1.2.tar.gz"
-sha256sums="13e5a3c227a8bb6fdaf22ca5b70aa81acc936955cb5d3ec10c1c8bf34b79aaea gi-1.2.tar.gz"
-sha512sums="9651f05423bfd75f1bab1fa03193fab351fbc3b675e49f233613f0e8d6d615bb4d48c31884b633b71c63eb438e669104d5baf89d509279bfaa851d0ebd3e7005 gi-1.2.tar.gz"
diff --git a/unmaintained/py-httreplay/APKBUILD b/unmaintained/py-httreplay/APKBUILD
deleted file mode 100644
index a96711e610..0000000000
--- a/unmaintained/py-httreplay/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-httreplay
-_pkgname=httreplay
-pkgver=0.1.6
-pkgrel=0
-pkgdesc="A HTTP replay library for testing"
-url="http://github.com/davepeck/httreplay"
-arch="noarch"
-license="MIT"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="1412c16295aff3862556900b77367972 httreplay-0.1.6.tar.gz"
-sha256sums="3ffd5f00cfffd4f10c0d67ffca481910b23775e70f11a2ed95e554e8f5c5b0e1 httreplay-0.1.6.tar.gz"
-sha512sums="13022180e9cbed6424a8153570177bc8a057cfe16a714050868bb343d71e1670dfccd17d29494156bda35b21156e2231b5c0d439f2953b9c5dbc0664e104b71d httreplay-0.1.6.tar.gz"
diff --git a/unmaintained/py-imaging/APKBUILD b/unmaintained/py-imaging/APKBUILD
deleted file mode 100644
index 0f8820d3ee..0000000000
--- a/unmaintained/py-imaging/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-imaging
-pkgver=1.1.7
-pkgrel=4
-pkgdesc="Python image manipulation library"
-url="https://pypi.python.org/pypi/PIL"
-arch="all"
-license="PSF"
-depends=""
-makedepends="python2-dev freetype-dev jpeg-dev zlib-dev"
-install=""
-subpackages=""
-source="http://effbot.org/downloads/Imaging-$pkgver.tar.gz"
-
-_builddir="$srcdir"/Imaging-$pkgver
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="fc14a54e1ce02a0225be8854bfba478e Imaging-1.1.7.tar.gz"
-sha256sums="895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211 Imaging-1.1.7.tar.gz"
-sha512sums="fec2d39b4db3cb33cd7e7895aba4c3a8a5d4cff28decb9106c88e392cb848edf5593fcd77d11994bb16321837fdb26958787dac2c86d6f7c09996f466bac11f1 Imaging-1.1.7.tar.gz"
diff --git a/unmaintained/py-ludibrio/APKBUILD b/unmaintained/py-ludibrio/APKBUILD
deleted file mode 100644
index ef544378bd..0000000000
--- a/unmaintained/py-ludibrio/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-ludibrio
-_pkgname=ludibrio
-pkgver=3.1.0
-pkgrel=0
-pkgdesc="A Platform for test doubles in Python"
-url="https://github.com/nsigustavo/ludibrio"
-arch="noarch"
-license="GPL"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="d83f752b7cad8baa9c6b6aa92605cab3 ludibrio-3.1.0.tar.gz"
-sha256sums="271a2a866b00a059d9330dc1213d182731121c83088a42f6b3e7f24777b522db ludibrio-3.1.0.tar.gz"
-sha512sums="7a29f30761ef376960131a04f5b6321a548a29bde0f95087bc6c7138ef50f93d1fb2ac34e8aef7bfa3d4bf852cf07e0edda5f25d3e1d53e8c9359ba4f4e65580 ludibrio-3.1.0.tar.gz"
diff --git a/unmaintained/py-mopidy-beets/APKBUILD b/unmaintained/py-mopidy-beets/APKBUILD
deleted file mode 100644
index fc81aba80c..0000000000
--- a/unmaintained/py-mopidy-beets/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-pkgname=py-mopidy-beets
-pkgver=2.0.0
-pkgrel=0
-pkgdesc="Mopidy extension for playing music from a Beets collection"
-url="http://www.mopidy.com/"
-arch="noarch"
-license="Apache"
-depends="python2 mopidy py-setuptools py-pykka py-requests"
-depends_dev=""
-makedepends="python2-dev"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/M/Mopidy-Beets/Mopidy-Beets-$pkgver.tar.gz"
-
-_builddir="$srcdir"/Mopidy-Beets-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="894b79054abad1406b3e6ce626a8e69d Mopidy-Beets-2.0.0.tar.gz"
-sha256sums="1628961a10f7c805babe048e3f6dd85062699c9fe7d18ff3ed0857b4865a3f1e Mopidy-Beets-2.0.0.tar.gz"
-sha512sums="69a8bb7590393367a1b6014b6353b5e32dabb4a3cf9e455dc314b72c9488f1e13bcd8911ce5bee8fbc09f085eeba87ee2c2bab1404b6269934c8191a15971ac0 Mopidy-Beets-2.0.0.tar.gz"
diff --git a/unmaintained/py-mopidy-moped/APKBUILD b/unmaintained/py-mopidy-moped/APKBUILD
deleted file mode 100644
index 3599ddc830..0000000000
--- a/unmaintained/py-mopidy-moped/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-pkgname=py-mopidy-moped
-pkgver=0.4.4
-pkgrel=0
-pkgdesc="Responsive Web client for Mopidy"
-url="https://github.com/martijnboland/moped"
-arch="noarch"
-license="Apache"
-depends="python2 mopidy"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/M/Mopidy-Moped/Mopidy-Moped-$pkgver.tar.gz"
-
-_builddir="$srcdir"/Mopidy-Moped-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="b9ee40e59e422348f7bbeab50fa0ce0d Mopidy-Moped-0.4.4.tar.gz"
-sha256sums="cab09486d93abf9ff158f9f4b7bdc93b9a58e64c78d409c7b612c839d62f077f Mopidy-Moped-0.4.4.tar.gz"
-sha512sums="6871ccb1794d8da375b4de550e76ab8699cf453cfb36c3f67fea57df03584136a44f218017f78535ea64a86d4c2bc7c2a6c4d512351ae0ad7802aea1c71f32b9 Mopidy-Moped-0.4.4.tar.gz"
diff --git a/unmaintained/py-mopidy-mopify/APKBUILD b/unmaintained/py-mopidy-mopify/APKBUILD
deleted file mode 100644
index ff69003f54..0000000000
--- a/unmaintained/py-mopidy-mopify/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-pkgname=py-mopidy-mopify
-pkgver=1.3.2
-pkgrel=0
-pkgdesc="a full music experience web client for Mopidy"
-url="https://github.com/martijnboland/mopidy-mopify"
-arch="noarch"
-license="Apache"
-depends="python2 mopidy"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/M/Mopidy-Mopify/Mopidy-Mopify-$pkgver.tar.gz"
-
-_builddir="$srcdir"/Mopidy-Mopify-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="62921f95197ff8902f269220b22fffdf Mopidy-Mopify-1.3.2.tar.gz"
-sha256sums="60bd41567b1d82ad03f434543b73652eb845f20c7c66fdf06eda117d41233a27 Mopidy-Mopify-1.3.2.tar.gz"
-sha512sums="b52609c1bdf6e86108a7e1ebed01a78a9d4a32c66e525698ecd2f86e3e041862337df13a20044c11138c8083ad4170fc80cb8a7daece079501cf9636bb4b4b5f Mopidy-Mopify-1.3.2.tar.gz"
diff --git a/unmaintained/py-mopidy-spotify/APKBUILD b/unmaintained/py-mopidy-spotify/APKBUILD
deleted file mode 100644
index d559801fda..0000000000
--- a/unmaintained/py-mopidy-spotify/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-pkgname=py-mopidy-spotify
-pkgver=1.2.0
-pkgrel=0
-pkgdesc="Mopidy extension for playing music from Spotify"
-url="https://github.com/mopidy/mopidy-spotify"
-arch="noarch"
-license="Apache"
-depends="python2 mopidy"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/M/Mopidy-Spotify/Mopidy-Spotify-$pkgver.tar.gz"
-
-_builddir="$srcdir"/Mopidy-Spotify-$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="03fec138e5d96e6254ecefea46561fec Mopidy-Spotify-1.2.0.tar.gz"
-sha256sums="b677f20b63a37c0dc1c7a4fa635f6c2ff853a60a65bddebfae08dc1b4cd748cc Mopidy-Spotify-1.2.0.tar.gz"
-sha512sums="1a2d9201d1c1493a9ac1d067848e15cb7d05b0141877a7ccc6b07419c63fa56632c7101a2c94edbc5f37bf64576aa5060b81d23eaab8bcd504d0be05283b93e5 Mopidy-Spotify-1.2.0.tar.gz"
diff --git a/unmaintained/py-mysqldb/APKBUILD b/unmaintained/py-mysqldb/APKBUILD
deleted file mode 100644
index d98d219ad1..0000000000
--- a/unmaintained/py-mysqldb/APKBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# Contributor: Łukasz Jendrysik <scadu@yandex.com>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-mysqldb
-pkgver=1.2.5
-pkgrel=1
-pkgdesc="MySQL database connector for Python (legacy version)"
-url="https://github.com/farcepest/MySQLdb1"
-arch="all"
-license="GPL"
-depends="python2"
-makedepends="mariadb-connector-c-dev python2-dev py-setuptools"
-source="https://files.pythonhosted.org/packages/source/M/MySQL-python/MySQL-python-$pkgver.zip
- mariadb.patch"
-
-builddir="$srcdir"/MySQL-python-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="37521c6fd855c4cde495cc8ec085aca79c2d441a6e3710759385bf2e2c17f43d3311cf1166663892829d2e3999c419443c358c7031cdda225ac44611ced188d0 MySQL-python-1.2.5.zip
-fcb15e47a1cc5faa9c6ef33826a661d2728a0bd59ee2d35f7046b5079875741574a3a80ff95f86b419fd6ae58d59fce8f391b1d0630aaec034098054683487ca mariadb.patch"
diff --git a/unmaintained/py-mysqldb/mariadb.patch b/unmaintained/py-mysqldb/mariadb.patch
deleted file mode 100644
index ed7d496f63..0000000000
--- a/unmaintained/py-mysqldb/mariadb.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/_mysql.c b/_mysql.c
-index f081346..1c434d3 100644
---- a/_mysql.c
-+++ b/_mysql.c
-@@ -40,8 +40,6 @@ PERFORMANCE OF THIS SOFTWARE.
- #include "structmember.h"
- #if defined(MS_WINDOWS)
- #include <config-win.h>
--#else
--#include "my_config.h"
- #endif
- #include "mysql.h"
- #include "mysqld_error.h"
-@@ -2002,7 +2000,7 @@ _mysql_ConnectionObject_ping(
- int r, reconnect = -1;
- if (!PyArg_ParseTuple(args, "|I", &reconnect)) return NULL;
- check_connection(self);
-- if ( reconnect != -1 ) self->connection.reconnect = reconnect;
-+ if ( reconnect != -1 ) mysql_options(&self->connection, MYSQL_OPT_RECONNECT, &reconnect);
- Py_BEGIN_ALLOW_THREADS
- r = mysql_ping(&(self->connection));
- Py_END_ALLOW_THREADS
diff --git a/unmaintained/py-napalm/APKBUILD b/unmaintained/py-napalm/APKBUILD
deleted file mode 100644
index cac905715e..0000000000
--- a/unmaintained/py-napalm/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
-pkgname=py-napalm
-pkgver=2.3.3
-pkgrel=1
-pkgdesc="Network Automation and Programmability Abstraction Layer with Multivendor support"
-url="https://github.com/napalm-automation/napalm"
-arch="noarch"
-license="Apache-2.0"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools py2-pip"
-options="!check" #no testsuite
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://github.com/napalm-automation/napalm/archive/$pkgver.tar.gz"
-builddir="$srcdir"/napalm-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py --quiet build
- python3 setup.py --quiet build
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- local pyver="${1:6:1}"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="5eb87a00da81101e8ea3d8994ebfacd2d976328dfd2b7dbc7f2d90b8a6710c97def348bddede1164534edb24e51e0de56ecc3ed92029da36be4bbb3515cfd835 py-napalm-2.3.3.tar.gz"
diff --git a/unmaintained/py-newt_syrup/APKBUILD b/unmaintained/py-newt_syrup/APKBUILD
deleted file mode 100644
index 5816a6f003..0000000000
--- a/unmaintained/py-newt_syrup/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=py-newt_syrup
-_realname=newt-syrup
-pkgver=0.2.0
-pkgrel=1
-pkgdesc="Newt Syrup is an app framework built on top of Newt"
-url="http://newt-syrup.fedorahosted.org/"
-arch="noarch"
-license="LGPL-2.0-or-later"
-depends="py-newt"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://mcpierce.fedorapeople.org/sources/newt_syrup-$pkgver.tar.gz"
-
-builddir="$srcdir"/${_realname}-RELEASE-$pkgver
-
-builddir="$srcdir"/newt_syrup-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="5707d1a33fd234c3684aad4f3ec4d448 newt_syrup-0.2.0.tar.gz"
-sha256sums="27f34eaa54540adee5cdda95bd97d2af75a7eddcc303b4c73f36917f79e157e9 newt_syrup-0.2.0.tar.gz"
-sha512sums="9b6b1807585d58aaeca0d4783b3d2d643cdf8779acb5352b24128a59ed151f917ecf91d3f1da1d42f10350e8afed13d878e713329154a94a95c181733f393006 newt_syrup-0.2.0.tar.gz"
diff --git a/unmaintained/py-pygtksourceview2/APKBUILD b/unmaintained/py-pygtksourceview2/APKBUILD
deleted file mode 100644
index f8d93dae6c..0000000000
--- a/unmaintained/py-pygtksourceview2/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-pygtksourceview2
-_pkgname=pygtksourceview
-pkgver=2.10.1
-pkgrel=1
-pkgdesc="Python bindings for gtksourceview2"
-url="https://www.gnome.org/"
-arch="all"
-license="GPL"
-depends="python2"
-makedepends="gtksourceview2-dev py-gtk-dev python2-dev py-gobject-dev py-gobject-doc"
-install=""
-subpackages="$pkgname-dev"
-source="https://download.gnome.org/sources/$_pkgname/2.10/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-prepare() {
- default_prepare
- update_config_guess
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="${pkgdir}" install
-}
-
-sha512sums="88c45e8b20e49d41ce5b692df17be9d020d77878cf67f2cd2ed64c93baca4a0619217eca4a460be7a0fedd3bd14877f97e88a82728e113cbdeb31a9e43d97450 pygtksourceview-2.10.1.tar.gz"
diff --git a/unmaintained/py-pysqlite/APKBUILD b/unmaintained/py-pysqlite/APKBUILD
deleted file mode 100644
index 73dc24efa2..0000000000
--- a/unmaintained/py-pysqlite/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
-pkgname=py-pysqlite
-_pkgname=pysqlite
-pkgver=2.8.3
-pkgrel=1
-pkgdesc="Python DB-API 2.0 interface for the SQLite"
-url="https://pypi.python.org/pypi/pysqlite"
-arch="all"
-license="MIT"
-subpackages="py2-${pkgname/py-/}:_py2"
-makedepends="python2-dev py-setuptools sqlite-dev"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
- replaces="$pkgname"
-}
-
-sha512sums="9bf378b47fe020b378a9bd749b2b27cefcf8018fbe715cca54004b36092d2202ed0bb7d8fb8bc9820ce16918e01cea8bd1f032c640d1c461bd99cdf2632b8e3e pysqlite-2.8.3.tar.gz"
diff --git a/unmaintained/py-pywebkitgtk/APKBUILD b/unmaintained/py-pywebkitgtk/APKBUILD
deleted file mode 100644
index 25d78217a0..0000000000
--- a/unmaintained/py-pywebkitgtk/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-pywebkitgtk
-_pkgname=pywebkitgtk
-pkgver=1.1.8
-pkgrel=0
-pkgdesc="Python bindings for the WebKit GTK+ port"
-url="https://code.google.com/archive/p/pywebkitgtk/"
-arch="all !ppc64le"
-license="GPL"
-depends=""
-makedepends="glib-dev py-gtk-dev python2-dev libxslt-dev webkitgtk-dev"
-install=""
-subpackages="$pkgname-dev"
-source="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-prepare() {
- default_prepare || return 1
- update_config_guess || return 1
-}
-
-build() {
- cd "$builddir"
- ./configure --prefix=/usr
- make || return 1
-
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-md5sums="158335385354ba38090c9324b37bf225 pywebkitgtk-1.1.8.tar.gz"
-sha256sums="7092212933000f23b3042135f01a371bd6a8f980c6b8d8b9dc7e20a1101d699c pywebkitgtk-1.1.8.tar.gz"
-sha512sums="18de613188f68d97be306af877b5d071758da1d08dfe4d4fa6ec275e931d9513520541747dcdcddacf5edf7e21061956ae2f3842155904c2e77c9a758e98e77f pywebkitgtk-1.1.8.tar.gz"
diff --git a/unmaintained/py-sphinxcontrib-jinjadomain/APKBUILD b/unmaintained/py-sphinxcontrib-jinjadomain/APKBUILD
deleted file mode 100644
index 614144190c..0000000000
--- a/unmaintained/py-sphinxcontrib-jinjadomain/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-jinjadomain
-_pkgname=sphinxcontrib-jinjadomain
-pkgver=0.5.1
-pkgrel=0
-pkgdesc="Sphinx jinjadomain extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-jinjadomain"
-arch="noarch"
-license="BSD"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="3303656d070a6d5c32a5a8ac0bfa9c5c sphinxcontrib-jinjadomain-0.5.1.tar.gz"
-sha256sums="7ebcdcad49c99daf3098a6ec0bbc1db9accb499f25cce28e09fef94a693aef91 sphinxcontrib-jinjadomain-0.5.1.tar.gz"
-sha512sums="ad0940a4015a1b83bb7214a5d7741c597e8248aa6ce87edcc8779796a697a015edcd2624146cb8406539dd7dbfb3808aef343a98605a296298530d9d882a48c8 sphinxcontrib-jinjadomain-0.5.1.tar.gz"
diff --git a/unmaintained/py-sphinxcontrib-jsx/APKBUILD b/unmaintained/py-sphinxcontrib-jsx/APKBUILD
deleted file mode 100644
index 1f73fb7a3e..0000000000
--- a/unmaintained/py-sphinxcontrib-jsx/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-jsx
-_pkgname=sphinxcontrib-jsx
-pkgver=0.2.0
-pkgrel=0
-pkgdesc="Sphinx JSX directive extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-jsx"
-arch="noarch"
-license="BSD"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="b29d40bea29c44b435d0d76c2a61ab5a sphinxcontrib-jsx-0.2.0.tar.gz"
-sha256sums="caa24d5025785905357357d952dd75d3d728264f8361d1812f28cb9c9afc4cf6 sphinxcontrib-jsx-0.2.0.tar.gz"
-sha512sums="e7be117cc2e42978c7d7381b313b04344998ef5ddee6831325a9bd75587860dcd13aa72080880b482fef33448980af21ad0e73d0bc5feaf36a6c294a7293aaa7 sphinxcontrib-jsx-0.2.0.tar.gz"
diff --git a/unmaintained/py-sphinxcontrib-rawfiles/APKBUILD b/unmaintained/py-sphinxcontrib-rawfiles/APKBUILD
deleted file mode 100644
index 3caf2c7e18..0000000000
--- a/unmaintained/py-sphinxcontrib-rawfiles/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-rawfiles
-_pkgname=sphinxcontrib-rawfiles
-pkgver=0.1.1
-pkgrel=0
-pkgdesc="Sphinx rawfiles extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-rawfiles"
-arch="noarch"
-license="BSD"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="959d641e41961f6f2440af4ec91cc600 sphinxcontrib-rawfiles-0.1.1.tar.gz"
-sha256sums="a68bb1e215b03bf18de1a9d69ca345abebfcdca25a5e1a183be4c22389857766 sphinxcontrib-rawfiles-0.1.1.tar.gz"
-sha512sums="d0af06e2c9da1281c7a9b1825b58c666b221e7b803855e30200a663e8a54255d575eb84b050966c60302ee3397cb202550fd42351df87dc9a8f2c8db2f444aee sphinxcontrib-rawfiles-0.1.1.tar.gz"
diff --git a/unmaintained/py-stencil/APKBUILD b/unmaintained/py-stencil/APKBUILD
deleted file mode 100644
index 1f03fc6d18..0000000000
--- a/unmaintained/py-stencil/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-stencil
-_pkgname=Stencil
-pkgver=0.2.1
-pkgrel=1
-pkgdesc="A Python module to creates files and directories from templates"
-url="https://github.com/trilan/stencil"
-arch="noarch"
-license="BSD"
-depends="python2"
-makedepends="python2-dev py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="18d42d8b30141a55074ea8c6dcd0d07bcdd65f3effe7eef2fa525b6580e3cef30a28ee22a61c94432316a898ed2fe6408c12279be9e8c82108ea220bf79b549c Stencil-0.2.1.tar.gz"
diff --git a/unmaintained/py-turq/APKBUILD b/unmaintained/py-turq/APKBUILD
deleted file mode 100644
index 8838c03f17..0000000000
--- a/unmaintained/py-turq/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-turq
-_pkgname=turq
-pkgver=0.2.0
-pkgrel=0
-pkgdesc="A Mock HTTP server"
-url="https://github.com/vfaronov/turq"
-arch="noarch"
-license="BSD"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="c739aea2604898f4dff135e8bc201f83 turq-0.2.0.tar.gz"
-sha256sums="645c967303d18ff54c628b23656c0df87b35e0fed8a4492c1b341eaba09118e7 turq-0.2.0.tar.gz"
-sha512sums="2de69a9c34f20e0e91c2d2f28c6aea45dde121b55d4954ec84de1a56b22ce7a05c89faa5415385e6e51bafa496be313a61f73f53696ff2321f9f5e9da8747ebe turq-0.2.0.tar.gz"
diff --git a/unmaintained/py-urlnorm/APKBUILD b/unmaintained/py-urlnorm/APKBUILD
deleted file mode 100644
index 27a7b5866e..0000000000
--- a/unmaintained/py-urlnorm/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Maintainer:
-pkgname=py-urlnorm
-_pkgname=${pkgname#py-}
-pkgver=1.1.2
-pkgrel=1
-pkgdesc="Normalize a URL to a standard unicode encoding"
-url="https://pypi.python.org/pypi/urlnorm"
-arch="noarch"
-license="MIT"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="e6544d41a4e992296ee8895873b472bf urlnorm-1.1.2.tar.gz"
-sha256sums="944b366eef37b5c99bcff10e1d1ae7f30cfeffb1eb4af16b1906d9127f467ab2 urlnorm-1.1.2.tar.gz"
-sha512sums="9cd8c5ca208518322b79eacca6db40101a6b0444f49665d42841edf890054713ef4c44a82cba3153bb7f268c5f3e3786c1524730af47c748887bb21c0d12e01c urlnorm-1.1.2.tar.gz"
diff --git a/unmaintained/py-weasyprint/APKBUILD b/unmaintained/py-weasyprint/APKBUILD
deleted file mode 100644
index 364466c78e..0000000000
--- a/unmaintained/py-weasyprint/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname=py-weasyprint
-_pkgname=WeasyPrint
-pkgver=0.42.3
-pkgrel=0
-pkgdesc="cairo-based HTML renderer for python"
-url="http://weasyprint.org"
-arch="noarch"
-license="LGPL"
-depends="pango cairo py-cairocffi py-cairosvg py-cssselect py-tinycss py-pyphen py-lxml"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-makedepends="python2-dev python3-dev py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-prepare() {
- cp -r "$builddir" "$builddir"-py3
-}
-
-build() {
- cd "$builddir"
- python2 setup.py build
- cd "$builddir"-py3
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 setup.py check
- cd "$builddir"-py3
- python3 setup.py check
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- cd "$builddir"
- _py python2
-}
-
-_py3() {
- cd "$builddir"-py3
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="d6007934c301904308bd4821626d6a7bb504268c5c71a31f7486faebb3dd649fad18774737cab39eb13a0916635bb58eba2c8432c72cc5a461cea2a5d874b1ee WeasyPrint-0.42.3.tar.gz"
diff --git a/unmaintained/qt5-qtwebkit/0001-musl-mcontext.patch b/unmaintained/qt5-qtwebkit/0001-musl-mcontext.patch
deleted file mode 100644
index 20100ca6e7..0000000000
--- a/unmaintained/qt5-qtwebkit/0001-musl-mcontext.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff --git a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-index 883914fd3d1..9c0209ad2f3 100644
---- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-+++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-@@ -683,7 +683,19 @@ void* MachineThreads::Thread::Registers::framePointer() const
- #endif
-
- #else
--#error Need a way to get the frame pointer for another thread on this platform
-+
-+// The following sequence depends on musl libc's sys/ucontext.h.
-+#if CPU(X86)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_EBP]);
-+#elif CPU(X86_64)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_RBP]);
-+#elif CPU(ARM)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.arm_fp);
-+#elif CPU(ARM64)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.regs[29]);
-+#elif CPU(MIPS)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[30]);
-+#endif
- #endif
- }
-
-@@ -765,7 +777,19 @@ void* MachineThreads::Thread::Registers::instructionPointer() const
- #endif
-
- #else
--#error Need a way to get the instruction pointer for another thread on this platform
-+
-+// The following sequence depends on musl libc's sys/ucontext.h.
-+#if CPU(X86)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_EIP]);
-+#elif CPU(X86_64)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_RIP]);
-+#elif CPU(ARM)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.arm_pc);
-+#elif CPU(ARM64)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.pc);
-+#elif CPU(MIPS)
-+ return reinterpret_cast<void *>((uintptr_t)regs.machineContext.pc);
-+#endif
- #endif
- }
- void* MachineThreads::Thread::Registers::llintPC() const
-@@ -856,7 +880,19 @@ void* MachineThreads::Thread::Registers::llintPC() const
- #endif
-
- #else
--#error Need a way to get the LLIntPC for another thread on this platform
-+
-+// The following sequence depends on musl libc's sys/ucontext.h.
-+#if CPU(X86)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_ESI]);
-+#elif CPU(X86_64)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_R8]);
-+#elif CPU(ARM)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.arm_r8);
-+#elif CPU(ARM64)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.regs[4]);
-+#elif CPU(MIPS)
-+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[12]);
-+#endif
- #endif
- }
- #endif // ENABLE(SAMPLING_PROFILER)
diff --git a/unmaintained/qt5-qtwebkit/0002-fix-build-with-bison3.7.patch b/unmaintained/qt5-qtwebkit/0002-fix-build-with-bison3.7.patch
deleted file mode 100644
index de3bbcfc3e..0000000000
--- a/unmaintained/qt5-qtwebkit/0002-fix-build-with-bison3.7.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From d92b11fea65364fefa700249bd3340e0cd4c5b31 Mon Sep 17 00:00:00 2001
-From: Dmitry Shachnev <mitya57@gmail.com>
-Date: Tue, 4 Aug 2020 21:04:06 +0300
-Subject: [PATCH] Let Bison generate the header directly, to fix build with
- Bison 3.7
-
-Starting with Bison 3.7, the generated C++ file #include's the header
-by default, instead of duplicating it. So we should not delete it.
-
-Remove the code to add #ifdef guards to the header, since Bison adds
-them itself since version 2.6.3.
----
- Source/WebCore/css/makegrammar.pl | 21 +--------------------
- 1 file changed, 1 insertion(+), 20 deletions(-)
-
-diff --git a/Source/WebCore/css/makegrammar.pl b/Source/WebCore/css/makegrammar.pl
-index 5d63b08102eb..9435701c7061 100644
---- a/Source/WebCore/css/makegrammar.pl
-+++ b/Source/WebCore/css/makegrammar.pl
-@@ -73,25 +73,6 @@
- }
-
- my $fileBase = File::Spec->join($outputDir, $filename);
--my @bisonCommand = ($bison, "-d", "-p", $symbolsPrefix, $grammarFilePath, "-o", "$fileBase.cpp");
-+my @bisonCommand = ($bison, "--defines=$fileBase.h", "-p", $symbolsPrefix, $grammarFilePath, "-o", "$fileBase.cpp");
- push @bisonCommand, "--no-lines" if $^O eq "MSWin32"; # Work around bug in bison >= 3.0 on Windows where it puts backslashes into #line directives.
- system(@bisonCommand) == 0 or die;
--
--open HEADER, ">$fileBase.h" or die;
--print HEADER << "EOF";
--#ifndef CSSGRAMMAR_H
--#define CSSGRAMMAR_H
--EOF
--
--open HPP, "<$fileBase.cpp.h" or open HPP, "<$fileBase.hpp" or die;
--while (<HPP>) {
-- print HEADER;
--}
--close HPP;
--
--print HEADER "#endif\n";
--close HEADER;
--
--unlink("$fileBase.cpp.h");
--unlink("$fileBase.hpp");
--
diff --git a/unmaintained/qt5-qtwebkit/0003-fix-compilation-with-python3.9.patch b/unmaintained/qt5-qtwebkit/0003-fix-compilation-with-python3.9.patch
deleted file mode 100644
index bad26ef543..0000000000
--- a/unmaintained/qt5-qtwebkit/0003-fix-compilation-with-python3.9.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 78360c01c796b6260bf828bc9c8a0ef73c5132fd Mon Sep 17 00:00:00 2001
-From: Konstantin Tokarev <annulen@yandex.ru>
-Date: Wed, 3 Jun 2020 15:01:42 +0300
-Subject: [PATCH] Fix compilation with Python 3.9: avoid passing encoding to
- json.load()
-
-In Python 2.7 UTF-8 is assumed by default, while in Python 3 this argument
-is not supported.
-
-Change-Id: Ic459d60a6b20bc1838d8771bc36ac41614fe61a9
----
- Source/JavaScriptCore/generate-bytecode-files | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Source/JavaScriptCore/generate-bytecode-files b/Source/JavaScriptCore/generate-bytecode-files
-index c5dab429c7b0f..af3431275ecf9 100644
---- a/Source/JavaScriptCore/generate-bytecode-files
-+++ b/Source/JavaScriptCore/generate-bytecode-files
-@@ -163,7 +163,7 @@ if __name__ == "__main__":
- initBytecodesFile = openOrExit(initASMFileName, "w")
-
- try:
-- bytecodeSections = json.load(bytecodeFile, encoding = "utf-8")
-+ bytecodeSections = json.load(bytecodeFile)
- except:
- print("Unexpected error parsing {0}: {1}".format(bytecodeJSONFile, sys.exc_info()))
-
diff --git a/unmaintained/qt5-qtwebkit/0004-glib-2.68.patch b/unmaintained/qt5-qtwebkit/0004-glib-2.68.patch
deleted file mode 100644
index 3df6078963..0000000000
--- a/unmaintained/qt5-qtwebkit/0004-glib-2.68.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 5b698ba3faffd4e198a45be9fe74f53307395e4b Mon Sep 17 00:00:00 2001
-From: Fabian Vogt <fvogt@suse.de>
-Date: Wed, 7 Apr 2021 13:38:09 +0200
-Subject: [PATCH] Remove invalid g_object declarations to fix build with glib
- >= 2.68
-
-g_object_ref_sink is defined as a macro meanwhile and so the build fails.
-Just remove the declarations, glib.h is included anyway.
----
- Source/WTF/wtf/glib/GRefPtr.h | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/Source/WTF/wtf/glib/GRefPtr.h b/Source/WTF/wtf/glib/GRefPtr.h
-index 06133d82cb35..d9a1d2f145f5 100644
---- a/Source/WTF/wtf/glib/GRefPtr.h
-+++ b/Source/WTF/wtf/glib/GRefPtr.h
-@@ -29,9 +29,6 @@
- #include <algorithm>
- #include <glib.h>
-
--extern "C" void g_object_unref(gpointer);
--extern "C" gpointer g_object_ref_sink(gpointer);
--
- namespace WTF {
-
- enum GRefPtrAdoptType { GRefPtrAdopt };
diff --git a/unmaintained/qt5-qtwebkit/0005-Add-support-for-RISC-V-64-bit-architecture.patch b/unmaintained/qt5-qtwebkit/0005-Add-support-for-RISC-V-64-bit-architecture.patch
deleted file mode 100644
index 2fb1643cd5..0000000000
--- a/unmaintained/qt5-qtwebkit/0005-Add-support-for-RISC-V-64-bit-architecture.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From 5f98212a18ac3893b8178abb88cbf2b946ccb518 Mon Sep 17 00:00:00 2001
-From: Dmitry Shachnev <mitya57@gmail.com>
-Date: Tue, 14 Apr 2020 13:51:37 +0300
-Subject: [PATCH] Add support for RISC-V 64-bit architecture
-
----
- CMakeLists.txt | 2 ++
- Source/JavaScriptCore/CMakeLists.txt | 1 +
- Source/WTF/wtf/Platform.h | 8 +++++++-
- Source/WTF/wtf/dtoa/utils.h | 2 +-
- 4 files changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 432ae6fce701..eaf3a35dfd5b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -83,6 +83,8 @@ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "s390")
- set(WTF_CPU_S390 1)
- elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "s390x")
- set(WTF_CPU_S390X 1)
-+elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "riscv64")
-+ set(WTF_CPU_RISCV64 1)
- else ()
- message(FATAL_ERROR "Unknown CPU '${LOWERCASE_CMAKE_SYSTEM_PROCESSOR}'")
- endif ()
-diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
-index afd76ca1a184..3d184090dce7 100644
---- a/Source/JavaScriptCore/CMakeLists.txt
-+++ b/Source/JavaScriptCore/CMakeLists.txt
-@@ -1287,6 +1287,7 @@ elseif (WTF_CPU_S390)
- elseif (WTF_CPU_S390X)
- elseif (WTF_CPU_MIPS)
- elseif (WTF_CPU_SH4)
-+elseif (WTF_CPU_RISCV64)
- elseif (WTF_CPU_X86)
- elseif (WTF_CPU_X86_64)
- if (MSVC AND ENABLE_JIT)
-diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
-index 5717f3ea1664..7aefa1bab50d 100644
---- a/Source/WTF/wtf/Platform.h
-+++ b/Source/WTF/wtf/Platform.h
-@@ -176,6 +176,11 @@
- #define WTF_CPU_X86_SSE2 1
- #endif
-
-+/* CPU(RISCV64) - RISCV64 */
-+#if defined(__riscv) && defined(__riscv_xlen) && __riscv_xlen == 64
-+#define WTF_CPU_RISCV64 1
-+#endif
-+
- /* CPU(ARM64) - Apple */
- #if (defined(__arm64__) && defined(__APPLE__)) || defined(__aarch64__)
- #define WTF_CPU_ARM64 1
-@@ -707,7 +712,8 @@
- || CPU(S390X) \
- || CPU(MIPS64) \
- || CPU(PPC64) \
-- || CPU(PPC64LE)
-+ || CPU(PPC64LE) \
-+ || CPU(RISCV64)
- #define USE_JSVALUE64 1
- #else
- #define USE_JSVALUE32_64 1
-diff --git a/Source/WTF/wtf/dtoa/utils.h b/Source/WTF/wtf/dtoa/utils.h
-index 889642cee722..176d5909f7d3 100644
---- a/Source/WTF/wtf/dtoa/utils.h
-+++ b/Source/WTF/wtf/dtoa/utils.h
-@@ -49,7 +49,7 @@
- defined(__ARMEL__) || \
- defined(_MIPS_ARCH_MIPS32R2)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
--#elif CPU(MIPS) || CPU(MIPS64) || CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(SH4) || CPU(S390) || CPU(S390X) || CPU(IA64) || CPU(ALPHA) || CPU(ARM64) || CPU(HPPA)
-+#elif CPU(MIPS) || CPU(MIPS64) || CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(SH4) || CPU(S390) || CPU(S390X) || CPU(IA64) || CPU(ALPHA) || CPU(ARM64) || CPU(HPPA) || CPU(RISCV64)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
- #elif defined(_M_IX86) || defined(__i386__)
- #if defined(_WIN32)
diff --git a/unmaintained/qt5-qtwebkit/APKBUILD b/unmaintained/qt5-qtwebkit/APKBUILD
deleted file mode 100644
index 692b44ed65..0000000000
--- a/unmaintained/qt5-qtwebkit/APKBUILD
+++ /dev/null
@@ -1,74 +0,0 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=qt5-qtwebkit
-pkgver=5.212.0_alpha4
-_pkgver=${pkgver/_/-}
-pkgrel=14
-pkgdesc="Qt5 - QtWebKit components"
-url="https://www.qt.io/developers/"
-# armhf blocked by qt5-qtdeclarative
-# mips64 and riscv64 disabled, build failure in JavascriptCore due to lack of JIT
-arch="all !armhf !mips64 !riscv64"
-license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
-depends_dev="
- qt5-qtbase-dev
- qt5-qtlocation-dev
- qt5-qtsensors-dev
- qt5-qtwebchannel-dev
- hyphen-dev
- libjpeg-turbo-dev
- icu-dev
- libxml2-dev
- libxslt-dev
- libxcomposite-dev
- libxrender-dev
- gst-plugins-base-dev
- libwebp-dev
- libexecinfo-dev
- "
-makedepends="$depends_dev
- cmake
- bison
- flex
- gperf
- ruby
- "
-subpackages="$pkgname-dev"
-
-source="https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz
- 0001-musl-mcontext.patch
- 0002-fix-build-with-bison3.7.patch
- 0003-fix-compilation-with-python3.9.patch
- 0004-glib-2.68.patch
- 0005-Add-support-for-RISC-V-64-bit-architecture.patch
- "
-builddir="$srcdir/qtwebkit-$_pkgver"
-
-build() {
- case "$CARCH" in
- ppc64le|s390x) _jit=FALSE ;;
- *) _jit=TRUE ;;
- esac
-
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DPORT=Qt \
- -DENABLE_JIT=$_jit
- make -C build
-}
-
-package() {
- DESTDIR="$pkgdir" make -C build install
-
- install -d "$pkgdir"/usr/share/licenses
- ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
-}
-
-sha512sums="
-33f11270bd030599beff9c1983a6c5ff2d61f407cc8a6825f7f405d46f9184c720fc7f60c7359f08f828db96a2170092875066a0d5c0a21ff09bc48a2603fbf6 qtwebkit-5.212.0-alpha4.tar.xz
-11f6b4b5101f5e89917062483c0d55c4180dc4b8107bb3f6ad92ed4e56361ef1b604909056b383313c4072b1229dc9f6606ceacdd84efc1dc80dd1151294b195 0001-musl-mcontext.patch
-cf21eff51e1026f4e506724a512b9925d4619909f5924bf01055244817ec9594e9d3ce105b510cd28ecce4772d122d1393fb7273501e20e16749f43282a3200b 0002-fix-build-with-bison3.7.patch
-e4d4d4abfb8f2e9913c2f5cb7b3a73d5c613a8e8ced66ae1a7789faaa83a2bdf89ff29955d7e9b7bd7a0935ca2ddcad796cf371882e2bb38b4e69c1d528cfe75 0003-fix-compilation-with-python3.9.patch
-f8a49e24023431ac37cff2b5bdf6f88d632021eb777668404956a4c6e4f8744f256205093dc5077325a33ec2a050b6e159dcf5d8cf3c1dda7d26ec0b37db95c3 0004-glib-2.68.patch
-096d567349584070781b7382c75f530fa1f34930281a5f58bdd5e7bb4281f613eb0d1d4e6d356a7e8b93529d742a12814723ec592f0e50f9b2b4829d5156f361 0005-Add-support-for-RISC-V-64-bit-architecture.patch
-"
diff --git a/unmaintained/wkhtmltopdf/APKBUILD b/unmaintained/wkhtmltopdf/APKBUILD
deleted file mode 100644
index 574edb1568..0000000000
--- a/unmaintained/wkhtmltopdf/APKBUILD
+++ /dev/null
@@ -1,24 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=wkhtmltopdf
-pkgver=0.12.6
-pkgrel=0
-pkgdesc="Simple shell utility to convert html to pdf"
-url="https://wkhtmltopdf.org/"
-# armhf, mips64 and riscv64 blocked by qt5-qtwebkit
-arch="all !armhf !mips64 !riscv64"
-license="LGPL-3.0-or-later"
-makedepends="qt5-qtbase-dev qt5-qtwebkit-dev qt5-qtsvg-dev
- qt5-qtxmlpatterns-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/wkhtmltopdf/wkhtmltopdf/archive/$pkgver.tar.gz"
-options="!check" # no test suite
-
-build() {
- qmake-qt5 -makefile && make
-}
-
-package() {
- make install INSTALL_ROOT="$pkgdir"/usr
-}
-
-sha512sums="616f51a9094ae91339ca9b6228ee15a67e4092117d087124e2966d3aa53d1caa27f729a40df4e1f2c95149bea86c9b6f184ce9930f9025728d2cdfe6c94a2fbb wkhtmltopdf-0.12.6.tar.gz"