aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/berry/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/berry/APKBUILD b/testing/berry/APKBUILD
new file mode 100644
index 00000000000..fb1b50286da
--- /dev/null
+++ b/testing/berry/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+pkgname=berry
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="a healthy, byte-sized window manager"
+url="https://berrywm.org/"
+arch="all"
+license="MIT"
+makedepends="libx11-dev libxft-dev libxinerama-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/JLErvin/berry/archive/$pkgver.tar.gz"
+options="!check" #test files only for man
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR=$pkgdir PREFIX=/usr MANPREFIX=/usr/share/man install
+}
+
+sha512sums="093a605513affa119a8e772401bff8473623d8ed320729fec5f615b4a66959451ba9cb07a51bb5bc6857b795694d9f7c0f7b5b89611d2654a284a3f24866ee08 berry-0.1.6.tar.gz"