aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/strace/APKBUILD10
-rw-r--r--main/strace/fix-ppc-pt-regs-collision.patch21
-rw-r--r--main/strace/s390-fix-SIGNAL_FRAMESIZE-macro.patch83
3 files changed, 14 insertions, 100 deletions
diff --git a/main/strace/APKBUILD b/main/strace/APKBUILD
index 3bc7826b71b..f1df34eafb3 100644
--- a/main/strace/APKBUILD
+++ b/main/strace/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=strace
-pkgver=4.26
+pkgver=5.2
pkgrel=0
pkgdesc="Diagnostic, debugging and instructional userspace tracer"
url="https://strace.io"
@@ -15,7 +15,6 @@ source="https://github.com/strace/strace/releases/download/v$pkgver/$pkgname-$pk
disable-fortify.patch
fix-ppc-pt-regs-collision.patch
nlattr-fix.patch
- s390-fix-SIGNAL_FRAMESIZE-macro.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -47,8 +46,7 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="cce153246802fcdb1547bc11164784066101a2e672e2a264cb742593b559e579aa4bedc749d87fdd1fc2045f4f79b54d419bb50c823074d2cca6f3c75ccf2290 strace-4.26.tar.xz
+sha512sums="41bea20215fa80ad90a5d49c41944e02774e715efda5e563b3714e5800933a5fca4a2392634193cf49c0752321a39e0c185bdbc9cfb8ee053b09a6bd5723da35 strace-5.2.tar.xz
273b92ebf0069f19bef7ec26c7860e2af7ef01e782255c70ded1ae5e967f8f6bf031ecba96612c6083bf58f46278ba4ab3ec0fb35b08c8c8d668191f97adee52 disable-fortify.patch
-b70cee89dd49a2b5a69dc2a56c3a11169d3306e1a73981155188b574486965c034aa52b4ac1c6edff5ef55c9d52f27750acb242fac095a8a9f69689b51b3fad1 fix-ppc-pt-regs-collision.patch
-44b1872cf996caa4970fa6c2875a3a2cffe4a38455e328d968bd7855ef9a05cf41190794dc137bc8667576635f5271057cf0e6cde9a6c7aee66afd1dba9bdba0 nlattr-fix.patch
-3cbc2dab39e65f18177bd1d33e1174eb8a00ad3f5972ca7ae4a7b50c31ef90860fe053ee26f3bded4d03628bdaae7b2faca8f13b4ad1f220c3892575f79cbac1 s390-fix-SIGNAL_FRAMESIZE-macro.patch"
+c5ba64a0e4686aeee5ceef099f1bedfef15fc79636249f168352ee10eb87bd788006d9a361e2b3819381bd1810c8b2bfda73b765c9781386737e19b6a037e93f fix-ppc-pt-regs-collision.patch
+44b1872cf996caa4970fa6c2875a3a2cffe4a38455e328d968bd7855ef9a05cf41190794dc137bc8667576635f5271057cf0e6cde9a6c7aee66afd1dba9bdba0 nlattr-fix.patch"
diff --git a/main/strace/fix-ppc-pt-regs-collision.patch b/main/strace/fix-ppc-pt-regs-collision.patch
index 6de0fcdd6f3..08058647987 100644
--- a/main/strace/fix-ppc-pt-regs-collision.patch
+++ b/main/strace/fix-ppc-pt-regs-collision.patch
@@ -1,19 +1,18 @@
---- a/ptrace.h
-+++ b/ptrace.h
-@@ -48,7 +48,15 @@
- # define ptrace_peeksiginfo_args XXX_ptrace_peeksiginfo_args
- #endif
+diff -upr strace-5.2.orig/ptrace.h strace-5.2/ptrace.h
+--- strace-5.2.orig/ptrace.h 2019-07-17 00:19:07.262775301 +0200
++++ strace-5.2/ptrace.h 2019-07-17 00:19:55.422778666 +0200
+@@ -30,7 +30,14 @@
+ # define ptrace_peeksiginfo_args XXX_ptrace_peeksiginfo_args
+ # endif
--#include <linux/ptrace.h>
+#if defined(__powerpc__) || defined(__powerpc64__)
+# include <linux/types.h>
+# define __ASSEMBLY__
-+# include <linux/ptrace.h>
+ # include <linux/ptrace.h>
+# undef __ASSEMBLY__
-+#else
++#else
+# include <linux/ptrace.h>
+#endif
-+
- #ifdef HAVE_STRUCT_IA64_FPREG
- # undef ia64_fpreg
+ # ifdef HAVE_STRUCT_IA64_FPREG
+ # undef ia64_fpreg
diff --git a/main/strace/s390-fix-SIGNAL_FRAMESIZE-macro.patch b/main/strace/s390-fix-SIGNAL_FRAMESIZE-macro.patch
deleted file mode 100644
index bf89e411c5a..00000000000
--- a/main/strace/s390-fix-SIGNAL_FRAMESIZE-macro.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From 6d2ed715191752850b4907496c13cca72e98bfe5 Mon Sep 17 00:00:00 2001
-From: Tuan Hoang <tmhoang@linux.ibm.com>
-Date: Thu, 14 Mar 2019 10:18:22 +0100
-Subject: [PATCH] s390: fix SIGNAL_FRAMESIZE macro
-
-Since __SIGNAL_FRAMESIZE is in private name space, it is better not to
-use it directly. This macro has been stable on s390/s390x so it is safe
-to use the integer value.
-
-* linux/s390/arch_sigreturn.c [!SIGNAL_FRAMESIZE] (SIGNAL_FRAMESIZE):
-Define to 96.
-* linux/s390x/arch_sigreturn.c (arch_sigreturn == s390_arch_sigreturn):
-Remove S390_SIGNAL_FRAMESIZE and SIGNAL_FRAMESIZE.
-(arch_sigreturn == s390x_arch_sigreturn): Define SIGNAL_FRAMESIZE.
-* linux/s390/rt_sigframe.h (SIGNAL_FRAMESIZE): Define.
-(struct_rt_sigframe): Replace __SIGNAL_FRAMESIZE with SIGNAL_FRAMESIZE.
-
-Signed-off-by: Tuan Hoang <tmhoang@linux.ibm.com>
-Co-Authored-by: Dmitry V. Levin <ldv@altlinux.org>
----
- linux/s390/arch_sigreturn.c | 2 +-
- linux/s390/rt_sigframe.h | 8 +++++++-
- linux/s390x/arch_sigreturn.c | 4 +---
- 3 files changed, 9 insertions(+), 5 deletions(-)
-
-diff --git a/linux/s390/arch_sigreturn.c b/linux/s390/arch_sigreturn.c
-index 1d0f0e00..4a9ca8ec 100644
---- a/linux/s390/arch_sigreturn.c
-+++ b/linux/s390/arch_sigreturn.c
-@@ -6,7 +6,7 @@
- */
-
- #ifndef SIGNAL_FRAMESIZE
--# define SIGNAL_FRAMESIZE __SIGNAL_FRAMESIZE
-+# define SIGNAL_FRAMESIZE 96
- #endif
- #ifndef PTR_TYPE
- # define PTR_TYPE unsigned long
-diff --git a/linux/s390/rt_sigframe.h b/linux/s390/rt_sigframe.h
-index e11573a4..51819b7b 100644
---- a/linux/s390/rt_sigframe.h
-+++ b/linux/s390/rt_sigframe.h
-@@ -10,8 +10,14 @@
-
- # include <signal.h>
-
-+#ifdef __s390x__
-+# define SIGNAL_FRAMESIZE 160
-+#else /* __s390__ */
-+# define SIGNAL_FRAMESIZE 96
-+#endif
-+
- typedef struct {
-- uint8_t callee_used_stack[__SIGNAL_FRAMESIZE];
-+ uint8_t callee_used_stack[SIGNAL_FRAMESIZE];
- uint16_t svc_insn;
- siginfo_t info;
- ucontext_t uc;
-diff --git a/linux/s390x/arch_sigreturn.c b/linux/s390x/arch_sigreturn.c
-index 55930a35..2d75a8c6 100644
---- a/linux/s390x/arch_sigreturn.c
-+++ b/linux/s390x/arch_sigreturn.c
-@@ -7,9 +7,6 @@
-
- #include <stdint.h>
-
--#define S390_SIGNAL_FRAMESIZE 96
--
--#define SIGNAL_FRAMESIZE S390_SIGNAL_FRAMESIZE
- #define PTR_TYPE uint32_t
- #define arch_sigreturn s390_arch_sigreturn
- #include "s390/arch_sigreturn.c"
-@@ -17,6 +14,7 @@
- #undef PTR_TYPE
- #undef SIGNAL_FRAMESIZE
-
-+#define SIGNAL_FRAMESIZE 160
- #define arch_sigreturn s390x_arch_sigreturn
- #include "s390/arch_sigreturn.c"
- #undef arch_sigreturn
---
-2.20.1
-