aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/mkinitfs/0001-Import-the-pool-without-mounting-any-file-systems.patch25
-rw-r--r--main/mkinitfs/APKBUILD11
2 files changed, 4 insertions, 32 deletions
diff --git a/main/mkinitfs/0001-Import-the-pool-without-mounting-any-file-systems.patch b/main/mkinitfs/0001-Import-the-pool-without-mounting-any-file-systems.patch
deleted file mode 100644
index 94973c06d8b..00000000000
--- a/main/mkinitfs/0001-Import-the-pool-without-mounting-any-file-systems.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f24ac9d0b0f797becdb976477be0d509aef7778b Mon Sep 17 00:00:00 2001
-From: omni <omni@omni.omni>
-Date: Wed, 13 Jan 2021 03:34:31 +0000
-Subject: [PATCH] Import the pool without mounting any file systems.
-
----
- nlplug-findfs.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/nlplug-findfs.c b/nlplug-findfs.c
-index 1ede4ca..f43c295 100644
---- a/nlplug-findfs.c
-+++ b/nlplug-findfs.c
-@@ -509,7 +509,7 @@ static void start_lvm2(char *devnode)
-
- static void start_zpool(char *uuid) {
- char *zpool_argv[] = {
-- ZPOOL_PATH, "import", uuid,
-+ ZPOOL_PATH, "import", "-N", uuid,
- NULL
- };
- if (use_zpool && uuid)
---
-2.30.0
-
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 47a0ed6128b..3fdf88a9b96 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
-pkgver=3.5.0_rc1
+pkgver=3.5.0
# shellcheck disable=SC2034 # used for git versions, keep around for next time
_ver=${pkgver%_git*}
-pkgrel=2
+pkgrel=0
pkgdesc="Tool to generate initramfs images for Alpine"
url="https://gitlab.alpinelinux.org/alpine/mkinitfs"
arch="all"
@@ -16,10 +16,8 @@ depends="busybox>=1.28.2-r1 apk-tools>=2.9.1 lddtree>=1.25 kmod"
subpackages="$pkgname-doc"
install="$pkgname.pre-upgrade $pkgname.post-install $pkgname.post-upgrade"
triggers="$pkgname.trigger=/usr/share/kernel/*"
-source="https://gitlab.alpinelinux.org/alpine/mkinitfs/-/archive/v$pkgver/mkinitfs-v$pkgver.tar.gz
- 0001-Import-the-pool-without-mounting-any-file-systems.patch
+source="https://gitlab.alpinelinux.org/alpine/mkinitfs/-/archive/$pkgver/mkinitfs-$pkgver.tar.gz
"
-builddir="$srcdir"/mkinitfs-v$pkgver
build() {
make VERSION=$pkgver-r$pkgrel
@@ -29,5 +27,4 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="99cfc7ba0a45f2ed033d36ce3a755d29e0f7325b12156f173b7aa238eeec8424e229400694f865928e5f8d36a42687693a6aaca99c80f08e15cf591cb5a5baa5 mkinitfs-v3.5.0_rc1.tar.gz
-1cae07259fa4715663cdbdf59ed809b6d3d862153412b9e07f5f72cb624efd5a8b5b591b9e562f81e9a39b5b0b489468992c5162621c24053e148de28dba7614 0001-Import-the-pool-without-mounting-any-file-systems.patch"
+sha512sums="bf6ab3c31f771702aa6d3b2f8f46a51126f347def3b1b620e4badb2ed4a2aa60311e4c930cb244ed899da79f0ae38c22f770872a850197f208a84ef31683c16b mkinitfs-3.5.0.tar.gz"