aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/perl-test-without-module/APKBUILD32
1 files changed, 12 insertions, 20 deletions
diff --git a/main/perl-test-without-module/APKBUILD b/main/perl-test-without-module/APKBUILD
index fe93f157353..dfb06ec3049 100644
--- a/main/perl-test-without-module/APKBUILD
+++ b/main/perl-test-without-module/APKBUILD
@@ -1,41 +1,33 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-test-without-module
_pkgreal="Test-Without-Module"
-pkgver=0.18
+pkgver=0.20
pkgrel=0
pkgdesc="Test::Without::Module perl module"
url="http://search.cpan.org"
arch="noarch"
license="GPL or Artistic"
-depends=""
makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/C/CO/CORION/Test-Without-Module-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgreal-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+builddir="$srcdir"/$_pkgreal-$pkgver
+
+check() {
+ cd "$builddir"
+ make test
}
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="cd19ad26024e89fdfefb0ae0334ee500 Test-Without-Module-0.18.tar.gz"
-sha256sums="e2c3360b171d7db518ac39a0e1dcb285c784ea393c11708914a0655d66138c7f Test-Without-Module-0.18.tar.gz"
-sha512sums="005ad54ac77283cf3155befe77fdb887dbc2ebc9c154472a23982636bbe7728154f56fdf1990b833639cd687b38e4d62250edd6dd93d37408e971bb4bd49c4c2 Test-Without-Module-0.18.tar.gz"
+sha512sums="e92353cee46e712ddc6515c5872a61a84eb4186f9ce736bbf0fcca2979bfa7143588c05e683d31fc22cbaaa792ce8364768310f9de621e881cc207b80cf14d87 Test-Without-Module-0.20.tar.gz"