aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/neatvi/APKBUILD37
-rw-r--r--testing/neatvi/conf.patch10
2 files changed, 47 insertions, 0 deletions
diff --git a/testing/neatvi/APKBUILD b/testing/neatvi/APKBUILD
new file mode 100644
index 00000000000..acb1624224b
--- /dev/null
+++ b/testing/neatvi/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alex Raschi <raschi.alex@gmail.com>
+pkgname=neatvi
+pkgver=06
+pkgrel=0
+pkgdesc="vi/ex editor with support for bidirectional UTF-8 text, syntax highlight and infinite undo/redo"
+url="https://github.com/aligrudi/neatvi"
+arch="all"
+license="ISC" # vi.c
+subpackages="$pkgname-doc"
+options="!check" # no test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/aligrudi/$pkgname/archive/$pkgver.tar.gz
+ conf.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
+}
+
+package() {
+ local pkgbin="$pkgdir"/usr/bin
+ cd "$builddir"
+ mkdir -p "$pkgbin"
+ mv vi "$pkgbin"/neatvi
+}
+
+doc() {
+ local pkgdoc="$subpkgdir"/usr/share/doc/"$pkgname"
+ cd "$builddir"
+ mkdir -p "$pkgdoc"
+ mv README "$pkgdoc"
+
+ default_doc
+}
+
+sha512sums="ff5850fc736afb33f57bcf738fc6eab346785caa5eff81fac567248eb0bede973731ca1791651d73d0157df170b6f07df3cd05ee4d8a6eb2090d51f92460d2b9 neatvi-06.tar.gz
+d5538cf2bfb98b93d3661f686540580f754cd5fca641893b58cf80312ec703aa332601f68258335a71bdeb72356148a75db22ae139e05c04c060cfcb31f2fafd conf.patch"
diff --git a/testing/neatvi/conf.patch b/testing/neatvi/conf.patch
new file mode 100644
index 00000000000..1fdc92ddee1
--- /dev/null
+++ b/testing/neatvi/conf.patch
@@ -0,0 +1,10 @@
+--- a/conf.h.orig 2017-10-01 09:07:44.000000000 +0200
++++ b/conf.h 2018-11-20 18:54:51.484850964 +0100
+@@ -12,6 +12,7 @@ static struct filetype {
+ {"mk", "Makefile$|makefile$|\\.mk$"}, /* makefile */
+ {"sh", "\\.sh$"}, /* shell script */
+ {"nm", "\\.nm$"}, /* neatmail */
++ {"sh", ".$"}, /* everything else */
+ };
+
+ /* syntax highlighting patterns */