aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/icecast/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/main/icecast/APKBUILD b/main/icecast/APKBUILD
index 5fa0f17a009..0e43153f1ca 100644
--- a/main/icecast/APKBUILD
+++ b/main/icecast/APKBUILD
@@ -1,13 +1,9 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-#
-# secfixes:
-# 2.4.4-r0:
-# - CVE-2018-18820
pkgname=icecast
pkgver=2.4.4
-pkgrel=1
+pkgrel=2
pkgdesc="Open source media server"
url="http://www.icecast.org"
arch="all"
@@ -17,14 +13,16 @@ pkgusers="icecast"
pkggroups="icecast"
makedepends="libxslt-dev libxml2-dev libogg-dev libvorbis-dev libtheora-dev openssl-dev curl-dev"
subpackages="$pkgname-doc $pkgname-openrc"
-source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+source="http://downloads.xiph.org/releases/icecast/icecast-$pkgver.tar.gz
conf-change-owner.patch
icecast.initd
icecast.confd"
-builddir="$srcdir"/$pkgname-$pkgver
+# secfixes:
+# 2.4.4-r0:
+# - CVE-2018-18820
+
build() {
- cd $builddir
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,16 +36,14 @@ build() {
}
check() {
- cd $builddir
make check
}
package() {
- cd $builddir
make DESTDIR="$pkgdir" install
- install -D -m755 ../icecast.initd "$pkgdir"/etc/init.d/icecast
- install -D -m755 ../icecast.confd "$pkgdir"/etc/conf.d/icecast
- install -d -D -o icecast -g icecast "$pkgdir"/var/log/icecast
+ install -Dm755 "$srcdir"/icecast.initd "$pkgdir"/etc/init.d/icecast
+ install -Dm644 "$srcdir"/icecast.confd "$pkgdir"/etc/conf.d/icecast
+ install -d -o icecast -g icecast "$pkgdir"/var/log/icecast
}
sha512sums="e9ffb478cac2570891787455591d881a59185e067bb36f51706a7070cd9d82d80425ec8cf151f5ebb17d1b75654449fc760f8b82a1bb05f020b47ec09e46b4d0 icecast-2.4.4.tar.gz