aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/stoken/APKBUILD (renamed from testing/stoken/APKBUILD)13
1 files changed, 4 insertions, 9 deletions
diff --git a/testing/stoken/APKBUILD b/community/stoken/APKBUILD
index 96cf18a16c6..9ef7431f728 100644
--- a/testing/stoken/APKBUILD
+++ b/community/stoken/APKBUILD
@@ -2,24 +2,21 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=stoken
pkgver=0.92
-pkgrel=2
+pkgrel=3
pkgdesc="RSA SecurID-compatible software token for Linux/UNIX systems"
-url="http://stoken.sf.net"
+url="https://github.com/cernekee/stoken"
arch="all"
license="LGPL-2.1-or-later"
makedepends="autoconf automake libtool libxml2-dev nettle-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cernekee/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cernekee/stoken/archive/v$pkgver.tar.gz"
prepare() {
default_prepare
- cd "$builddir"
./autogen.sh
}
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--datadir=/usr/share \
@@ -28,16 +25,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR=$pkgdir install
}
-dev(){
+dev() {
default_dev
cd "$builddir"
rm "$subpkgdir"/usr/share/doc/stoken/*