aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/unit/APKBUILD8
-rw-r--r--community/unit/Python-fixing-build-for-Python-3.8.patch42
2 files changed, 3 insertions, 47 deletions
diff --git a/community/unit/APKBUILD b/community/unit/APKBUILD
index 9c0efa7c051..db033ae73a7 100644
--- a/community/unit/APKBUILD
+++ b/community/unit/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=unit
-pkgver=1.12.0
-pkgrel=1
+pkgver=1.14.0
+pkgrel=0
pkgdesc="NGINX Unit is a dynamic web application server"
url="https://unit.nginx.org/"
arch="all"
@@ -13,7 +13,6 @@ makedepends="perl-dev php$_phpver-dev php$_phpver-embed python3-dev ruby-dev"
install="$pkgname.pre-install"
subpackages="$pkgname-openrc"
source="https://unit.nginx.org/download/unit-$pkgver.tar.gz
- Python-fixing-build-for-Python-3.8.patch
$pkgname.initd
$pkgname.confd
$pkgname.logrotate"
@@ -77,8 +76,7 @@ _module() {
make $modname-install DESTDIR="$subpkgdir"
}
-sha512sums="a55a084ed6e1cd3f784bd81571772ca29ca9a0d19089c9bb74c88258d2e1ef872978219c47b6dc2610711ae1aa95ef68ddb77f45747a2eacdd9d92c6f8fee28b unit-1.12.0.tar.gz
-e9741cceacf9cb1cfbc8788ce4b6abc4145dc36c28e06ade42e77367d0ef668f4773a483f5b68d109788631f19e34b36ea049f5475abef1160b35e75a851e06c Python-fixing-build-for-Python-3.8.patch
+sha512sums="0cfe5364d427ff09d08c3b1b134827665f8bf70b8871f3c4506680e4c2d61249a53581122c42276b590f5eb077c398ae6a6c2fa46f24c680844b7d365f2ca66b unit-1.14.0.tar.gz
a835b83284d7bd4afb445dd93c84e2c6dd5906f137784ff3189edc82c3f14f07c5de00681125924138e3ac420cc849cc93e52cabbd6b550ded09d055d30e091c unit.initd
f85112726dfcace2b6d94b10669615fef517f5aa10ac858890dd9f5c868a6e2569500f7411f758fcb24c98c9630760d36a74bd33ea510ab0f8ca8cd6cb1fb1e8 unit.confd
723e465162dfdb31881680200221542add414e54ef4f4f1fc57e91b7b57777dfb21c2eee4727ecbba0c1943bb77a2597cc0225b16e334c38258c296d15b1df74 unit.logrotate"
diff --git a/community/unit/Python-fixing-build-for-Python-3.8.patch b/community/unit/Python-fixing-build-for-Python-3.8.patch
deleted file mode 100644
index 1af001661a3..00000000000
--- a/community/unit/Python-fixing-build-for-Python-3.8.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From e54f5f3dc8ec281bbc17e4092d168ea32ae099d7 Mon Sep 17 00:00:00 2001
-From: Max Romanov <max.romanov@nginx.com>
-Date: Tue, 22 Oct 2019 16:04:30 +0300
-Subject: [PATCH] Python: fixing build for Python 3.8.
-
-Thanks to tonyafanasyev.
-This is related to #331 issue on GitHub.
----
- auto/modules/python | 4 ++++
- src/nxt_python_wsgi.c | 4 ++++
- 2 files changed, 8 insertions(+)
-
-diff --git a/auto/modules/python b/auto/modules/python
-index abd145c9..ecf8802a 100644
---- a/auto/modules/python
-+++ b/auto/modules/python
-@@ -64,6 +64,10 @@ nxt_found=no
-
- if /bin/sh -c "$NXT_PYTHON_CONFIG --prefix" >> $NXT_AUTOCONF_ERR 2>&1; then
-
-+ if ${NXT_PYTHON_CONFIG} --embed 2>/dev/null; then
-+ NXT_PYTHON_CONFIG="${NXT_PYTHON_CONFIG} --embed"
-+ fi
-+
- NXT_PYTHON_INCLUDE=`${NXT_PYTHON_CONFIG} --includes`
- NXT_PYTHON_LIBS=`${NXT_PYTHON_CONFIG} --ldflags`
-
-diff --git a/src/nxt_python_wsgi.c b/src/nxt_python_wsgi.c
-index a6d5f217..977c2998 100644
---- a/src/nxt_python_wsgi.c
-+++ b/src/nxt_python_wsgi.c
-@@ -179,6 +179,10 @@ static PyTypeObject nxt_py_input_type = {
- #if PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION > 3
- 0, /* tp_finalize */
- #endif
-+#if PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION >= 8
-+ 0, /* tp_vectorcall */
-+ 0, /* tp_print */
-+#endif
- };
-
-