aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libfm-qt/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libfm-qt/APKBUILD b/testing/libfm-qt/APKBUILD
new file mode 100644
index 00000000000..534cfa83e27
--- /dev/null
+++ b/testing/libfm-qt/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=libfm-qt
+pkgver=0.16.0
+pkgrel=0
+pkgdesc="Qt port of libfm"
+url="https://github.com/lxqt/libfm-qt"
+arch="all !s390x" # s390x blocked by libfm
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake lxqt-build-tools qt5-qtx11extras-dev qt5-qttools-dev
+ menu-cache-dev libexif-dev libfm-dev qt5-qtbase-dev
+ "
+subpackages="$pkgname-dev"
+options="!check" # No testsuite
+source="https://github.com/lxqt/libfm-qt/releases/download/$pkgver/libfm-qt-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+sha512sums="5de63408a641b0e77cb319952e428aee9cd35db9ec3e6726a8327ebc53f5641cf66b28dbabd96797c64a253b1e41421dbe05dcb9f4bc7941bd92676bbfa9cc84 libfm-qt-0.16.0.tar.xz"