aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/eom/APKBUILD16
-rw-r--r--community/eom/install-sh.patch10
2 files changed, 5 insertions, 21 deletions
diff --git a/community/eom/APKBUILD b/community/eom/APKBUILD
index d5d90e0da54..1200ce9cdac 100644
--- a/community/eom/APKBUILD
+++ b/community/eom/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=eom
-pkgver=1.22.0
+pkgver=1.22.1
pkgrel=0
pkgdesc="A simple graphics viewer for the MATE"
url="https://github.com/mate-desktop/eom"
@@ -9,34 +9,28 @@ arch="all"
license="GPL-2.0"
depends="mate-icon-theme libxml2-utils"
makedepends="glib-dev gtk+3.0-dev itstool mate-desktop-dev
- libexif-dev lcms2-dev dconf-dev dbus-dev librsvg-dev
+ libexif-dev lcms2-dev dconf-dev dbus-dev librsvg-dev
libxslt-dev libpeas-dev dbus-glib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz
- install-sh.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--sysconfdir=/etc \
- --enable-static=no \
+ --disable-static \
--disable-schemas-compile \
--prefix=/usr
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="${pkgdir}" install
}
-sha512sums="1e086d1e2a0adc02978ffb45a4636e9b614a52d53a7a821af4050029f3fa3a774c29c2d43b5f2e0c58a100311eccc34e9424caf44e7e2139b4fa8d695b77cea0 eom-1.22.0.tar.xz
-2220612dcda2f992ce6e7d8225c3d012497ff297921c24d40853553783c6b0f95c8e25ab0ad3454931e6e104a9951892972c045e4b9e2672cbbe34cd5a0936f3 install-sh.patch"
+sha512sums="f510de62b9b6f11d02df067128042d6905484e0509a939b7919405d0c1dd03fe4b6735dcd8ccf780d36c5713f4585b50b2727645a454da148307a74cf542be87 eom-1.22.1.tar.xz"
diff --git a/community/eom/install-sh.patch b/community/eom/install-sh.patch
deleted file mode 100644
index d32f681c0e4..00000000000
--- a/community/eom/install-sh.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/install-sh b/install-sh
-index defb86a..8175c64 100755
---- a/install-sh
-+++ b/install-sh
-@@ -1,4 +1,4 @@
--#!/usr/bin/sh
-+#!/bin/sh
- # install - install a program, script, or datafile
-
- scriptversion=2018-03-11.20; # UTC