aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/liblockfile/APKBUILD32
1 files changed, 9 insertions, 23 deletions
diff --git a/main/liblockfile/APKBUILD b/main/liblockfile/APKBUILD
index 6e1be9e9ee4..d5ab481357c 100644
--- a/main/liblockfile/APKBUILD
+++ b/main/liblockfile/APKBUILD
@@ -1,44 +1,30 @@
# Contributor: Duane Hughes <duanejevon@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=liblockfile
-pkgver=1.09
+pkgver=1.14
pkgrel=0
pkgdesc="Shared library with NFS-safe locking functions"
url="http://packages.debian.org/sid/liblockfile1"
arch="all"
license="GPL"
-depends=""
-makedepends=
-install=
+options="!check" # upstream does not provide tests
subpackages="$pkgname-dev $pkgname-doc"
source="http://ftp.debian.org/debian/pool/main/libl/liblockfile/${pkgname}_$pkgver.orig.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
+builddir="$srcdir/$pkgname"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- || return 1
- make -j1 || return 1
+ --sysconfdir=/etc
+ make -j1
}
package() {
- cd "$_builddir"
-
- install -d "$pkgdir"/usr/include
- install -d "$pkgdir"/usr/bin
- install -d "$pkgdir"/usr/lib
- install -d "$pkgdir"/usr/share/man
-
- make -j1 ROOT="$pkgdir" install
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
}
-md5sums="2aa269e4405ee8235ff17d1b357c6ae8 liblockfile_1.09.orig.tar.gz"
-sha256sums="16979eba05396365e1d6af7100431ae9d32f9bc063930d1de66298a0695f1b7f liblockfile_1.09.orig.tar.gz"
-sha512sums="8577f8bfa9c78983d6a409bc449be0d981e599a6a5f2fc8b43f76a238810ec5e3c180e27280719398f31041ed837fe8ba61df208ce77db77a354453e4579848a liblockfile_1.09.orig.tar.gz"
+sha512sums="d6d75a1ddb55bae8ee63bd0cbacf7ab8cd6d28b29a7d3c2e4a5c31c76c6743ed517cdebd42e3ef5c44698faebfd1537b023510c692b54a1275e7114605fe6550 liblockfile_1.14.orig.tar.gz"