aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/alkimia/APKBUILD6
-rw-r--r--community/bluedevil/APKBUILD2
-rw-r--r--community/choqok/APKBUILD35
-rw-r--r--community/dolphin-plugins/APKBUILD6
-rw-r--r--community/elisa/APKBUILD2
-rw-r--r--community/kalarm/APKBUILD4
-rw-r--r--community/kanagram/APKBUILD4
-rw-r--r--community/kbounce/APKBUILD4
-rw-r--r--community/kde-cli-tools/APKBUILD2
-rw-r--r--community/kde-gtk-config/APKBUILD2
-rw-r--r--community/kdenetwork-filesharing/APKBUILD4
-rw-r--r--community/kdeplasma-addons/APKBUILD4
-rw-r--r--community/kdesdk-thumbnailers/APKBUILD15
-rw-r--r--community/kdewebkit/APKBUILD25
-rw-r--r--community/kfind/APKBUILD16
-rw-r--r--community/kget/APKBUILD42
-rw-r--r--community/kgpg/APKBUILD34
-rw-r--r--community/kile/APKBUILD35
-rw-r--r--community/kinfocenter/APKBUILD4
-rw-r--r--community/kio-fuse/APKBUILD4
-rw-r--r--community/kio-gdrive/APKBUILD6
-rw-r--r--community/kmail/APKBUILD4
-rw-r--r--community/koko/APKBUILD2
-rw-r--r--community/kolf/APKBUILD24
-rw-r--r--community/kpat/APKBUILD6
-rw-r--r--community/ktorrent/APKBUILD6
-rw-r--r--community/kturtle/APKBUILD19
-rw-r--r--community/kwalletmanager/APKBUILD30
-rw-r--r--community/kwin-effect-xrdesktop/APKBUILD2
-rw-r--r--community/mycroft-gui/APKBUILD4
-rw-r--r--community/oxygen/APKBUILD3
-rw-r--r--community/plasma-pa/APKBUILD2
-rw-r--r--community/plasma-phone-components/APKBUILD2
-rw-r--r--community/plasma-sdk/APKBUILD3
-rw-r--r--community/powerdevil/APKBUILD2
-rw-r--r--community/qt5-qtwebview/APKBUILD6
-rw-r--r--community/sddm-kcm/APKBUILD4
-rw-r--r--community/skanlite/APKBUILD2
-rw-r--r--community/sweeper/APKBUILD23
39 files changed, 308 insertions, 92 deletions
diff --git a/community/alkimia/APKBUILD b/community/alkimia/APKBUILD
index 2516020de1..fe36110af9 100644
--- a/community/alkimia/APKBUILD
+++ b/community/alkimia/APKBUILD
@@ -4,9 +4,9 @@ pkgname=alkimia
pkgver=8.1.0
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# mips blocked by qt5-qtwebkit-dev
-# armhf, mips64, s390x and riscv64 blocked by kio
-arch="all !armhf !mips !mips64 !s390x !riscv64"
+# mips64 blocked by qt5-qtwebkit-dev
+# mips64, s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !mips64 !s390x !riscv64"
url="https://community.kde.org/Alkimia/libalkimia"
pkgdesc="A library with common classes and functionality used by finance applications for the KDE SC"
license="GPL-3.0-or-later"
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
index ec77668322..42886c2bc7 100644
--- a/community/bluedevil/APKBUILD
+++ b/community/bluedevil/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
# armhf blocked by qt5-qtdeclarative
-# armhf, s390x, mips64 and riscv64 blocked by kio, kiconthemes
+# armhf, s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
diff --git a/community/choqok/APKBUILD b/community/choqok/APKBUILD
index 7fce618c75..3284a02ae5 100644
--- a/community/choqok/APKBUILD
+++ b/community/choqok/APKBUILD
@@ -5,13 +5,34 @@ pkgver=1.7.0
pkgrel=1
pkgdesc="A micro-blogging client"
url="https://choqok.kde.org/"
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
license="GPL-2.0-only OR GPL-3.0-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtnetworkauth-dev
- kconfigwidgets-dev kcoreaddons-dev kdoctools-dev ki18n-dev kemoticons-dev
- kglobalaccel-dev kguiaddons-dev kcmutils-dev kio-dev knotifications-dev
- knotifyconfig-dev sonnet-dev ktextwidgets-dev kwallet-dev kwidgetsaddons-dev
- kxmlgui-dev purpose-dev qca-dev kparts-dev"
+makedepends="
+ extra-cmake-modules
+ kcmutils-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kdoctools-dev
+ kemoticons-dev
+ kglobalaccel-dev
+ kguiaddons-dev
+ ki18n-dev
+ kio-dev
+ knotifications-dev
+ knotifyconfig-dev
+ kparts-dev
+ ktextwidgets-dev
+ kwallet-dev
+ kwidgetsaddons-dev
+ kxmlgui-dev
+ purpose-dev
+ qca-dev
+ qt5-qtbase-dev
+ qt5-qtnetworkauth-dev
+ sonnet-dev
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/choqok/${pkgver%.*}/src/choqok-$pkgver.tar.xz"
@@ -29,7 +50,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
mkdir -p "$pkgdir"/usr/lib
mv "$pkgdir"/usr/share/cmake "$pkgdir"/usr/lib
diff --git a/community/dolphin-plugins/APKBUILD b/community/dolphin-plugins/APKBUILD
index e489ce2d86..0d72f81870 100644
--- a/community/dolphin-plugins/APKBUILD
+++ b/community/dolphin-plugins/APKBUILD
@@ -5,7 +5,9 @@ pkgver=21.04.2
pkgrel=0
url="https://www.kde.org/applications/system/dolphin/"
pkgdesc="Extra Dolphin plugins"
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by dolphin
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
license="GPL-2.0-or-later"
makedepends="
dolphin-dev
@@ -35,7 +37,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/elisa/APKBUILD b/community/elisa/APKBUILD
index 838a8ac87b..01eef23ff9 100644
--- a/community/elisa/APKBUILD
+++ b/community/elisa/APKBUILD
@@ -4,7 +4,7 @@ pkgname=elisa
pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# armh, s390x, mips64 and riscv64 blocked by kio, vlc
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/multimedia/org.kde.elisa"
pkgdesc="A simple music player aiming to provide a nice experience for its users"
diff --git a/community/kalarm/APKBUILD b/community/kalarm/APKBUILD
index 3ee1faf7e6..48837f3039 100644
--- a/community/kalarm/APKBUILD
+++ b/community/kalarm/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kalarm
pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by kmailtransport
-arch="all !armhf !ppc64le !s390x !mips !mips64 !riscv64"
+# ppc64le, s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Personal alarm scheduler"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kanagram/APKBUILD b/community/kanagram/APKBUILD
index 6172f10c49..970a365819 100644
--- a/community/kanagram/APKBUILD
+++ b/community/kanagram/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kanagram
pkgver=21.04.2
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# armhf, s390x, mips64 and riscv64 blocked by kio
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://edu.kde.org/kanagram/"
pkgdesc="Letter Order Game"
@@ -43,7 +43,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kbounce/APKBUILD b/community/kbounce/APKBUILD
index 24791ad089..76e7657e20 100644
--- a/community/kbounce/APKBUILD
+++ b/community/kbounce/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kbounce
pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# armhf, mips64, s390x and riscv64 blocked by kio, kconfigwidgets
+# mips64, s390x and riscv64 blocked by polkit -> kio
arch="all !armhf !mips64 !s390x !riscv64"
url="https://kde.org/applications/games/kbounce/"
pkgdesc="A single player arcade game with the elements of puzzle"
@@ -43,7 +43,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kde-cli-tools/APKBUILD b/community/kde-cli-tools/APKBUILD
index 0c78918255..a96a6bd5fd 100644
--- a/community/kde-cli-tools/APKBUILD
+++ b/community/kde-cli-tools/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Tools based on KDE Frameworks 5 to better interact with the system"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by libksysguard
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://invent.kde.org/plasma/kde-cli-tools"
license="(GPL-2.0-only OR GPL-3.0-only) AND GPL-2.0-or-later AND GPL-2.0-only AND LGPL-2.1-only"
diff --git a/community/kde-gtk-config/APKBUILD b/community/kde-gtk-config/APKBUILD
index fa6807d07f..15896806fe 100644
--- a/community/kde-gtk-config/APKBUILD
+++ b/community/kde-gtk-config/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="GTK2 and GTK3 Configurator for KDE"
# armhf blocked by qt5-qtdeclarative
-# armhf, s390x, mips64, riscv64 blocked by kio, kcmutils
+# s390x, mips64, riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://invent.kde.org/plasma/kde-gtk-config"
license="GPL-2.0 AND LGPL-2.1-only OR LGPL-3.0-only"
diff --git a/community/kdenetwork-filesharing/APKBUILD b/community/kdenetwork-filesharing/APKBUILD
index 1baaa3bb5e..c3be25bda9 100644
--- a/community/kdenetwork-filesharing/APKBUILD
+++ b/community/kdenetwork-filesharing/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kdenetwork-filesharing
pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# armhf, s390x, mips64 and riscv64 blocked by kio
+# armhf, s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://www.kde.org/applications/internet/"
pkgdesc="Properties dialog plugin to share a directory with the local network"
@@ -40,7 +40,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kdeplasma-addons/APKBUILD b/community/kdeplasma-addons/APKBUILD
index 7122f6f6a7..4b16e9e497 100644
--- a/community/kdeplasma-addons/APKBUILD
+++ b/community/kdeplasma-addons/APKBUILD
@@ -4,9 +4,9 @@ pkgname=kdeplasma-addons
pkgver=5.22.2.1
pkgrel=0
pkgdesc="All kind of addons to improve your Plasma experience"
-# mips, ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
# armhf blocked by qt5-qtdeclarative
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64"
+# mips, ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.0-only AND GPL-2.0-or-later"
depends="purpose"
diff --git a/community/kdesdk-thumbnailers/APKBUILD b/community/kdesdk-thumbnailers/APKBUILD
index 69b074785b..b4141945d8 100644
--- a/community/kdesdk-thumbnailers/APKBUILD
+++ b/community/kdesdk-thumbnailers/APKBUILD
@@ -3,11 +3,20 @@
pkgname=kdesdk-thumbnailers
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://www.kde.org/applications/development/"
pkgdesc="Plugins for the thumbnailing system"
license="GPL-2.0-only OR GPL-3.0-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev ki18n-dev kio-dev gettext-dev"
+makedepends="
+ extra-cmake-modules
+ gettext-dev
+ kconfig-dev
+ ki18n-dev
+ kio-dev
+ qt5-qtbase-dev
+ "
source="https://download.kde.org/stable/release-service/$pkgver/src/kdesdk-thumbnailers-$pkgver.tar.xz"
subpackages="$pkgname-lang"
options="!check" # No tests
@@ -26,7 +35,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kdewebkit/APKBUILD b/community/kdewebkit/APKBUILD
index cad94b7893..0d48f41aa7 100644
--- a/community/kdewebkit/APKBUILD
+++ b/community/kdewebkit/APKBUILD
@@ -4,12 +4,27 @@ pkgname=kdewebkit
pkgver=5.83.0
pkgrel=0
pkgdesc="Integration of the HTML rendering engine WebKit"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
-arch="$arch !mips !mips64 !riscv64" # blocked by qt5-qtwebkit
+# armhf blocked by extra-cmake-modules
+# mips64 and riscv64 blocked by qt5-qtwebkit
+# s390x blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev qt5-qtwebkit-dev kconfig-dev kcoreaddons-dev kio-dev kjobwidgets-dev kparts-dev kservice-dev kwallet-dev qt5-qttools-dev"
-makedepends="$depends_dev extra-cmake-modules"
+depends_dev="
+ kconfig-dev
+ kcoreaddons-dev
+ kio-dev
+ kjobwidgets-dev
+ kparts-dev
+ kservice-dev
+ kwallet-dev
+ qt5-qtbase-dev
+ qt5-qttools-de
+ qt5-qtwebkit-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ "
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/portingAids/kdewebkit-$pkgver.tar.xz"
subpackages="$pkgname-dev"
@@ -28,7 +43,7 @@ check() {
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kfind/APKBUILD b/community/kfind/APKBUILD
index b8820691c8..27c862401e 100644
--- a/community/kfind/APKBUILD
+++ b/community/kfind/APKBUILD
@@ -4,12 +4,22 @@ pkgname=kfind
pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio, ktextwidgets
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://www.kde.org/applications/utilities/kfind"
pkgdesc="Find Files/Folders"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules karchive-dev kcoreaddons-dev kdoctools-dev kfilemetadata-dev ki18n-dev kio-dev ktextwidgets-dev kwidgetsaddons-dev"
+makedepends="
+ extra-cmake-modules
+ karchive-dev
+ kcoreaddons-dev
+ kdoctools-dev
+ kfilemetadata-dev
+ ki18n-dev
+ kio-dev
+ ktextwidgets-dev
+ kwidgetsaddons-dev
+ "
source="https://download.kde.org/stable/release-service/$pkgver/src/kfind-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
options="!check" # No tests
@@ -28,7 +38,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kget/APKBUILD b/community/kget/APKBUILD
index 8d0633f3b9..07ce52f804 100644
--- a/community/kget/APKBUILD
+++ b/community/kget/APKBUILD
@@ -3,14 +3,46 @@
pkgname=kget
pkgver=21.04.2
pkgrel=0
-# ppc64le, s390x and riscv64 blocked by plasma-workspace -> libksysguard -> qt5-qtwebengine
+# ppc64le, s390x and riscv64 blocked by polkit -> kio
# armhf blocked by extra-cmake-modules
-# mips blocked by libktorrent
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64"
+# mips64 blocked by libktorrent
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://kde.org/applications/internet/org.kde.kget"
pkgdesc="A versatile and user-friendly download manager"
license="GPL-2.0-or-later AND LGPL-2.0-only AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev kitemviews-dev kcmutils-dev kio-dev knotifications-dev knotifyconfig-dev kparts-dev kservice-dev ktextwidgets-dev kwallet-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kitemmodels-dev kdelibs4support-dev plasma-workspace-dev sqlite-dev qca-dev gpgme-dev libktorrent-dev libmms-dev"
+makedepends="
+ extra-cmake-modules
+ gpgme-dev
+ kcmutils-dev
+ kcompletion-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdelibs4support-dev
+ kdoctools-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ kitemmodels-dev
+ kitemviews-dev
+ knotifications-dev
+ knotifyconfig-dev
+ kparts-dev
+ kservice-dev
+ ktextwidgets-dev
+ kwallet-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ kxmlgui-dev
+ libktorrent-dev
+ libmms-dev
+ plasma-workspace-dev
+ qca-dev
+ qt5-qtbase-dev
+ sqlite-dev
+ "
source="https://download.kde.org/stable/release-service/$pkgver/src/kget-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
options="!check" # No tests
@@ -29,7 +61,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kgpg/APKBUILD b/community/kgpg/APKBUILD
index 8424641a29..e6d8612562 100644
--- a/community/kgpg/APKBUILD
+++ b/community/kgpg/APKBUILD
@@ -3,15 +3,35 @@
pkgname=kgpg
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio, kiconthemes, kxmlgui, akonadi, kiconthemes
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/utilities/org.kde.kgpg"
pkgdesc="A simple interface for GnuPG, a powerful encryption utility"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev karchive-dev kdoctools-dev
- kcodecs-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev ki18n-dev
- kiconthemes-dev kjobwidgets-dev kio-dev knotifications-dev kservice-dev
- ktextwidgets-dev kxmlgui-dev kwidgetsaddons-dev kwindowsystem-dev
- akonadi-contacts-dev kcontacts-dev gpgme-dev"
+makedepends="
+ akonadi-contacts-dev
+ extra-cmake-modules
+ gpgme-dev
+ karchive-dev
+ kcodecs-dev
+ kcontacts-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ kjobwidgets-dev
+ knotifications-dev
+ kservice-dev
+ ktextwidgets-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ kxmlgui-dev
+ qt5-qtbase-dev
+ "
source="https://download.kde.org/stable/release-service/$pkgver/src/kgpg-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
@@ -31,7 +51,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kile/APKBUILD b/community/kile/APKBUILD
index 851affc0f4..30371c2800 100644
--- a/community/kile/APKBUILD
+++ b/community/kile/APKBUILD
@@ -3,29 +3,52 @@
pkgname=kile
pkgver=2.9.93
pkgrel=1
-arch="all !ppc64le !armhf !mips !mips64 !s390x !riscv64" # blocked by texlive
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x, mips64 and riscv64 blocked by texlive
+arch="all !armhf !ppc64le !mips64 !s390x !riscv64"
url="https://kde.org/applications/office/org.kde.kile"
pkgdesc="A user-friendly TeX/LaTeX editor"
license="GPL-2.0-or-later"
depends="texlive"
-makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdoctools-dev kguiaddons-dev ki18n-dev kiconthemes-dev kinit-dev khtml-dev kio-dev kparts-dev ktexteditor-dev kwindowsystem-dev kxmlgui-dev poppler-qt5-dev okular-dev"
+makedepends="
+ extra-cmake-modules
+ kconfig-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kguiaddons-dev
+ khtml-dev
+ ki18n-dev
+ kiconthemes-dev
+ kinit-dev
+ kio-dev
+ kparts-dev
+ ktexteditor-dev
+ kwindowsystem-dev
+ kxmlgui-dev
+ okular-dev
+ poppler-qt5-dev
+ qt5-qtbase-dev
+ "
source="https://downloads.sourceforge.net/kile/kile-$pkgver.tar.bz2"
subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B "$builddir"/build \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make -C build
+ cmake --build build
}
check() {
- make -C build
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="d87277b8ef16c82cfd415dd191916641fa1a25e316e1eb2c463b275d3654dcfe180bea03027589ab30cd8b769d92d97005846a78aff8058bcfb20eed76287504 kile-2.9.93.tar.bz2"
diff --git a/community/kinfocenter/APKBUILD b/community/kinfocenter/APKBUILD
index 6211f5a02f..eb4a4ed338 100644
--- a/community/kinfocenter/APKBUILD
+++ b/community/kinfocenter/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="A utility that provides information about a computer system"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by kconfigwidgets, polkit-qt, kio
-arch="all !armhf !s390x !mips !mips64 !riscv64"
+# mips64, s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/plasma-desktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="
diff --git a/community/kio-fuse/APKBUILD b/community/kio-fuse/APKBUILD
index 9abcbce123..067c782978 100644
--- a/community/kio-fuse/APKBUILD
+++ b/community/kio-fuse/APKBUILD
@@ -3,7 +3,9 @@
pkgname=kio-fuse
pkgver=5.0.1
pkgrel=1
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/"
pkgdesc="FUSE interface for KIO"
license="GPL-3.0-only"
diff --git a/community/kio-gdrive/APKBUILD b/community/kio-gdrive/APKBUILD
index 13e9bbf7d6..570b7e7927 100644
--- a/community/kio-gdrive/APKBUILD
+++ b/community/kio-gdrive/APKBUILD
@@ -3,7 +3,9 @@
pkgname=kio-gdrive
pkgver=21.04.2
pkgrel=0
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64" # blocked by libkgapi -> qt5-qtwebengine
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> libkgapi
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://community.kde.org/KIO_GDrive"
pkgdesc="KIO Slave to access Google Drive"
license="GPL-2.0-or-later"
@@ -39,7 +41,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kmail/APKBUILD b/community/kmail/APKBUILD
index 9ad0f1c3c0..945ef91f5f 100644
--- a/community/kmail/APKBUILD
+++ b/community/kmail/APKBUILD
@@ -3,7 +3,9 @@
pkgname=kmail
pkgver=21.04.2
pkgrel=0
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64" # blocked by qt5-qtwebengine
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://kontact.kde.org/components/kmail.html"
pkgdesc="Email client, supporting POP3 and IMAP mailboxes"
license="GPL-2.0-or-later"
diff --git a/community/koko/APKBUILD b/community/koko/APKBUILD
index 6f6a987577..7df8037d06 100644
--- a/community/koko/APKBUILD
+++ b/community/koko/APKBUILD
@@ -7,7 +7,7 @@ _geonames_pkgver=2020.06.25
pkgdesc="Image gallery application for Plasma Mobile"
url="https://invent.kde.org/graphics/koko"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by kdeclarative
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
license="LGPL-2.0-or-later AND LGPL-2.1-only AND LGPL-3.0-only AND LicenseRef-KDE-Accepted-GPL"
depends="
diff --git a/community/kolf/APKBUILD b/community/kolf/APKBUILD
index be34935fc0..136f12e264 100644
--- a/community/kolf/APKBUILD
+++ b/community/kolf/APKBUILD
@@ -4,10 +4,28 @@ pkgname=kolf
pkgver=21.04.2
pkgrel=0
pkgdesc="A miniature golf game with 2d top-down view"
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/games/kolf/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdoctools-dev ki18n-dev kio-dev ktextwidgets-dev kwidgetsaddons-dev kxmlgui-dev libkdegames-dev"
+makedepends="
+ extra-cmake-modules
+ kcompletion-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ ki18n-dev
+ kio-dev
+ ktextwidgets-dev
+ kwidgetsaddons-dev
+ kxmlgui-dev
+ libkdegames-dev
+ qt5-qtbase-dev
+ "
source="https://download.kde.org/stable/release-service/$pkgver/src/kolf-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
options="!check" # No tests
@@ -21,7 +39,7 @@ build() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kpat/APKBUILD b/community/kpat/APKBUILD
index 9dd0e763db..8d61ef2cc2 100644
--- a/community/kpat/APKBUILD
+++ b/community/kpat/APKBUILD
@@ -4,7 +4,9 @@ pkgname=kpat
pkgver=21.04.2
pkgrel=0
pkgdesc="KPatience offers a selection of solitaire card games"
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/games/kpat/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -46,7 +48,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/ktorrent/APKBUILD b/community/ktorrent/APKBUILD
index f460bdbed5..bd16748d37 100644
--- a/community/ktorrent/APKBUILD
+++ b/community/ktorrent/APKBUILD
@@ -4,9 +4,9 @@ pkgname=ktorrent
pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and riscv64 blocked by plasma-workspace
-# mips blocked by libktorrent
-arch="all !armhf !ppc64le !s390x !mips !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by polkit -> plasma-workspace
+# mips64 blocked by libktorrent
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
license="GPL-2.0-or-later"
diff --git a/community/kturtle/APKBUILD b/community/kturtle/APKBUILD
index 10c44a2e58..62db5bd666 100644
--- a/community/kturtle/APKBUILD
+++ b/community/kturtle/APKBUILD
@@ -3,11 +3,24 @@
pkgname=kturtle
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="http://edu.kde.org/kturtle"
pkgdesc="Educational Programming Environment"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kcrash-dev kio-dev knewstuff-dev kdoctools-dev ktextwidgets-dev ki18n-dev kcoreaddons-dev"
+makedepends="
+ extra-cmake-modules
+ kcoreaddons-dev
+ kcrash-dev
+ kdoctools-dev
+ ki18n-dev
+ kio-dev
+ knewstuff-dev
+ ktextwidgets-dev
+ qt5-qtbase-dev
+ qt5-qtsvg-dev
+ "
source="https://download.kde.org/stable/release-service/$pkgver/src/kturtle-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
options="!check" # No tests
@@ -26,7 +39,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kwalletmanager/APKBUILD b/community/kwalletmanager/APKBUILD
index 644802d5ee..1c24b685f4 100644
--- a/community/kwalletmanager/APKBUILD
+++ b/community/kwalletmanager/APKBUILD
@@ -3,11 +3,35 @@
pkgname=kwalletmanager
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by kio
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/system/org.kde.kwalletmanager5"
pkgdesc="A tool to manage the passwords on your KDE system"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev karchive-dev kauth-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev kjobwidgets-dev kcmutils-dev kio-dev knotifications-dev kservice-dev ktextwidgets-dev kwallet-dev kwindowsystem-dev kxmlgui-dev kcrash-dev"
+makedepends="
+ extra-cmake-modules
+ karchive-dev
+ kauth-dev
+ kcmutils-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ kjobwidgets-dev
+ knotifications-dev
+ kservice-dev
+ ktextwidgets-dev
+ kwallet-dev
+ kwindowsystem-dev
+ kxmlgui-dev
+ qt5-qtbase-dev
+ "
checkdepends="xvfb-run"
source="https://download.kde.org/stable/release-service/$pkgver/src/kwalletmanager-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
@@ -26,7 +50,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
diff --git a/community/kwin-effect-xrdesktop/APKBUILD b/community/kwin-effect-xrdesktop/APKBUILD
index f375277fa5..0839cc033f 100644
--- a/community/kwin-effect-xrdesktop/APKBUILD
+++ b/community/kwin-effect-xrdesktop/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="xrdesktop effect for KWin"
url="https://gitlab.freedesktop.org/xrdesktop/kwin-effect-xrdesktop"
# armhf blocked by extra-cmake-modules
-# mips64, s390x, ppc64le and riscv64 blocked by polkit
+# mips64, s390x, ppc64le and riscv64 blocked by polkit -> kxmlgui
arch="all !s390x !ppc64le !mips64 !armhf !riscv64"
license="MIT"
makedepends="
diff --git a/community/mycroft-gui/APKBUILD b/community/mycroft-gui/APKBUILD
index 971778a08b..a1fd5e8f64 100644
--- a/community/mycroft-gui/APKBUILD
+++ b/community/mycroft-gui/APKBUILD
@@ -5,7 +5,9 @@ pkgver=1.0.1
pkgrel=1
pkgdesc="The Graphical User Interface used by the Mycroft Mark II and more"
url="https://mycroft.ai"
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64" # blocked by qt5-qtwebview
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> qt5-qtwebview
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
license="Apache-2.0"
depends="kirigami2"
makedepends="
diff --git a/community/oxygen/APKBUILD b/community/oxygen/APKBUILD
index f3eaf44a05..349ae8b1a3 100644
--- a/community/oxygen/APKBUILD
+++ b/community/oxygen/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Artwork, styles and assets for the Oxygen visual style for the Plasma Desktop"
# armhf blocked by extra-cmake-modules
-# armhf, s390x, mips64 and riscv64 blocked by frameworkintegration and kcmutils
+# s390x, mips64 and riscv64 blocked by polkit -> kcmutils
arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
@@ -52,6 +52,7 @@ package() {
sounds() {
pkgdesc="$pkgdesc (sounds)"
+
amove usr/share/sounds
}
sha512sums="
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index af312e98ee..10c15aa109 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Plasma applet for audio volume management using PulseAudio"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by libksysguard
+# s390x, mips64 and riscv64 blocked by polkit -> plasma-workspace
arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
diff --git a/community/plasma-phone-components/APKBUILD b/community/plasma-phone-components/APKBUILD
index 4c30871b90..2b8728e3c6 100644
--- a/community/plasma-phone-components/APKBUILD
+++ b/community/plasma-phone-components/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Modules providing phone functionality for Plasma"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-nano
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://www.plasma-mobile.org/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
diff --git a/community/plasma-sdk/APKBUILD b/community/plasma-sdk/APKBUILD
index e8e1917557..664f22245f 100644
--- a/community/plasma-sdk/APKBUILD
+++ b/community/plasma-sdk/APKBUILD
@@ -5,8 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Applications useful for Plasma Development"
# armhf blocked by qt5-qtdeclarative
-# s390x blocked by kconfigwidgets
-# mips64 and riscv64 blocked by multiple dependencies
+# mips64, s390x and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
diff --git a/community/powerdevil/APKBUILD b/community/powerdevil/APKBUILD
index e7b2021b9c..bce13c9706 100644
--- a/community/powerdevil/APKBUILD
+++ b/community/powerdevil/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Manages the power consumption settings of a Plasma Shell"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by libksysguard
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
diff --git a/community/qt5-qtwebview/APKBUILD b/community/qt5-qtwebview/APKBUILD
index ac537eb4b0..19fae3eb2e 100644
--- a/community/qt5-qtwebview/APKBUILD
+++ b/community/qt5-qtwebview/APKBUILD
@@ -6,13 +6,15 @@ pkgrel=0
_commit="920de5f1cd9f9001cfef1bfd2c19e6720793362f"
# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
# armhf blocked by qt5-qtdeclarative
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64"
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://www.qt.io/developers/"
license="LGPL-3.0-only AND GPL-2.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
pkgdesc="Provides a way to display web content in a QML application"
depends="qt5-qtwebengine"
depends_dev="qt5-qtdeclarative-dev"
-makedepends="$depends_dev qt5-qtbase-dev"
+makedepends="$depends_dev
+ qt5-qtbase-dev
+ "
subpackages="$pkgname-dev"
builddir="$srcdir/qtwebview-$_commit"
diff --git a/community/sddm-kcm/APKBUILD b/community/sddm-kcm/APKBUILD
index c06865f178..5319d9af77 100644
--- a/community/sddm-kcm/APKBUILD
+++ b/community/sddm-kcm/APKBUILD
@@ -4,7 +4,9 @@ pkgname=sddm-kcm
pkgver=5.22.2.1
pkgrel=0
pkgdesc="Config module for SDDM"
-arch="all !armhf !s390x !mips64 !riscv64" # blocked by plasma-workspace
+# armhf blocked by extra-cmake-modules
+# s390x, mips64 and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://www.kde.org"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-only"
depends="
diff --git a/community/skanlite/APKBUILD b/community/skanlite/APKBUILD
index 5b0a23f3ca..da9a63a0ac 100644
--- a/community/skanlite/APKBUILD
+++ b/community/skanlite/APKBUILD
@@ -4,7 +4,7 @@ pkgname=skanlite
pkgver=2.2.0
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio-dev and kxmlgui-dev
+# s390x, mips64 and riscv64 blocked by polkit -> kio
arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/graphics/skanlite"
pkgdesc="Lite image scanning application"
diff --git a/community/sweeper/APKBUILD b/community/sweeper/APKBUILD
index 7948543947..c50014c6a7 100644
--- a/community/sweeper/APKBUILD
+++ b/community/sweeper/APKBUILD
@@ -3,12 +3,27 @@
pkgname=sweeper
pkgver=21.04.2
pkgrel=0
-# mips, mips64, riscv64: blocked by rust
-arch="all !armhf !s390x !mips !mips64 !riscv64"
+# armhf blocked by extra-cmake-modules
+# mips64, s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/utilities/org.kde.sweeper"
pkgdesc="System cleaner to help clean unwanted traces the user leaves on the system"
license="LGPL-2.1-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev kactivities-stats-dev kbookmarks-dev kcrash-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdoctools-dev ki18n-dev kio-dev ktextwidgets-dev kxmlgui-dev"
+makedepends="
+ extra-cmake-modules
+ kactivities-stats-dev
+ kbookmarks-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdoctools-dev
+ ki18n-dev
+ kio-dev
+ ktextwidgets-dev
+ kxmlgui-dev
+ qt5-qtbase-dev
+ "
source="https://download.kde.org/stable/release-service/$pkgver/src/sweeper-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
@@ -26,7 +41,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="