aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/unshield/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/community/unshield/APKBUILD b/community/unshield/APKBUILD
index 53fc21130ae..0c066d55639 100644
--- a/community/unshield/APKBUILD
+++ b/community/unshield/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=unshield
-pkgver=1.4.3
+pkgver=1.4.3_git20211021
+_commit="c758ac017dda2f1735d385a360f82b673b898f4b"
pkgrel=0
pkgdesc="Extracts CAB files from InstallShield installers"
# Note: only tested on the following archs, may work on others too but not
# adding them until this has been confirmed
-arch="x86_64 aarch64"
+arch="x86_64 aarch64 armv7"
url="https://github.com/twogood/unshield"
license="MIT"
makedepends="cmake zlib-dev"
checkdepends="bash"
-source="$pkgname-$pkgver.tar.gz::https://github.com/twogood/unshield/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/twogood/unshield/archive/$_commit.tar.gz"
subpackages="
$pkgname-doc
$pkgname-dev
@@ -19,6 +20,7 @@ subpackages="
options="!check"
# Package includes unit tests but they fail to execute:
# https://github.com/twogood/unshield/issues/99
+builddir="$srcdir/$pkgname-$_commit"
build() {
cmake -B build . \
@@ -35,4 +37,6 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
}
-sha512sums="2f058e0a28d0497e2afe231ded1b1bb16745401398eb1035e628d263351b10a1343c9664f3937b8912755db9dc5236a1b43e9bcba596affb7aa8b036f49382aa unshield-1.4.3.tar.gz"
+sha512sums="
+d9304c63905fc3f9e9db59d76ee2701f998ae0a7c1e1da87107df45f0f5012683f068402ac496911ac95b631a5585afd7757443e4856b4effda21f725d915c00 unshield-1.4.3_git20211021.tar.gz
+"