aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-jsonpickle/APKBUILD10
-rw-r--r--testing/py3-jsonpickle/test-opts.patch12
2 files changed, 4 insertions, 18 deletions
diff --git a/testing/py3-jsonpickle/APKBUILD b/testing/py3-jsonpickle/APKBUILD
index fd745f97c9b..249db96e374 100644
--- a/testing/py3-jsonpickle/APKBUILD
+++ b/testing/py3-jsonpickle/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=py3-jsonpickle
-pkgver=1.5.1
+pkgver=2.0.0
pkgrel=0
pkgdesc="Serializing any arbitrary object graph into JSON"
url="https://pypi.python.org/pypi/jsonpickle/"
@@ -11,7 +11,6 @@ makedepends="py3-setuptools py3-setuptools_scm"
checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/j/jsonpickle/jsonpickle-$pkgver.tar.gz
tests.patch
- test-opts.patch
"
builddir="$srcdir/jsonpickle-$pkgver"
@@ -31,13 +30,12 @@ build() {
}
check() {
- PYTHONPATH=$PWD/build/lib pytest-3
+ PYTHONPATH=$PWD/build/lib pytest-3 -c /dev/null
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="ee3694e961bfbb6cc985691fb4821cf831dd6a2cbbdc8c6d1ba8e43fe7a4bba3d4b6868a02f76b88d9b036cebf51b217171504a6647f26b0e2d11727baee62f3 jsonpickle-1.5.1.tar.gz
-8df533695556bc7b329211dfbb5ad667fbd8f9b569721a054f9dead9402ac365666f50ff4343feda536e679a58f1244708ab10fa2f6f8b33b2469dfdc57c576c tests.patch
-3cfa2793f5d51b32aea0453adc677766f8545963cf6cc0d8726dfd43c1038673e3b232a232d18bfb5feb9032ff778677243e0451688ed503a2865f761fdaf655 test-opts.patch"
+sha512sums="acba11e5dfce116b27edfe0fdccdd74755e299aa43f873dd1ce547d947b58f14c1059c21d04007b5be0857f7ce69fe5355fb2edc47a99cc2217fe00297ca78d3 jsonpickle-2.0.0.tar.gz
+8df533695556bc7b329211dfbb5ad667fbd8f9b569721a054f9dead9402ac365666f50ff4343feda536e679a58f1244708ab10fa2f6f8b33b2469dfdc57c576c tests.patch"
diff --git a/testing/py3-jsonpickle/test-opts.patch b/testing/py3-jsonpickle/test-opts.patch
deleted file mode 100644
index 1767357bf49..00000000000
--- a/testing/py3-jsonpickle/test-opts.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/pytest.ini b/pytest.ini
-index baef2a8..95365d2 100644
---- a/pytest.ini
-+++ b/pytest.ini
-@@ -1,6 +1,5 @@
- [pytest]
- norecursedirs=dist build .tox .eggs
--addopts=--doctest-modules --flake8 --black --cov --cov-append
- doctest_optionflags=ALLOW_UNICODE ELLIPSIS
- filterwarnings=
- # https://github.com/pytest-dev/pytest/issues/6928
-