aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/mate-common/APKBUILD9
-rw-r--r--community/mate-common/install-sh.patch10
2 files changed, 16 insertions, 3 deletions
diff --git a/community/mate-common/APKBUILD b/community/mate-common/APKBUILD
index 5436447f68a..c55940616d5 100644
--- a/community/mate-common/APKBUILD
+++ b/community/mate-common/APKBUILD
@@ -1,14 +1,16 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=mate-common
-pkgver=1.20.0
+pkgver=1.22.0
pkgrel=0
pkgdesc="Common scripts and macros"
url="http://mate-desktop.org/"
arch="noarch"
license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
-source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ install-sh.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -31,4 +33,5 @@ package() {
make DESTDIR="${pkgdir}" install
}
-sha512sums="78fed107087f21f30a87b2fd635479f31162f1b9e7ae2f9c02146af275d7662a4ea466da2a049c35d726073d3a0bd9a043818b332b93670334c59aef36bc3b8a mate-common-1.20.0.tar.xz"
+sha512sums="3887634081c126c6c23f560ca256ae83edbc5f77f0fc0128c2aaa2b5652672ec6f21ca29b0b44802b03c5dfd53bf0da860093ec73c46fba58f7be12a1db1d2a3 mate-common-1.22.0.tar.xz
+2220612dcda2f992ce6e7d8225c3d012497ff297921c24d40853553783c6b0f95c8e25ab0ad3454931e6e104a9951892972c045e4b9e2672cbbe34cd5a0936f3 install-sh.patch"
diff --git a/community/mate-common/install-sh.patch b/community/mate-common/install-sh.patch
new file mode 100644
index 00000000000..d32f681c0e4
--- /dev/null
+++ b/community/mate-common/install-sh.patch
@@ -0,0 +1,10 @@
+diff --git a/install-sh b/install-sh
+index defb86a..8175c64 100755
+--- a/install-sh
++++ b/install-sh
+@@ -1,4 +1,4 @@
+-#!/usr/bin/sh
++#!/bin/sh
+ # install - install a program, script, or datafile
+
+ scriptversion=2018-03-11.20; # UTC