aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/munin/APKBUILD6
-rw-r--r--community/munin/munin-config.patch63
2 files changed, 11 insertions, 58 deletions
diff --git a/community/munin/APKBUILD b/community/munin/APKBUILD
index 942097f225e..5868f7d87a0 100644
--- a/community/munin/APKBUILD
+++ b/community/munin/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=munin
-pkgver=2.0.37
+pkgver=2.0.39
pkgrel=0
pkgdesc="A distributed monitoring/graphing tool"
url="http://munin-monitoring.org/"
@@ -61,8 +61,8 @@ node() {
"$subpkgdir"/etc/init.d/$subpkgname
}
-sha512sums="84328697cf6d42bd28e948ff505e89840d8c9c72cfd21136da8d738d39ecb9921344e95b3eb0bbf6fc620b1237965f5d7d4605a14e6317f4ec39365c0a6e5ca1 munin-2.0.37.tar.gz
-a1c691a4c5d7d2619ea6d2605c71a23eeaa65f9cf533477524927bc3244371e271a4dadf24e71d6630f3ea8d6ad56f26bed83330a22ff0573e67c5cafe66cf17 munin-config.patch
+sha512sums="8dac18de92ff39b6a13a5da7eb5778549fa43d86561dbae308dba3561e57c8012d4b055e66046aa9e97304bee1d9ef51e51cead862b36fc53256e24c7272b4df munin-2.0.39.tar.gz
+d39760b9c0546638feaf164ad132a0f384f1b70872de2251a328a27a64797501f926141a7273cd5e41a8c11ec4d7a4adda1863b02439d9caa8b216fac60d3062 munin-config.patch
06061feb63a451fe45ea4271dac3d0b0f4758f877df9b0d734cc6057eadfec26765b65fd91d3a00febb66ac79c70c9468cc1548e39362adfc19809900aaf8aa9 fix-build.patch
194b742b2ff8312c4c42a8a77d1d9a80bc53ced2343248c36f4229b0b0d366e898487fb5e415f1f5ccea7210a7a86e25de5e45193dbb5d26d2d6a195f0597642 munin.crond
4b2a49a7bcb64eef65eee3b77ce86ca2cd8afef681922fdb830cb382f334c07356576f1151f4423f066ba8ac1c2d9a51cf9ff3d4dd4b18a5c1e2c95abcd9a940 munin-node.initd
diff --git a/community/munin/munin-config.patch b/community/munin/munin-config.patch
index cae8ec3c134..d4150fc74c7 100644
--- a/community/munin/munin-config.patch
+++ b/community/munin/munin-config.patch
@@ -1,6 +1,6 @@
-diff -ur munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
---- munin-2.0.25.orig/Makefile.config 2014-11-24 22:46:24.000000000 +0100
-+++ munin-2.0.25/Makefile.config 2016-04-14 00:32:53.547838027 +0200
+diff -ur a/Makefile.config b/Makefile.config
+--- a/Makefile.config 2018-08-06 16:23:55.119755310 +0200
++++ b/Makefile.config 2018-08-06 16:26:23.252875870 +0200
@@ -17,35 +17,35 @@
#
# the base of the Munin installation.
@@ -48,7 +48,7 @@ diff -ur munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
# Client only - Where the spool files are written. Must be writable by
# group "munin", and should be preserved between reboots
-@@ -56,17 +56,17 @@
+@@ -56,14 +56,14 @@
PLUGSTATE = $(DBDIRNODE)/plugin-state
# Where Munin should place its logs.
@@ -65,11 +65,7 @@ diff -ur munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
+PERL := /usr/bin/perl
# The python interpreter to use (used by some plugins)
--PYTHON := /usr/bin/env python
-+PYTHON := /usr/bin/env python2
-
- # The ruby interpreter to use (used by some plugins)
- RUBY := /usr/bin/env ruby
+ PYTHON := /usr/bin/env python3
@@ -89,13 +89,13 @@
# On Linux /bin/sh, SunOS/Solaris /usr/xpg4/bin/sh or /bin/ksh
# In general: bash or ksh will work
@@ -81,51 +77,8 @@ diff -ur munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
BASH := /bin/bash
# Server only - Where to install the perl libraries
--PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
-+PERLSITELIB := $(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
- PERLLIB = $(DESTDIR)$(PERLSITELIB)
+-PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
++PERLLIB = $(DESTDIR)$(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
# Client only - Install plugins for this architecture
-@@ -106,7 +106,7 @@
-
- # How to figure out the hostname. (Only used in default configuration
- # files)
--HOSTNAME := $(shell hostname)
-+HOSTNAME := localhost
-
- # What is the safest way to create a tempfile.
- # Default is to figure it out by testing various methods.
-@@ -129,9 +129,9 @@
- # Which command to use to check if the USER and GROUP to run Munin as, exists.
- # These will work on most modern OSes:
- #
--GETENT := $(shell which getent || which true 2>/dev/null)
--CHECKUSER := $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
--CHECKGROUP := $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
-+GETENT := /bin/true
-+CHECKUSER := /bin/true
-+CHECKGROUP := /bin/true
-
- # For OSX, comment out the previous two lines and comment in these
- #
-@@ -153,9 +153,9 @@
- #CHECKUSER := $(shell id $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
- #CHECKGROUP := $(shell grep ^$(GROUP): /etc/group >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
-
--CHOWN := chown
-+CHOWN := true
- CHMOD := chmod
--CHGRP := chgrp
-+CHGRP := true
-
- # Java compiler stuff - only needed on the buildhost
- JC := javac
-@@ -166,7 +166,7 @@
- # Note that we defer JCVALID evaluation to runtime,
- # since $(JC) can be redefined later in a specific Makefile.config
- # The core Makefile.config is then used as a Makefile.default
--JCVALID = $(shell $(JC) -version >/dev/null 2>/dev/null && echo "yes")
-+JCVALID = no
-
- # Check whether setruid functionality can be used
- HASSETR := $(shell perl -e 'use Config; my @vars=("d_setruid", "d_setreuid", "d_setresuid"); foreach my $$var (@vars) { if ($$Config{$$var} eq "define") { print "1\n"; exit 0; } } print "0\n"; exit 0;' )
+ # the LANG=C makes tr work as expected, not regarding any locale it