aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/zram-init/APKBUILD12
-rw-r--r--community/zram-init/default-lz4.patch49
2 files changed, 7 insertions, 54 deletions
diff --git a/community/zram-init/APKBUILD b/community/zram-init/APKBUILD
index 5f5aadf801d..166945f27a2 100644
--- a/community/zram-init/APKBUILD
+++ b/community/zram-init/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
# Contributor: Pedro Filipe <xpecex@outlook.com>
pkgname=zram-init
-pkgver=9.1
+pkgver=10.5
pkgrel=0
pkgdesc="wrapper script for the zram kernel module"
arch="noarch"
@@ -15,9 +15,12 @@ subpackages="
$pkgname-doc
"
source="$pkgname-$pkgver.tar.gz::https://github.com/vaeth/zram-init/archive/v$pkgver.tar.gz
- default-lz4.patch
"
-options="!check"
+options="!check" # no tests
+
+build() {
+ make SYSTEMD=FALSE SYSCONFDIR=/etc GETTEXT=FALSE
+}
package() {
install -Dm644 modprobe.d/zram.conf "$pkgdir"/lib/modprobe.d/zram.conf
@@ -37,5 +40,4 @@ zshcomp() {
install -Dm644 "$builddir"/zsh/_zram-init -t "$subpkgdir"/usr/share/zsh/site-functions
}
-sha512sums="4e3c76a389d188df98479f3f70af28405144b065df60ba191777cbec88d9bfe94be472d94bbb16314c0eefd41d177105cba74b45d1f13e82a741ff21a4d69c6a zram-init-9.1.tar.gz
-4dee4a83771fec0b4ea63e59f61d7615ae7253acaff46a219d700237326e8b96d3d2fda31754c3c7bc53c04159d163dcdc432bfb790f9e9a52faef508036b3ed default-lz4.patch"
+sha512sums="97591549aa9b678b0b12efcc27136826c19b42cc0cf027a3f251843ef5678425568c9eb573d24661ce795eede1d136243fcccbf4dcd62e9d61eb7d775f84f1c1 zram-init-10.5.tar.gz"
diff --git a/community/zram-init/default-lz4.patch b/community/zram-init/default-lz4.patch
deleted file mode 100644
index 30d2e8f5755..00000000000
--- a/community/zram-init/default-lz4.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/openrc/conf.d/zram-init b/openrc/conf.d/zram-init
-index 06871f3..9d6ce70 100644
---- a/openrc/conf.d/zram-init
-+++ b/openrc/conf.d/zram-init
-@@ -54,7 +54,7 @@ mlim0= # no hard memory limit
- back0= # no backup device
- notr0= # keep the default on linux-3.15 or newer
- maxs0=1 # maximum number of parallel processes for this device
--algo0=zstd # zstd (since linux-4.18), lz4 (since linux-3.15), or lzo.
-+algo0=lz4 # zstd (since linux-4.18), lz4 (since linux-3.15), or lzo.
- # Size: zstd (best) > lzo > lz4. Speed: lz4 (best) > zstd > lzo
- labl0=zram_swap # the label name
- uuid0= # Do not force UUID
-@@ -74,7 +74,7 @@ mode1=1777
- owgr1= # No reason to change the default "root:root"
- notr1= # keep the default on linux-3.15 or newer
- maxs1=2
--algo1=zstd
-+algo1=lz4
- labl1=tmp_dir
- uuid1=
- args1=
-@@ -90,7 +90,7 @@ mode2=1777
- owgr2= # No reason to change the default "root:root"
- notr2= # keep the default on linux-3.15 or newer
- maxs2=1
--algo2=zstd
-+algo2=lz4
- labl2=var_tmp_dir
- uuid2=
- args2=
-@@ -100,7 +100,7 @@ type3=- # Only format the filesystem but actually do not mount it
- flag3=btrfs
- size3=1024
- maxs3=1
--algo3=zstd
-+algo3=lz4
- labl3=zbtrfs
- uuid3=
- args3=
-@@ -114,7 +114,7 @@ type3=swap
- flag3=
- size3=512
- maxs3=1
--algo3=zstd
-+algo3=lz4
- labl3=zram_swap2
- uuid3=
- args3=