aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/ttf-tlwg/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/main/ttf-tlwg/APKBUILD b/main/ttf-tlwg/APKBUILD
new file mode 100644
index 00000000000..544117c9aec
--- /dev/null
+++ b/main/ttf-tlwg/APKBUILD
@@ -0,0 +1,19 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=ttf-tlwg
+pkgver=0.7.2
+pkgrel=0
+pkgdesc="The Thai TrueType fonts included here are Norasi and Garuda from the National Font project"
+url="https://linux.thai.net/projects/fonts-tlwg"
+arch="noarch"
+license="LPPL-1.3c AND GPL-2.0-only WITH Font-exception-2.0"
+options="!check" # No tests, only font files
+source="https://linux.thai.net/pub/thailinux/software/fonts-tlwg/fonts/ttf-tlwg-$pkgver.tar.xz"
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/ "$pkgdir"/etc/fonts/conf.d
+ cp -r *.ttf "$pkgdir"/usr/share/fonts/
+ cp -r fontconfig/conf.avail/*.conf "$pkgdir"/etc/fonts/conf.d
+}
+
+sha512sums="dd5865da81bbb10665c561ae188197a3bb0831162bf69795298f80f8aff1a210fce8e3d961476a878851376d15d95dd7d36144d53e8123a309ea883ced1a7e58 ttf-tlwg-0.7.2.tar.xz"