aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-dominate/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/py3-dominate/APKBUILD b/testing/py3-dominate/APKBUILD
index 8f6f9b055ee..c90ef8153ac 100644
--- a/testing/py3-dominate/APKBUILD
+++ b/testing/py3-dominate/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=py3-dominate
-pkgver=2.5.2
+pkgver=2.6.0
pkgrel=0
pkgdesc="Library for creating and manipulating HTML documents using an elegant DOM API"
-options="!check" # Tests are broken
url="https://github.com/Knio/dominate/"
arch="noarch"
license="LGPL-3.0-only"
depends="python3"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/Knio/dominate/archive/$pkgver.tar.gz"
builddir="$srcdir/dominate-$pkgver"
@@ -17,8 +17,12 @@ build() {
python3 setup.py build
}
+check() {
+ py.test-3
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="2120061c11ac52e89e6e2f4a770a0d6eafdccd583866bf38bd841231c38c7086db453ba3a92b30ab7180ae19f2b6ff47a5c838ff6a5afa94a3a6d71eda20ff63 py3-dominate-2.5.2.tar.gz"
+sha512sums="ce32146ab105b5f53e5b1281d3da1166d5704c6972ff294cdb8ecfa69bc88ec49c62998e9e3e58f303389cb6002ae6042e956037a521b118de2d6de35ea712af py3-dominate-2.6.0.tar.gz"