aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/php7-libvirt-php/APKBUILD23
-rw-r--r--testing/php7-libvirt-php/musl-idn.patch11
-rw-r--r--testing/php7-libvirt-php/offline-tests.patch30
3 files changed, 53 insertions, 11 deletions
diff --git a/testing/php7-libvirt-php/APKBUILD b/testing/php7-libvirt-php/APKBUILD
index 0f2abc656be..fffd9f920e4 100644
--- a/testing/php7-libvirt-php/APKBUILD
+++ b/testing/php7-libvirt-php/APKBUILD
@@ -1,41 +1,42 @@
# Contributor: Fernando Casas Schossow <casasfernando@outlook.com>
# Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
pkgname=php7-libvirt-php
-pkgver=0.5.4
-pkgrel=1
+pkgver=0.5.5
+pkgrel=0
pkgdesc="PHP language bindings for Libvirt API. For more details see: http://www.libvirt.org/php/"
url="https://libvirt.org/php/"
-arch="all !x86 !armhf !armv7 !aarch64" # missing deps on armv7, segfault on x86, armhf and aarch64
-license="LGPL-2.1"
+arch="all !x86 !armhf !armv7" # segfault on x86, armhf and armv7
+license="LGPL-2.1-only"
makedepends="autoconf libvirt-dev libxml2-dev libxml2-utils libxslt php7-dev php7-pecl-imagick libtool linux-headers"
subpackages="$pkgname-doc"
-source="http://libvirt.org/sources/php/libvirt-php-$pkgver.tar.gz
+source="https://libvirt.org/sources/php/libvirt-php-$pkgver.tar.gz
+ offline-tests.patch
+ musl-idn.patch
musl-fixes.patch"
builddir="$srcdir/libvirt-php-$pkgver"
prepare() {
- cd "$builddir"
default_prepare
autoconf
}
build() {
- cd "$builddir"
./configure --prefix=/usr
make
}
check() {
- cd "$builddir"
- php7 --no-php-ini --define extension=src/.libs/libvirt-php.so --modules | grep libvirt
+ make check
+ php7 --define extension=src/.libs/libvirt-php.so --ri libvirt
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
rm "$pkgdir/usr/lib/php7/modules/libvirt-php.la"
}
-sha512sums="b5b204549e6810668203d1df8404a5cb71f646ae7e01ea223c6e9b9eec9b1f6500cc5bb4559859959d821a213ff992f22a97e4b683da2c683be3732710943487 libvirt-php-0.5.4.tar.gz
+sha512sums="2ea263561a0bf5d155314e06dcf3c3b5c278640bc5edfa674cdd777cb6d0810bda0492c6cf77a02bc88fb6aa99b0ff1f0cbaeea87ff2e45bff9b5774a2507684 libvirt-php-0.5.5.tar.gz
+a212746438428537422716f5883f6941704137cd2cdceafb965fec8306c81c3bc4a4ce1caf65efc2a033823e8eb6f5afa1b452f9a191c50cd07d4c979e10d5fd offline-tests.patch
+cae4423b361c7735052ae1c1ec4e24090486020d4f3aaf87c16991b9fb90960d90cd8bc392bb017449525fc4567de1080e3d29337b2d756f46edac672b2bd81b musl-idn.patch
732f22ca206187b7a0ea41fe2d63808c8afc0994f941fbbb933dbde219f597d108aa3ed10b67e074fe90ac6ab571ee0dc70ef725ce8ed746d8f6e4689e972291 musl-fixes.patch"
diff --git a/testing/php7-libvirt-php/musl-idn.patch b/testing/php7-libvirt-php/musl-idn.patch
new file mode 100644
index 00000000000..323a5f56f1c
--- /dev/null
+++ b/testing/php7-libvirt-php/musl-idn.patch
@@ -0,0 +1,11 @@
+--- a/src/libvirt-php.c
++++ b/src/libvirt-php.c
+@@ -1168,7 +1168,7 @@
+
+ /* need to get FQDN of the local name */
+ memset(&hints, 0, sizeof(hints));
+- hints.ai_flags = AI_CANONNAME|AI_CANONIDN;
++ hints.ai_flags = AI_CANONNAME;
+ hints.ai_family = AF_UNSPEC;
+
+ /* could not get FQDN or got localhost, use whatever gethostname gave us */
diff --git a/testing/php7-libvirt-php/offline-tests.patch b/testing/php7-libvirt-php/offline-tests.patch
new file mode 100644
index 00000000000..90826023f00
--- /dev/null
+++ b/testing/php7-libvirt-php/offline-tests.patch
@@ -0,0 +1,30 @@
+--- a/tests/runtests.sh
++++ b/tests/runtests.sh
+@@ -8,7 +8,7 @@
+ "test-domain-define-undefine"
+ "test-domain-define-create-destroy"
+ "test-domain-create" "test-domain-create-and-get-xpath" "test-domain-create-and-coredump"
+- "test-install" "test-get-models" "test-get-models-unsupported-hw" "test-domain-create-get-metadata"
++ "test-install" "test-get-models-unsupported-hw" "test-domain-create-get-metadata"
+ )
+
+ run_test()
+@@ -41,12 +41,12 @@
+ fi
+ done
+
+-qemu-img create -f qcow2 /tmp/example-test.qcow2 1M > /dev/null
+-run_test "test-domain-snapshot" $nf; ret="$?"
+-if [ "x$ret" == "x1" ]; then
+- error=1
+-fi
+-rm -f /tmp/example-test.qcow2
++#qemu-img create -f qcow2 /tmp/example-test.qcow2 1M > /dev/null
++#run_test "test-domain-snapshot" $nf; ret="$?"
++#if [ "x$ret" == "x1" ]; then
++# error=1
++#fi
++#rm -f /tmp/example-test.qcow2
+
+ if [ "x$error" == "x0" ]; then
+ echo "All tests passed successfully"