aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/claws-mail/APKBUILD43
-rw-r--r--main/claws-mail/claws_gnutls.patch16
2 files changed, 54 insertions, 5 deletions
diff --git a/main/claws-mail/APKBUILD b/main/claws-mail/APKBUILD
index 2dd456eb1d1..f1f921cc66f 100644
--- a/main/claws-mail/APKBUILD
+++ b/main/claws-mail/APKBUILD
@@ -1,12 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=claws-mail
pkgver=3.8.0
-pkgrel=2
+pkgrel=3
pkgdesc="A GTK+ based e-mail client."
url="http://www.claws-mail.org"
arch="all"
license="GPL3"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang
+ $pkgname-plugins-spamassassin:spamassassin
+ $pkgname-plugins-pgp:pgp
+ $pkgname-plugins-smime:smime
+ "
+
makedepends="gtk+-dev openssl-dev startup-notification-dev enchant-dev
libgcrypt-dev libsm-dev gnutls-dev curl-dev dbus-glib-dev
libetpan-dev openldap-dev gpgme-dev"
@@ -14,6 +19,7 @@ depends=
install=
source="http://downloads.sourceforge.net/sourceforge/sylpheed-claws/$pkgname-$pkgver.tar.bz2
libc-version.patch
+ claws_gnutls.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -37,7 +43,9 @@ build() {
--disable-crash-dialog \
--enable-pgpmime-plugin \
--enable-spamassassin-plugin \
- --enable-bogofilter-plugin \
+ --disable-bogofilter-plugin \
+ --enable-trayicon-plugin \
+ --enable-compface \
--disable-jpilot \
|| return 1
@@ -53,9 +61,34 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/claws-mail/plugins/*.la
- find tools -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i; do
+ find tools -maxdepth 1 -type f -and -perm 111 -or -name '*.conf' | while read i; do
install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
done
}
+
+pgp() {
+ pkgdesc="PGP plugin for signing and encrypting with Claws Mail"
+ depends="pinentry-gtk"
+ mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
+ mv "$pkgdir"/usr/lib/claws-mail/plugins/pgp* \
+ "$subpkgdir"/usr/lib/claws-mail/plugins/
+}
+
+spamassassin() {
+ pkgdesc="Spamassassin plugin for Claws Mail"
+ depends="spamassassin"
+ mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
+ mv "$pkgdir"/usr/lib/claws-mail/plugins/spamass* \
+ "$subpkgdir"/usr/lib/claws-mail/plugins/
+}
+
+smime() {
+ pkgdesc="S/MIME support for Claws Mail"
+ mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
+ mv "$pkgdir"/usr/lib/claws-mail/plugins/smime* \
+ "$subpkgdir"/usr/lib/claws-mail/plugins/
+}
+
md5sums="df9f1657d7f34959a2205344d952c2e3 claws-mail-3.8.0.tar.bz2
-f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch"
+f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch
+7b5d7503a921d19350b0d7f1bc6a2910 claws_gnutls.patch"
diff --git a/main/claws-mail/claws_gnutls.patch b/main/claws-mail/claws_gnutls.patch
new file mode 100644
index 00000000000..315a0eddb7b
--- /dev/null
+++ b/main/claws-mail/claws_gnutls.patch
@@ -0,0 +1,16 @@
+
+http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2646
+
+diff --git a/src/common/ssl_certificate.c b/src/common/ssl_certificate.c
+index f37e51f..4911acb 100644
+--- a/src/common/ssl_certificate.c
++++ b/src/common/ssl_certificate.c
+@@ -686,7 +686,7 @@ parse_pkcs12 (gnutls_pkcs12_t p12,
+ gnutls_x509_privkey * key,
+ gnutls_x509_crt_t * cert)
+ {
+- gnutls_pkcs12_bag bag = NULL;
++ gnutls_pkcs12_bag_t bag = NULL;
+ int index = 0;
+ int ret;
+