aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/inkscape/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/community/inkscape/APKBUILD b/community/inkscape/APKBUILD
index a3eb3325b8b..669841b1b3a 100644
--- a/community/inkscape/APKBUILD
+++ b/community/inkscape/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=inkscape
pkgver=0.92.4
-pkgrel=4
+pkgrel=5
pkgdesc="A vector-based drawing program - svg compliant"
url="https://inkscape.org/"
arch="all"
@@ -31,7 +31,6 @@ source="https://launchpad.net/inkscape/${pkgver%.*}.x/$pkgver/+download/inkscape
poppler-082.patch
"
options="!check" # cxxtest hangs at least on x86_64
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
@@ -52,7 +51,6 @@ prepare() {
}
build() {
- cd "$builddir"
CXXFLAGS="$CXXFLAGS -std=c++11" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -66,12 +64,10 @@ build() {
}
check() {
- cd "$builddir"
PATH="$PATH:$PWD" make -C src check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}