aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-pygit2/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-pygit2/APKBUILD b/community/py3-pygit2/APKBUILD
index 1d1a1087cf1..9f8a21e2aa7 100644
--- a/community/py3-pygit2/APKBUILD
+++ b/community/py3-pygit2/APKBUILD
@@ -4,13 +4,14 @@
pkgname=py3-pygit2
_pkgname=pygit2
pkgver=1.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Python bindings for libgit2"
url="https://github.com/libgit2/pygit2"
arch="all"
license="GPL-2.0 WITH GCC-exception-2.0"
depends="py3-cffi py3-six"
makedepends="python3-dev py3-setuptools libgit2-dev"
+checkdepends="py3-pytest py3-hypothesis"
source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -18,11 +19,11 @@ replaces="py-pygit" # Backward compat
provides="py-pygit=$pkgver-r$pkgrel" # Backward compat
build() {
- python3 setup.py build
+ python3 setup.py build_ext --inplace
}
check() {
- python3 setup.py check
+ pytest-3
}
package() {