aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/step-certificates/01-Makefile-GOFLAGS.patch10
-rw-r--r--testing/step-certificates/02-Makefile-yubikey-and-pkcs11-binary.patch8
-rw-r--r--testing/step-certificates/APKBUILD24
3 files changed, 23 insertions, 19 deletions
diff --git a/testing/step-certificates/01-Makefile-GOFLAGS.patch b/testing/step-certificates/01-Makefile-GOFLAGS.patch
index 402e5b9b057..e2aab0d0b43 100644
--- a/testing/step-certificates/01-Makefile-GOFLAGS.patch
+++ b/testing/step-certificates/01-Makefile-GOFLAGS.patch
@@ -7,7 +7,7 @@ This patch fixes some shell quoting issues. GOFLAGS was not being honored.
diff -aur a/Makefile b/Makefile
--- a/Makefile
+++ b/Makefile
-@@ -75,7 +75,7 @@
+@@ -86,7 +86,7 @@
DATE := $(shell date -u '+%Y-%m-%d %H:%M UTC')
LDFLAGS := -ldflags='-w -X "main.Version=$(VERSION)" -X "main.BuildTime=$(DATE)"'
@@ -16,7 +16,7 @@ diff -aur a/Makefile b/Makefile
download:
$Q go mod download
-@@ -85,23 +85,23 @@
+@@ -96,23 +96,23 @@
$(PREFIX)bin/$(BINNAME): download $(call rwildcard,*.go)
$Q mkdir -p $(@D)
@@ -45,7 +45,7 @@ diff -aur a/Makefile b/Makefile
# Target to force a build of step-ca without running tests
simple: build
-@@ -121,7 +121,7 @@
+@@ -132,7 +132,7 @@
# Test
#########################################
test:
@@ -54,7 +54,7 @@ diff -aur a/Makefile b/Makefile
testcgo:
$Q go test -short -coverprofile=coverage.out ./...
-@@ -131,7 +131,7 @@
+@@ -142,7 +142,7 @@
integrate: integration
integration: bin/$(BINNAME)
@@ -63,7 +63,7 @@ diff -aur a/Makefile b/Makefile
.PHONY: integrate integration
-@@ -143,7 +143,7 @@
+@@ -154,7 +154,7 @@
$Q gofmt -l -w $(SRC)
lint:
diff --git a/testing/step-certificates/02-Makefile-yubikey-and-pkcs11-binary.patch b/testing/step-certificates/02-Makefile-yubikey-and-pkcs11-binary.patch
index 0d15c2e346c..32ce59e0855 100644
--- a/testing/step-certificates/02-Makefile-yubikey-and-pkcs11-binary.patch
+++ b/testing/step-certificates/02-Makefile-yubikey-and-pkcs11-binary.patch
@@ -9,7 +9,7 @@ Enable building of Yubikey KMS binary, to do this also enable CGO.
diff -aur a/Makefile b/Makefile
--- a/Makefile
+++ b/Makefile
-@@ -75,7 +75,7 @@
+@@ -86,7 +86,7 @@
DATE := $(shell date -u '+%Y-%m-%d %H:%M UTC')
LDFLAGS := -ldflags='-w -X "main.Version=$(VERSION)" -X "main.BuildTime=$(DATE)"'
@@ -18,7 +18,7 @@ diff -aur a/Makefile b/Makefile
download:
$Q go mod download
-@@ -156,15 +156,19 @@
+@@ -167,15 +167,19 @@
INSTALL_PREFIX?=/usr/
@@ -27,8 +27,8 @@ diff -aur a/Makefile b/Makefile
$Q install -D $(PREFIX)bin/$(BINNAME) $(DESTDIR)$(INSTALL_PREFIX)bin/$(BINNAME)
$Q install -D $(PREFIX)bin/$(CLOUDKMS_BINNAME) $(DESTDIR)$(INSTALL_PREFIX)bin/$(CLOUDKMS_BINNAME)
$Q install -D $(PREFIX)bin/$(AWSKMS_BINNAME) $(DESTDIR)$(INSTALL_PREFIX)bin/$(AWSKMS_BINNAME)
-+ $Q install -D $(PREFIX)bin/$(AWSKMS_BINNAME) $(DESTDIR)$(INSTALL_PREFIX)bin/$(YUBIKEY_BINNAME)
-+ $Q install -D $(PREFIX)bin/$(AWSKMS_BINNAME) $(DESTDIR)$(INSTALL_PREFIX)bin/$(PKCS11_BINNAME)
++ $Q install -D $(PREFIX)bin/$(YUBIKEY_BINNAME) $(DESTDIR)$(INSTALL_PREFIX)bin/$(YUBIKEY_BINNAME)
++ $Q install -D $(PREFIX)bin/$(PKCS11_BINNAME) $(DESTDIR)$(INSTALL_PREFIX)bin/$(PKCS11_BINNAME)
uninstall:
$Q rm -f $(DESTDIR)$(INSTALL_PREFIX)/bin/$(BINNAME)
diff --git a/testing/step-certificates/APKBUILD b/testing/step-certificates/APKBUILD
index dc8161f486e..865155cea33 100644
--- a/testing/step-certificates/APKBUILD
+++ b/testing/step-certificates/APKBUILD
@@ -3,16 +3,11 @@
# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
# Maintainer: Dermot Bradley <dermot_bradley@yahoo.com>
pkgname=step-certificates
-pkgver=0.15.8
-pkgrel=1
+pkgver=0.16.0
+pkgrel=0
pkgdesc="Online certificate authority and related tools"
url="https://smallstep.com/certificates/"
arch="all !s390x !mips !mips64"
-options="!check" # No tests as fails for Yubikey
-source="$pkgname-$pkgver.tar.gz::https://github.com/smallstep/certificates/archive/v$pkgver.tar.gz
- 01-Makefile-GOFLAGS.patch
- 02-Makefile-yubikey-and-pkcs11-binary.patch
- "
license="Apache-2.0"
makedepends="
bash
@@ -20,6 +15,12 @@ makedepends="
go-bindata
pcsc-lite-dev
"
+depends="step-cli"
+options="!check" # No tests as fails for Yubikey
+source="$pkgname-$pkgver.tar.gz::https://github.com/smallstep/certificates/archive/v$pkgver.tar.gz
+ 01-Makefile-GOFLAGS.patch
+ 02-Makefile-yubikey-and-pkcs11-binary.patch
+ "
builddir="$srcdir/certificates-$pkgver"
build() {
@@ -33,6 +34,9 @@ check() {
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b416668c4494f097f57d700f57412b3aafce93915444a3cd4d1a3bb8692bc14cb701e55c355e09b901a4ea44f18a48b0541bf3614c5be2510e9d7c2b11ab7e7a step-certificates-0.15.8.tar.gz
-e74ef2adf9460a3075a7e847dad70483455b338f5ed4bd803a25a272c14003f6c8dd28e01873c88aa8f58b45086a6d91b353bee8b9d54053aa4bc4699d8eccfa 01-Makefile-GOFLAGS.patch
-e5eee342e3c16e732c924114e944332a940dffbb13ed94fa506ebd09274a21cd27d103c3c90dc7a717f960ac194938c0910690c33116594f1a0aa7afc6933ee6 02-Makefile-yubikey-and-pkcs11-binary.patch"
+
+sha512sums="
+a6a02f49f7b7281662cdac51018b19d937457667e33b23965613993310fcc78de0aeb1d4d2d310688c11f97611baa0ede8587dbb1716b1ab6e462a0017ac03ca step-certificates-0.16.0.tar.gz
+5cce04fd9233a1de480426d77c21a5318a9d68926ce63dc6b8b14b2061b73312a685971e695ead40c066a24557414b6a00f8bfbab4e64d1e39679378e8970315 01-Makefile-GOFLAGS.patch
+0b49bda9b0b0df9d9e10ab96405a8eff5b50aaf354b8ce424d4f085ef7b033d98169521f798b27dce3959ea18cf97da365613417c40a3d54779fad7ecc15e3d4 02-Makefile-yubikey-and-pkcs11-binary.patch
+"