aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-partd/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/py3-partd/APKBUILD b/community/py3-partd/APKBUILD
index 1132eb9f50e..c3de3eab8c4 100644
--- a/community/py3-partd/APKBUILD
+++ b/community/py3-partd/APKBUILD
@@ -1,13 +1,20 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-partd
-pkgver=1.1.0
-pkgrel=1
+pkgver=1.2.0
+pkgrel=0
pkgdesc="Concurrent appendable key-value storage"
url="https://github.com/dask/partd/"
arch="noarch !mips !mips64 !s390x" # Blocked by py3-pyzmq
license="BSD-3-Clause"
-depends="python3 py3-toolz py3-numpy py3-pyzmq py3-pandas py3-locket"
+depends="
+ py3-locket
+ py3-numpy
+ py3-pandas
+ py3-pyzmq
+ py3-toolz
+ python3
+ "
makedepends="py3-setuptools"
source="https://pypi.python.org/packages/source/p/partd/partd-$pkgver.tar.gz"
options="!check" # No tests
@@ -17,12 +24,10 @@ build() {
python3 setup.py build
}
-check() {
- python3 setup.py test
-}
-
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="5e26c4a63fc2f9a290b211c1fce291da6b3354b4d0fdf941d29ddad1252629c94275ac360d33c88d11ff4e36a4f4d6bee42edd867c92eb7ef0d2697472c9a338 partd-1.1.0.tar.gz"
+sha512sums="
+dbcf6a73e23aacd6502f0669abcb8e51547f280b1b7b94baa7ab5637cd838f8427ad1c4e39127fb7f8b164f3a83b66611b2c71667d31fe0137619fb6c457fab9 partd-1.2.0.tar.gz
+"