aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pytest-aiohttp/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-pytest-aiohttp/APKBUILD b/testing/py3-pytest-aiohttp/APKBUILD
new file mode 100644
index 00000000000..7ccb31d3867
--- /dev/null
+++ b/testing/py3-pytest-aiohttp/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+pkgname=py3-pytest-aiohttp
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="pytest plugin for aiohttp support"
+options="!check" # no testsuite
+url="https://github.com/aio-libs/pytest-aiohttp/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/p/pytest-aiohttp/pytest-aiohttp-$pkgver.tar.gz"
+builddir="$srcdir/pytest-aiohttp-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="4164166465dc40ff78a86304d1bcd4db9fb3f7dad3188f8ebe2ff151ed51eb0bf9c1b7a608d94cfe3339ee3b6efd4d5abbaa0691388460d5ac95635afa14984c pytest-aiohttp-0.3.0.tar.gz"