aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/cmake/APKBUILD12
-rw-r--r--main/cmake/musl-header-fixes.patch13
2 files changed, 4 insertions, 21 deletions
diff --git a/main/cmake/APKBUILD b/main/cmake/APKBUILD
index 8eb52a48805..e379b9db7a1 100644
--- a/main/cmake/APKBUILD
+++ b/main/cmake/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cmake
-pkgver=3.4.0
+pkgver=3.4.1
pkgrel=0
pkgdesc="CMake is a cross-platform open-source make system"
url="http://www.cmake.org"
@@ -16,7 +16,6 @@ case $pkgver in
esac
source="http://www.cmake.org/files/$_v/cmake-${pkgver}.tar.gz
- musl-header-fixes.patch
"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -60,9 +59,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="cd3034e0a44256a0917e254167217fc8 cmake-3.4.0.tar.gz
-500d40f006182e7f4e3e594347882fdf musl-header-fixes.patch"
-sha256sums="a5b82bf6ace6c481cdb911fd5d372a302740cbefd387e05297cb37f7468d1cea cmake-3.4.0.tar.gz
-7169e21d649b35c031a615986ebc559d772d40667506ce495cbc51f828825ae8 musl-header-fixes.patch"
-sha512sums="3600faa8475840e350954c8273829c1fb6dc63984860455b792b520e20a8fd9864c96d7afd6b42a6937624edf49b73c8807aa230a3ee9c24aa7aec136022bc90 cmake-3.4.0.tar.gz
-36ec0e51b4b1f00f8d7439d3e5a39ee8882704f69ec1ca901010ffba4914e7949aefafdb6698c28b966d5bccfa209aca993c228a37189ced047203d02644127c musl-header-fixes.patch"
+md5sums="73acda0d33be9b2729af99893d99a012 cmake-3.4.1.tar.gz"
+sha256sums="d41462bdd80dc37f0d5608167b354bb3af8c068eee640be04c907154c5c113e2 cmake-3.4.1.tar.gz"
+sha512sums="072bbfc3ffe3a838945ce6e7c4bbce267362673c3b870886accdc5a5ee01dbd071604fca6aa519d077676423d37bfe987b71f22f14a194f8d6ec8fb9de0a6049 cmake-3.4.1.tar.gz"
diff --git a/main/cmake/musl-header-fixes.patch b/main/cmake/musl-header-fixes.patch
deleted file mode 100644
index edbdc270e34..00000000000
--- a/main/cmake/musl-header-fixes.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-mode_t needs sys/stat.h
-
---- ./Source/cmStandardIncludes.h.orig
-+++ ./Source/cmStandardIncludes.h
-@@ -74,6 +74,8 @@
-
- #if defined( _MSC_VER )
- typedef unsigned short mode_t;
-+#else
-+#include <sys/stat.h>
- #endif
-
- // use this class to shrink the size of symbols in .o files