aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/moc/APKBUILD16
-rw-r--r--community/moc/ffmpeg-3.patch14
-rw-r--r--community/moc/ffmpeg4.patch34
3 files changed, 47 insertions, 17 deletions
diff --git a/community/moc/APKBUILD b/community/moc/APKBUILD
index 54ac61de50d..dd6ad0fa447 100644
--- a/community/moc/APKBUILD
+++ b/community/moc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=moc
pkgver=2.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="MOC is a console audio player"
url="http://moc.daper.net/"
arch="all"
@@ -10,7 +10,11 @@ license="GPL"
makedepends="curl-dev libtool file ffmpeg-dev speex-dev alsa-lib-dev
libmodplug-dev faad2-dev jack-dev libmad-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="http://ftp.daper.net/pub/soft/moc/stable/moc-${pkgver}.tar.bz2"
+# ffmpeg4.patch courtesy of Arch Linux
+source="
+ http://ftp.daper.net/pub/soft/moc/stable/moc-${pkgver}.tar.bz2
+ ffmpeg4.patch
+"
builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -45,9 +49,15 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="${pkgdir}" install
}
-sha512sums="992d06809fb52e58dcee63704bde05795b99edbac46edd8381f314c564490013b18e1853926f419c2c3c7f1bb68ff35e97048de03ace3232b800cf4b3b7dbe0f moc-2.5.2.tar.bz2"
+sha512sums="992d06809fb52e58dcee63704bde05795b99edbac46edd8381f314c564490013b18e1853926f419c2c3c7f1bb68ff35e97048de03ace3232b800cf4b3b7dbe0f moc-2.5.2.tar.bz2
+a2af41467573b6f674be4007fda5990035513da6733030b882874dd44562b75c88c63e60c1d84a7b6522191bb4dbc38fb4e7d8462ba4add7425643dcbbf6d315 ffmpeg4.patch"
diff --git a/community/moc/ffmpeg-3.patch b/community/moc/ffmpeg-3.patch
deleted file mode 100644
index f6d32254442..00000000000
--- a/community/moc/ffmpeg-3.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/decoder_plugins/ffmpeg/ffmpeg.c b/decoder_plugins/ffmpeg/ffmpeg.c
-index 206b2b1..6af6759 100644
---- a/decoder_plugins/ffmpeg/ffmpeg.c
-+++ b/decoder_plugins/ffmpeg/ffmpeg.c
-@@ -66,9 +66,6 @@ GCC_DIAG_OFF(deprecated-declarations)
- #include <libavformat/avformat.h>
- GCC_DIAG_ON(deprecated-declarations)
- #include <libavutil/mathematics.h>
--#ifdef HAVE_AV_GET_CHANNEL_LAYOUT_NB_CHANNELS
--#include <libavutil/audioconvert.h>
--#endif
- #else
- #include <ffmpeg/avformat.h>
- #endif
diff --git a/community/moc/ffmpeg4.patch b/community/moc/ffmpeg4.patch
new file mode 100644
index 00000000000..8ebd9466153
--- /dev/null
+++ b/community/moc/ffmpeg4.patch
@@ -0,0 +1,34 @@
+Index: a/decoder_plugins/ffmpeg/ffmpeg.c
+===================================================================
+--- a/decoder_plugins/ffmpeg/ffmpeg.c (revisiĆ³n: 2963)
++++ b/decoder_plugins/ffmpeg/ffmpeg.c (copia de trabajo)
+@@ -697,7 +697,7 @@
+ * FFmpeg/LibAV in use. For some versions this will be caught in
+ * *_find_stream_info() above and misreported as an unfound codec
+ * parameters error. */
+- if (data->codec->capabilities & CODEC_CAP_EXPERIMENTAL) {
++ if (data->codec->capabilities & AV_CODEC_CAP_EXPERIMENTAL) {
+ decoder_error (&data->error, ERROR_FATAL, 0,
+ "The codec is experimental and may damage MOC: %s",
+ data->codec->name);
+@@ -705,8 +705,8 @@
+ }
+
+ set_downmixing (data);
+- if (data->codec->capabilities & CODEC_CAP_TRUNCATED)
+- data->enc->flags |= CODEC_FLAG_TRUNCATED;
++ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
++ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
+
+ if (avcodec_open2 (data->enc, data->codec, NULL) < 0)
+ {
+@@ -725,7 +725,7 @@
+
+ data->sample_width = sfmt_Bps (data->fmt);
+
+- if (data->codec->capabilities & CODEC_CAP_DELAY)
++ if (data->codec->capabilities & AV_CODEC_CAP_DELAY)
+ data->delay = true;
+ data->seek_broken = is_seek_broken (data);
+ data->timing_broken = is_timing_broken (data->ic);
+