aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/openocd-git/APKBUILD15
-rw-r--r--testing/openocd-git/fix-dynamic-linking.patch25
2 files changed, 8 insertions, 32 deletions
diff --git a/testing/openocd-git/APKBUILD b/testing/openocd-git/APKBUILD
index 00778d41989..d0d1be3904e 100644
--- a/testing/openocd-git/APKBUILD
+++ b/testing/openocd-git/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
_pkgname=openocd
-_commit=28c91b8f80937e6ec6521496f363038d9a5f9a04
+_commit=2586fec922ae9ea9bea345f40598e0367934d22c
pkgname=$_pkgname-git
-pkgver=20210702
-pkgrel=1
+pkgver=20220305
+pkgrel=0
pkgdesc="Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
url="http://openocd.org/"
arch="all"
@@ -14,9 +14,11 @@ makedepends="libftdi1-dev libusb-dev hidapi-dev jimtcl-dev
provides="openocd"
subpackages="$pkgname-dev $pkgname-doc"
# Note: Using a github mirror here as sourceforge git snapshots have changing checksums
-source="$_pkgname-$_commit.tar.gz::https://github.com/openocd-org/openocd/archive/$_commit.tar.gz
+source="
+ $_pkgname-$_commit.tar.gz::https://github.com/openocd-org/openocd/archive/$_commit.tar.gz
+
fix-jimtcl-link.patch
- fix-dynamic-linking.patch"
+ "
builddir="$srcdir/$_pkgname-$_commit"
prepare() {
@@ -50,7 +52,6 @@ package() {
}
sha512sums="
-c1f02277262ec3cc168b18a71d436a123f08e5246e35f94e37c922618c9d91e34b8ca525eed1f93a2ce37315f23c6d9a6a8f88ca4c2bc16bc3e432127ffcd70d openocd-28c91b8f80937e6ec6521496f363038d9a5f9a04.tar.gz
+f89c1c8daca4cef4ca705f4dacd2671c5d4a5d5a82c4c4da04e33073af127af62c600dc2726ee445ddb88901f9323d4444c9885b8166e90a7308004116e196e3 openocd-2586fec922ae9ea9bea345f40598e0367934d22c.tar.gz
6fd2fbe11917bb7f181ba67812f63e75d51bcd19e4df6a7e22e1abb8f36a4f4bdc9202e815f560476ec184d54d84df8ae4dceb17f2429b9dc1d9503804dacb03 fix-jimtcl-link.patch
-a0980806af54bafd759c2e329cd11eabf0eb352f7f823966ab0f4a60508559fb7abd41072c0a882da0906ddf086ee139115deca04bb1a70ab915b50a1d3fc2e7 fix-dynamic-linking.patch
"
diff --git a/testing/openocd-git/fix-dynamic-linking.patch b/testing/openocd-git/fix-dynamic-linking.patch
deleted file mode 100644
index 44cec606308..00000000000
--- a/testing/openocd-git/fix-dynamic-linking.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Without this patch, linking against libjim dynamically will cause an
-infinite loop. We just fix the memory leak, for which this thingy is
-supposed to be a workaround, directly in the jimtcl package instead.
-
-See: https://gitlab.alpinelinux.org/alpine/aports/-/issues/13046#note_182639
-
-diff -upr a/src/helper/command.c b/src/helper/command.c
---- a/src/helper/command.c 2021-10-02 11:47:43.452995606 +0200
-+++ b/src/helper/command.c 2021-10-02 11:51:10.803049538 +0200
-@@ -148,9 +148,14 @@ static void command_log_capture_finish(s
- * If jimtcl is linked-in from a precompiled library, either static or dynamic,
- * the symbol Jim_CreateCommandObj is not exported and the build will use the
- * bugged API.
-+ *
-+ * This workaround creates an infinite loop when OpenOCD is linked
-+ * dynamically against jimtcl on Alpine and thus only enabled if the internal
-+ * version of jimtcl is used.
-+ *
- * To be removed when OpenOCD will switch to jimtcl 0.81
- */
--#if JIM_VERSION == 80 && defined __linux__
-+#if JIM_VERSION == 80 && defined __linux__ && defined INTERNAL_JIMTCL
- static int workaround_createcommand(Jim_Interp *interp, const char *cmdName,
- Jim_CmdProc *cmdProc, void *privData, Jim_DelCmdProc *delProc);
- int Jim_CreateCommandObj(Jim_Interp *interp, Jim_Obj *cmdNameObj,