aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/tcpflow/APKBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/main/tcpflow/APKBUILD b/main/tcpflow/APKBUILD
index d1e81a7317b..421739fd8d4 100644
--- a/main/tcpflow/APKBUILD
+++ b/main/tcpflow/APKBUILD
@@ -2,34 +2,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tcpflow
pkgver=1.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="A Tool for monitoring, capturing and storing TCP connections flows"
url="https://github.com/simsong/tcpflow"
arch="all"
-license="GPL-3.0"
-depends=""
+license="GPL-3.0-only"
makedepends="libpcap-dev zlib-dev boost-dev openssl-dev autoconf automake"
-install=""
subpackages="$pkgname-doc"
-source="https://fossies.org/linux/misc/$pkgname-$pkgver.tar.gz
+source="https://fossies.org/linux/misc/tcpflow-$pkgver.tar.gz
CVE-2018-18409.patch
"
# secfixes:
# 1.5.2-r1:
-# - CVE-2018-18409
+# - CVE-2018-18409
-builddir="$srcdir"/tcpflow-$pkgver
prepare() {
- cd "$builddir"
default_prepare
sed -i 's/test-pdfs.sh//' tests/Makefile.am
autoreconf -fsiv
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}