aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/rpm/APKBUILD28
-rw-r--r--community/rpm/include-fcntl.patch15
-rw-r--r--community/rpm/musl.patch3
3 files changed, 33 insertions, 13 deletions
diff --git a/community/rpm/APKBUILD b/community/rpm/APKBUILD
index 461478ddb2c..57f226f5832 100644
--- a/community/rpm/APKBUILD
+++ b/community/rpm/APKBUILD
@@ -1,32 +1,31 @@
# Contributor:
# Maintainer:
pkgname=rpm
-# When updating to 4.16.x:
-# - Enable sqlite and switch to it
-# - Remove bdb (deprecated) and enable bdb_ro
-pkgver=4.15.1
-pkgrel=2
+pkgver=4.16.0
+pkgrel=0
pkgdesc="Redhat Package Management utilities (RPM)"
url="https://www.rpm.org/"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
-depends_dev="acl-dev binutils-dev bzip2-dev db-dev file-dev libarchive-dev
- libcap-dev nspr-dev nss-dev popt-dev xz-dev zlib-dev"
+depends_dev="acl-dev binutils-dev bzip2-dev sqlite-dev file-dev libarchive-dev
+ libcap-dev libgcrypt-dev popt-dev xz-dev zlib-dev"
makedepends="$depends_dev gettext-dev graphviz py3-setuptools python3-dev
zstd-dev automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py3-rpm:py_rpm"
source="http://ftp.rpm.org/releases/rpm-${pkgver%.*}.x/rpm-$pkgver.tar.bz2
musl.patch
+ include-fcntl.patch
"
prepare() {
+ # Switch to sqlite db by default, including during build-time tests
+ sed -i -e "/_db_backend/ s/ bdb/ sqlite/g" macros.in
+
default_prepare
autoreconf -fi
}
build() {
- _EXT_CPPFLAGS="-I/usr/include/nspr -I/usr/include/nss" \
- CFLAGS="$CFLAGS $_EXT_CPPFLAGS" CPPFLAGS="$CPPFLAGS $_EXT_CPPFLAGS" \
LIBS="$LIBS -lintl" \
PYTHON=python3 \
./configure --prefix=/usr \
@@ -34,13 +33,15 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --with-external-db \
--with-cap \
--with-acl \
--without-lua \
--enable-python \
--enable-zstd=yes \
- --with-crypto=nss \
+ --enable-sqlite=yes \
+ --enable-bdb_ro=yes \
+ --enable-bdb=no \
+ --with-crypto=libgcrypt \
--disable-plugins
make
}
@@ -59,5 +60,6 @@ py_rpm() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib
}
-sha512sums="6c66835da5a54349bcfba5cc69831c8c57568aabd53c5c2820ec78c361be5116fecd41777b097e9c49458f984a7beb054fa8ed453ff7263cad4a29a11f780767 rpm-4.15.1.tar.bz2
-7972e9b129749b69b1c3b795cdc9981ff77e47954fe05f4885ce4d1b970eff4c0ad0393fa47ab43086dbfe7c0b7660b00860a978593da484aae514097e940868 musl.patch"
+sha512sums="177119c3ac3d48980db55bb4ba0fdbb2a911968e5efc690bfa8cc343f850fc90531cc0dee6dd8e45d2b14f0d951ced35bd8893d24011b7f270745d281ddf4e3d rpm-4.16.0.tar.bz2
+212a4265abc8d002e16bed106b8b773cf65564f95e6074bc1378c4745420202a476373b49b660bdfe82cc2470c35fff4f184168a698abfa2a4bf30c8f91e64ad musl.patch
+6424005c78aaebcd3565debbdc1ca14fb16ef8f4aa79748eca3403115a31c77afbb8929add1a8450afbd0496e303c915c6ad6d60cde41a89caf553a10256ace5 include-fcntl.patch"
diff --git a/community/rpm/include-fcntl.patch b/community/rpm/include-fcntl.patch
new file mode 100644
index 00000000000..611b92935e0
--- /dev/null
+++ b/community/rpm/include-fcntl.patch
@@ -0,0 +1,15 @@
+Upstream: Yes, https://github.com/rpm-software-management/rpm/pull/1379
+Reason: Fixes compilation with musl
+
+diff --git a/lib/rpmdb.c b/lib/rpmdb.c
+index 4c10156..7318763 100644
+--- a/lib/rpmdb.c
++++ b/lib/rpmdb.c
+@@ -8,6 +8,7 @@
+ #include <utime.h>
+ #include <errno.h>
+ #include <dirent.h>
++#include <fcntl.h>
+
+ #ifndef DYING /* XXX already in "system.h" */
+ #include <fnmatch.h>
diff --git a/community/rpm/musl.patch b/community/rpm/musl.patch
index 7c894b70227..65f3a10aa44 100644
--- a/community/rpm/musl.patch
+++ b/community/rpm/musl.patch
@@ -1,3 +1,6 @@
+Upstream: No
+Reason: Fixes compilation with musl
+
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,7 @@ AC_SEARCH_LIBS(dlopen, [dl])