aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libglacierapp/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/testing/libglacierapp/APKBUILD b/testing/libglacierapp/APKBUILD
index a60a39fb48f..2540c4d36b2 100644
--- a/testing/libglacierapp/APKBUILD
+++ b/testing/libglacierapp/APKBUILD
@@ -1,24 +1,28 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libglacierapp
-pkgver=0.4.0
+pkgver=0.6
pkgrel=0
-pkgdesc="libglacierapp"
+pkgdesc="Glacier applications wrapper library"
url="https://github.com/nemomobile-ux/libglacierapp"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
license="LGPL-2.0-or-later"
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
-makedepends="$depends_dev"
+makedepends="$depends_dev cmake"
subpackages="$pkgname-dev"
source="https://github.com/nemomobile-ux/libglacierapp/archive/$pkgver/libglacierapp-$pkgver.tar.gz"
+options="!check" # No tests
build() {
- qmake-qt5
- make
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
package() {
- INSTALL_ROOT="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="ffa9fe41c2bc9ef875226cd94b18b3a206a5c73bb4db0b259a6abae67601cb5e2853e8cfa3bfc936fe488ca37459d3f5c39928d8188de761fd7889c5093052d0 libglacierapp-0.4.0.tar.gz"
+sha512sums="6136e5a787704d2a02174d89506e9e81a160149a8f178523c9023acd037b5302e76403205545225dda4c061067ed47593ccbaeaa7bf27a3604d27172ec8fd4bd libglacierapp-0.6.tar.gz"