aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ktoblzcheck/APKBUILD37
1 files changed, 13 insertions, 24 deletions
diff --git a/community/ktoblzcheck/APKBUILD b/community/ktoblzcheck/APKBUILD
index af35555d784..ad4654c021c 100644
--- a/community/ktoblzcheck/APKBUILD
+++ b/community/ktoblzcheck/APKBUILD
@@ -1,42 +1,31 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=ktoblzcheck
-pkgver=1.49
-pkgrel=1
+pkgver=1.50
+pkgrel=0
pkgdesc="A library to check account numbers and bank codes of german banks"
url="http://ktoblzcheck.sourceforge.net/"
arch="all"
-license="LGPL"
-depends=""
-makedepends=""
-install=""
+license="LGPL-2.1-or-later"
+makedepends="cmake python2-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://downloads.sourceforge.net/sourceforge/ktoblzcheck/ktoblzcheck-$pkgver.tar.gz"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_BANKDATA_DOWNLOAD=OFF
make
}
check() {
- make -C "$builddir" check
+ ctest
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
- install -m644 AUTHORS README NEWS ChangeLog \
- "$pkgdir"/usr/share/doc/$pkgname/
+ DESTDIR="$pkgdir" make install
}
-sha512sums="da2321112a78b11ccaa938ec295275cb27a4830de0de62e7b9335f2991b9ca335f0ad10e422d9dcbd32a16effc2fc59f3cdde0fd732a639d3e6a39e141081aaa ktoblzcheck-1.49.tar.gz"
+sha512sums="b34b771d1f4f1935c714ecded1c09066846385485ea4b7b21dd5219a01acec7e7204c1da723b42babda5d3f21f4471d1a1902bb7b5350d0f564ae3447c1d154d ktoblzcheck-1.50.tar.gz"