aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/flex/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/main/flex/APKBUILD b/main/flex/APKBUILD
index fe03b8dfa02..f3e3225ae6c 100644
--- a/main/flex/APKBUILD
+++ b/main/flex/APKBUILD
@@ -2,19 +2,17 @@
# Contributor: Arch3y <arch3y@riseup.net>
pkgname=flex
pkgver=2.6.4
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for generating text-scanning programs"
url="https://github.com/westes/flex"
arch="all"
-license="BSD and LGPL-2.0-or-later"
+license="BSD-2-Clause AND LGPL-2.0-or-later"
depends="m4"
depends_dev="flex"
-makedepends="$depends_dev m4 bison help2man"
+makedepends="$depends_dev bison help2man"
subpackages="$pkgname-doc $pkgname-libs $pkgname-dev"
source="https://github.com/westes/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
build() {
cd "$builddir"
./configure \
@@ -31,8 +29,8 @@ build() {
}
check() {
- cd "$builddir"
- make check
+ cd "$builddir"
+ make check
}
package() {