aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/firefox/APKBUILD23
1 files changed, 20 insertions, 3 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index de7e1d181fc..9ae935fa330 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -2,11 +2,10 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=firefox
pkgver=70.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="https://www.firefox.com/"
-# limited by rust and cargo
-arch="x86_64 aarch64"
+arch="x86_64 armhf aarch64 x86 ppc64le" # limited by rust and cargo, build failure on armv7
license="GPL-3.0-only AND LGPL-2.1-only AND LGPL-3.0-only AND MPL-2.0"
makedepends="
alsa-lib-dev
@@ -120,6 +119,11 @@ build() {
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
case "$CARCH" in
+ x86)
+ # disable-elf-hack: exists only on arm, x86, x86_64
+ _arch_config="--disable-elf-hack"
+ export RUST_TARGET="i686-unknown-linux-musl"
+ ;;
x86_64)
# disable-elf-hack: exists only on arm, x86, x86_64
_arch_config="--disable-elf-hack"
@@ -128,6 +132,19 @@ build() {
aarch64)
export RUST_TARGET="aarch64-unknown-linux-musl"
;;
+ armv7)
+ # disable-elf-hack: exists only on arm, x86, x86_64
+ _arch_config="--disable-elf-hack"
+ export RUST_TARGET="armv7-unknown-linux-musleabihf"
+ ;;
+ armhf)
+ # disable-elf-hack: exists only on arm, x86, x86_64
+ _arch_config="--disable-elf-hack"
+ export RUST_TARGET="arm-unknown-linux-musleabihf"
+ ;;
+ ppc64le)
+ export RUST_TARGET="powerpc64le-unknown-linux-musl"
+ ;;
esac
../configure \