aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/lv2/APKBUILD25
1 files changed, 21 insertions, 4 deletions
diff --git a/community/lv2/APKBUILD b/community/lv2/APKBUILD
index 2ee2d5b69b1..76d34a3a3a8 100644
--- a/community/lv2/APKBUILD
+++ b/community/lv2/APKBUILD
@@ -1,23 +1,32 @@
# Contributor: David Demelier <markand@malikania.fr>
# Maintainer: David Demelier <markand@malikania.fr>
pkgname=lv2
-pkgver=1.18.8
+pkgver=1.18.10
pkgrel=0
pkgdesc="extensible open standard for audio plugins"
url="https://lv2plug.in"
arch="all"
license="ISC"
+depends_dev="$pkgname-specgen=$pkgver-r$pkgrel"
+_pydepends="
+ py3-lxml
+ py3-rdflib
+ py3-markdown
+ py3-pygments
+ python3
+ "
makedepends="
gtk+2.0-dev
libsamplerate-dev
libsndfile-dev
meson
+ $_pydepends
"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev $pkgname-specgen"
source="https://lv2plug.in/spec/lv2-$pkgver.tar.xz"
build() {
- abuild-meson . output
+ abuild-meson -Db_lto=true . output
meson compile -C output
}
@@ -29,6 +38,14 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
+specgen() {
+ pkgdesc="$pkgdesc (python specgen)"
+ depends="$_pydepends"
+
+ amove usr/bin/lv2specgen.py
+ amove usr/share/lv2specgen
+}
+
sha512sums="
-9925290818bd683200bc738e3e9342b946fe82a04d983e89c240ae70b9053a7a59a8d505c522fe7af5b804adeba00fdf94403bd34844ce11e26cc1ff62c2f254 lv2-1.18.8.tar.xz
+ab4bcf593f633b1ed16c0eb6aa4525458a00655ef9c87619bf85eaa966f8fd094a8e871b825f679e0d97923f8bbbf11841ff467022390ca2f1a5b5f66ccd5d1b lv2-1.18.10.tar.xz
"