aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-tqdm/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py-tqdm/APKBUILD b/testing/py-tqdm/APKBUILD
index fbbfa1cfe78..dba30b9b6c3 100644
--- a/testing/py-tqdm/APKBUILD
+++ b/testing/py-tqdm/APKBUILD
@@ -2,7 +2,7 @@
pkgname=py-tqdm
_pkgname=tqdm
pkgver=4.30.0
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, Extensible Progress Meter"
url="https://pypi.python.org/pypi/tqdm"
arch="noarch"
@@ -10,7 +10,7 @@ license="MIT"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
-0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch"
+ 0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch"
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
@@ -18,8 +18,9 @@ prepare() {
cd "$builddir"
case "$CARCH" in
- # XXX: Perf tests fail on aarch64 builder.
+ # FIXME: remove selected failing tests on selected arches
aarch64) rm tqdm/tests/tests_perf.py;;
+ x86) rm tqdm/tests/tests_synchronisation.py;;
esac
}