aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/vault/APKBUILD24
-rw-r--r--testing/vault/bindata-filename.patch14
2 files changed, 30 insertions, 8 deletions
diff --git a/testing/vault/APKBUILD b/testing/vault/APKBUILD
index 4defc832d2c..07db546af28 100644
--- a/testing/vault/APKBUILD
+++ b/testing/vault/APKBUILD
@@ -1,31 +1,38 @@
# Contributor: Christian Kampka <christian@kampka.net>
# Maintainer: Gennady Feldman <gena01@gmail.com>
pkgname=vault
-pkgver=0.11.5
+pkgver=1.0.3
pkgrel=0
pkgdesc="Vault is a tool for securely accessing secrets"
url="https://www.vaultproject.io/"
arch="all !s390x"
license="MPL-2.0"
-depends=""
-makedepends="go"
+makedepends="libcap bash make go python2 yarn npm go-bindata-assetfs"
install="$pkgname.pre-install"
pkgusers="vault"
pkggroups="vault"
subpackages="$pkgname-openrc"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz
+ bindata-filename.patch
vault.confd
vault.hcl
vault.initd"
-builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/src/github.com/hashicorp/$pkgname"
+
+prepare() {
+ mkdir -p "$srcdir/src/github.com/hashicorp"
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+ default_prepare
+}
build() {
cd "$builddir"
- mkdir -p "$builddir/src/github.com/hashicorp"
- ln -s "$builddir" "$builddir/src/github.com/hashicorp/vault"
- GOPATH="$builddir" go build -v -o bin/$pkgname --tags="vault"
+ GOPATH="$srcdir" CGO_ENABLED=0 make static-dist prep
+ GOPATH="$srcdir" CGO_ENABLED=0 go build -v -o bin/$pkgname \
+ -ldflags "-X github.com/hashicorp/vault/version.GitDescribe='$pkgver'" \
+ --tags ui
}
package() {
@@ -50,7 +57,8 @@ package() {
install -m750 -o vault -g vault -d "$pkgdir/var/lib/$pkgname"
}
-sha512sums="b290523ee94199d241bbd2477ca686076f645804953181996aefe2a425bc5114db3d375fd5c832d1fa257a790947544406f50777317e854ccf2d4d4477ab6ffd vault-0.11.5.tar.gz
+sha512sums="fde77e92c381d4fc76907f6dc51946085ff15439cebd44433ad35f5f60edad031c00ce050669d402ad1d95d9d6aa2e8fb96864535f02251cb9788e723d4355b6 vault-1.0.3.tar.gz
+0a2dc4d2deb42c77a225451a3c3cf68063435bc077495a6b207cfa2e2b446c9dba5ac726f9a7ec0be7f52e4519e7563c49561397750a069f5536fda66843ace4 bindata-filename.patch
6f3f30e5c9d9dd5117f18fce0e669f0cd752a6be4910405d6b394f15273372731ee887a5ba4c700293e5b8bc2bf40fd69d4337156f77b03549d2dc2c0a666bec vault.confd
8c064aa5dcca84822c1fa85e9d0ff520df46f794b2e9c689a9b4f81f74279387b3aebc08b3ca26cf786c2fcf1a330e765bf5a511074c24f87e5346672346ba1c vault.hcl
1e436932647b191e691f5c60bec4ad926588cee5119c7cbe61345249a6768472387b6dd8b19b954c8ac80fb97f6e68f93749229b216300b0438dbeb0bdb57957 vault.initd"
diff --git a/testing/vault/bindata-filename.patch b/testing/vault/bindata-filename.patch
new file mode 100644
index 00000000000..f48f76860d1
--- /dev/null
+++ b/testing/vault/bindata-filename.patch
@@ -0,0 +1,14 @@
+This patch removes the custom output name option that is handled properly only
+in the master branch of go-bindata-assetfs (see https://github.com/elazarl/go-bindata-assetfs/pull/32)
+diff --git a/Makefile b/Makefile
+index 8a72e5f70..4055122f4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -118,7 +118,7 @@ update-plugins:
+
+ static-assets:
+ @echo "--> Generating static assets"
+- @go-bindata-assetfs -o bindata_assetfs.go -pkg http -prefix pkg -modtime 1480000000 -tags ui ./pkg/web_ui/...
++ @go-bindata-assetfs -pkg http -prefix pkg -modtime 1480000000 -tags ui ./pkg/web_ui/...
+ @mv bindata_assetfs.go http
+ @$(MAKE) -f $(THIS_FILE) fmt