aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/xdg-utils/APKBUILD21
1 files changed, 5 insertions, 16 deletions
diff --git a/main/xdg-utils/APKBUILD b/main/xdg-utils/APKBUILD
index 9b73d6c9b5c..d8c1402369e 100644
--- a/main/xdg-utils/APKBUILD
+++ b/main/xdg-utils/APKBUILD
@@ -2,32 +2,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xdg-utils
pkgver=1.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Basic desktop integration functions"
url="http://portland.freedesktop.org/wiki/"
arch="noarch"
license="MIT"
depends="xset xprop"
-makedepends="libxml2-utils libxslt xmlto links"
-install=
+makedepends="libxml2-utils libxslt xmlto lynx"
subpackages="$pkgname-doc"
source="http://portland.freedesktop.org/download/xdg-utils-$pkgver.tar.gz
xdg-screensaver-mv-T.patch
"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg "$i"; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,7 +29,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}